Cannot open control panel / rundll32 problem

By stereosteve
Sep 22, 2006
  1. Hi everyone,

    Excuse my ignorance over this (I'm a bit of a novice), but I can't access any of the options in my Windows XP control panel.

    Having read through the forum, I noticed a couple of other people have experienced the same problem. Whenever I click on, say, add/remove programs, an error message reading "c:\windows\system32\rundll32.exe : this file is being used by another program" flashes up.

    I've tried following the trojan pre-removal advice (very helpful btw), but I can't turn off system restore as I can't get into the system option in control panel!

    I also tried running a ewido scan in safe mode but the computer froze up. I've even tried replacing the dll file with a downloaded version (as mentioned in another thread), but no joy.

    As far as I can tell, it started when I installed the latest iTunes (which was a big, big mistake on so many levels!).

    I have attached a hijackthis log, but again I'm a novice and I don't know if I did it right.

    Sorry for waffling on and thanks in advance,

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Hello and welcome to Techspot.

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).


    Close task manager.

    Run HJT with no other programmes open. Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page =

    O4 - HKLM\..\Run: [AlcxMonitor] ALCXMNTR.EXE

    O8 - Extra context menu item: Search with Wanadoo - res://C:\PROGRA~1\Wanadoo\WSBar\WSBar.dll/VSearch.htm

    O16 - DPF: {3A7FE611-1994-4EF1-A09F-99456752289D} -

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or directories(if there).

    ALCXMNTR.EXE Search your system for this file and delete all instances of it.

    Other than the above, your HJT log is clean.

    I believe your problem is caused by installing the new itunes programme. It is known to be very buggy and can cause many problems. See HERE for more info. There are links in the article to some possible fixes.

    However, if none of them work for you, it might be a case of backing up your important data and reformatting.

    Regards Howard :wave: :wave:

    This thread is for the use of stereosteve only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...