Cannot Run Two Optical Drives on one IDE Chain Anymore, Whats Wrong?

By ronny ยท 7 replies
Jun 2, 2005
  1. :mad: I am getting so sick of this computer. I would consider myself to be a somewhat advanced computer user, but I just have no idea whats goin on here.

    Here's the problem:

    I have a Compaq S3310OM which I have 2 (IDE) Hard Drives on one IDE Channel and on the other I have had 2 (IDE) Optical Drives (a DVD Burner and the DVD-ROM Drive that came in the computer). The two optical drives worked for 1 1/2 years then all the sudden they decided to not work together. I messed around for quite some time with it trying to get them to work together with no luck. I dual boot with on being XP Pro w/ SP2 and the other being Windows 2000 PRO. Both operating systems including the BIOS will not pick up on EITHER of the drives when they are hooked up on the chain together. I went from Cable Select to choosing a master and a slave and even tried switching the IDE chains with the hard drives incase it was a Motherboard Issue, however the Hard Drives still worked fine but the optical drives wouldnt fire up. At that point I figured that it must have been something to do w/ the drive that came with the computer so I switched it out w/ a DVD-ROM that I had in another PC. Voila! This worked, or so I thought. About a week to a week and a half later that drive started acting up and would occasionaly not read discs then lead to it not working with the burner as well. So then I thought I'd try the two DVD-ROMs togehter and they would not work together either. It was this point that I went looking for firmware updates for the MOBO and I also completely formated my PC and am now running a clean install of Windows XP Pro and still, none of the drives will work together. I cant figure this out. I have tried everything that I can think of but have gotten nowhere. Hopefully someone here can help me out. What could be the possible causes of my troubles?

    Thanks in Advance,

  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    welcome to techspot.
    your computer is oem (original equipment manufacturer) and there will be problems like this, with seemingly no cause. attempt operating them on seperate chains (attach one to the primary chain, with the boot hard drive as master)
  3. Grok451

    Grok451 TS Booster Posts: 85

    Looks like you tried all the right things. . . How about something really simple, maybe? Try using a different cable?
  4. Bobcat1132

    Bobcat1132 TS Rookie Posts: 79

    its a long shot but maybe could be a solution how big is your hard drive and how old is it? it could be that maybe it has just been worn down and will no longer give out the power that it needs to give out? also you could check your irq's see if something somehow got mixed up there? sorry
  5. ronny

    ronny TS Rookie Topic Starter

    Hey guys,

    I really appreciate the quick response, and I have tried to think of the simple things. I did change the IDE cable (twice to be exact) and yes it is OEM which sucks cuz I cant just buy a new motherboard to put in it, I'll have to move all my components to a new case/mobo/processor combo which I'm hopin I dont have to do. I was just hoping that its something simple I missed....

    Many Thanks,

  6. Grok451

    Grok451 TS Booster Posts: 85

    Another way to go. Instead of going the new mobo route, etc. How about getting an external drive enclosure that connects via USB or Firewire? Hopefully, that will work for you.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    As OEM PCs tend to have low-end components, it may be something as simple as a powersupply that no longer gives enough 'juice'.
    If each drive on its own works, then they are not the problem.
    Borrow someone else's (more powerful than your) powersupply and see what gives.

    Another point to check is air-circulation, you might need an extra fan in the rear, to keep things cool.
  8. ronny

    ronny TS Rookie Topic Starter

    Thanks guys, I have thought about the External Enclosure w/ a USB to IDE cable, however I was hoping that there would be some way to keep things internal. I was really hoping that it was just something that I was forgetting... but that does not seem to be the case!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...