Can't get some websites to load

By jam_scot
May 20, 2014
Post New Reply
  1. I am using Windows 8 64-bit and I am having an issue loading certain websites. Twitter and Facebook are the main two. I have tried Chrome, Firefox, IE, Chrome portable, Firefox portable and qupzilla portable. I tried using https as well. loads but once I enter my login details it just comes up with "problem loading page" again. I have run Malwarebytes and SUPERantispyware I have cleared cache's etc and nothing seems to be helping. Any help would be greatly appreciated as I'm almost at my wits end with it.
    I should add I've reset my router, restored factory settings but they seem to work on other devices (android phone, old laptop etc).
  2. oliverpowell

    oliverpowell TS Enthusiast Posts: 26

    Check and make sure that time/date settings were accurate in your computer. If the problem still persists, try uninstalling Firefox/Chrome and install it back again.

    Post back for further help!!
  3. jam_scot

    jam_scot TS Rookie Topic Starter

    Hello, thanks for the response.
    I've tried this and it doesn't make any difference. I should mention it only appears to be the www. version of the websites. I can access for example. This is very frustrating as most log in's mirror to www. I have even experienced this issue signing into some of the Google log in pages.
  4. learninmypc

    learninmypc TS Evangelist Posts: 7,999   +513

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...