CD-RW doesn't erase

By cairo ยท 4 replies
Apr 7, 2004
  1. Hello,
    I have a LG 24x10x40x a MITSHUBISHI 650MB CD-RW.

    I tried to erase the existing contents of this CD-RW. In Windows Explorer, I right clicked on the CD-RW drive and choose erase this CD-RW. It works like normal, a bar notifies percentage of the work. Finally, it said all done.

    However, the problem is my CD-RW is actually not erased at all. The existing content is still there.

    This should not be the CD-RW disk problem, because I have tried different brand of disk. and all 650MB CD-RW disk cann't be erased properly.

    The strange thing is while I tried to erase the content in a Verbatim Pocket CD-RW 185MB, it works!

    I dunno what happens.

    Please advice.

    thank you.
  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Is the only burning software you have the windws built in software?
    Try using something such as Nero. You might get a better result with that.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Are you actually able to burn CDs with this CDRW?
  4. OS samurai

    OS samurai TS Rookie Posts: 159

    Also do you have a quick erase & full erase option? If so be sure to try full rather then quick erase. I would try a fCD burning program like Nero. It has worked great for me:D or maybe a free program like CDBurnerXP Pro which you can find here
    StormBringer was correct clonecd is not free sorry for the :confused:
  5. StormBringer

    StormBringer TS Maniac Posts: 2,244

    CloneCD wasn't free last time I checked.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...