Compaq Presario R4000 will only boot for less than a second

By deluxman ยท 26 replies
Dec 17, 2007
  1. I have the above laptop and recently I had problem with it being the fact that it will not boot properly. Each time the power button is pressed, it will only try to boot for less than a second and it will shut off again. I have tested the ac adapter and it appears fine. A few of my friends said it could be a motherboard problem. Has anyone had this issue before? I was wondering if anyone knows exactly which part of the motherboard that is faulty so that I do not have to replace the whole motherboard.

    Any suggestion or inputs in resolving this will be greatly appreciated.
    By the way, everything is standard, has not been modified or changed.

  2. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Less than a second huh ...

    I/O board or motherboard problem would be my guess
  3. deluxman

    deluxman TS Rookie Topic Starter

    What do you mean? CAn you elaborate a little bit? and is there a simple way to fix it?
  4. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    I can try to help you troubleshoot it if you would like:

    1. Remove the battery and AC adapter from the notebook.
    2. Remove any optical disks (CD or DVD), and disconnect any external devices or peripherals such as USB devices, printers, docking stations etc.
    3. Plug the AC adapter directly into a functioning wall socket.
    4. Press the Power button to turn on the computer.

    After the battery, optical media and peripherals are removed, the Notebook PC may startup normally
  5. deluxman

    deluxman TS Rookie Topic Starter

    Yes, it is staying on right now and this is message I got on the screen:
    NTLDR is missing
    Press Ctrl+Alt+Del to restrart

    What do I do next?
  6. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  7. deluxman

    deluxman TS Rookie Topic Starter

    So r u suggesting that it is the BIOS issues? I went to the website you gave but it does not seem to have the most recent BIOS version. I wonder if I should go ahead and update it.

    By the way, with your suggestion to remove the CD ROM and battery, it worked and then I tried putting back the CD ROM and trying to reinstall windows since I had a new drive. However, while it is trying to setup, the computer just shuts itself down. What could be the issue now? I had the laptop cleaned already so there should not be any dust preventing the heat to be released. Could it be because I had the CD ROM inserted?

    I really could not start the computer since I do no have a drive that is installed with the operating system. I had bare drive in the laptop right now.

    Please advice!
  8. deluxman

    deluxman TS Rookie Topic Starter

    Last update, I had all the CD ROM and battery removed but the problem appears to be the same again, that is it keeps shutting down in less than a second. What could be the issue here now?
  9. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Did you go into BIOS and change the boot order before attempting reinstalling windows?
  10. deluxman

    deluxman TS Rookie Topic Starter

    I did not change the boot order but it was able to read the CD in the CD ROM but the problem is now, even though I had all the CD ROM removed and the battery, the problem is still back that is it keeps shutting off in less than a second.
  11. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    If you are attempting to run the install from the CD-ROM make sure the CD-ROM is the first boot device, and not the hard disk drive.

    I was going to have you try a repair function but I'm suggesting this as you already tried to reinstall
  12. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    1. Remove all external devices and media. Be sure to check the optical drive, flash memory slot and the floppy drive (if available).
    2.Restart the computer by holding down the Power button for 5 seconds. Then release the Power button and press it again briefly to turn the computer on.
    3.When the power light turns on, press the F10 key on the keyboard to enter the system BIOS menu.
    4.Press the F9 key to reset the BIOS defaults. Then Press the F10 Key to save the changes and restart the computer. Press the Enter key when prompted to save the changes.

    If after performing steps 1-4 Windows does not startup properly, then the hard drive needs to be tested using the following steps.

    Option 2: Test the Hard Drive
    Use the steps below to test the hard drive in a Notebook PC using the HP Hard Drive Self Test.

    Plug the AC Adapter into the Notebook PC.
    Press and Hold the Power button for 5 Seconds to turn off the PC.
    Press and hold the F10 Key . Then Press the Power button to turn on the PC releasing the F10 key after text is displayed on the screen of the PC.
    After the BIOS Setup Utility is displayed, use the Right Arrow key to select the Tools menu.
    Select Hard Drive Self Test
    Press the Enter key to start the test.

    The Hard Drive Self Test will provide an Estimated test time . A Quick test a Comprehensive test and a SMART test will execute when the Enter key is pressed.
    If any test fails , contact HP service and support for instructions on how to order a replacement hard drive.
  13. lamo

    lamo TS Rookie

    deluxeman, this is not software problem. this is hardware problem. one thing i can suggest, is overheating and automatic shutdown. try to disassembly your laptop and check out heatsink(including thermal paste, and cooler).

    second. if you receive message "NTLDR is missing" so the problem may be in corrupt HDD sectors, or invalid MBR.

    to those people who give advice to check bios settings, cd-rom connectors, etc. people, if you don't know, don't speak.
  14. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    First of all why dont you read this before criticizing my response

    Second, you are correct about the error code -> why do you think I put up instructions on how to test the HDD. Another option I didn't get to yet is attempting to reseat the RAM.

    Also, the last option you would want to attempt is to fix the MBR because running the fix could cause all the partitions on the current hard disk to become inaccessible.
  15. deluxman

    deluxman TS Rookie Topic Starter

    Thanks guys for the input. It works now and it appears that there is a loose socket connector around the dc port. Does anyone know where I could get a cheap used/new ac adapter for my Presario R4000?

    Please email me if anyone has it.

  16. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  17. lamo

    lamo TS Rookie

    deluxman, the problem may be not only with ac adapter, but with dc connector on the laptop MB.
    and, you didn't say if your laptop charges the battery or not. if it charges, so the problem may be with bad BGA soldering of some chips. if no - the AC adapter or mainboard dc connector may be corrupt.
  18. deluxman

    deluxman TS Rookie Topic Starter

    Yes, you are right...there must be something wrong with the motherboard or the DC port. I have been using this laptop now for 2 days and this is what I found. Every time I used it for say about over 15-20 minutes, the power light on the computer will start blinking and so is the power button. It appears to me that the battery is not charging since it keeps going down even though the ac cable is plugged in. However, if I were to shut the computer down for a little while and plug the ac cable back in, then it will start charing normally again. Do you know what is wrong here? My guess is either the AC adapter or the DC port but really it only acting up when it has been used for a while.

    Any idea which part I should replace?

    BTW, I think the BGA chips on the memory is fine. My guess is either the AC adapter or the AC port on the motherboard. Any other idea or suggestion is greatly appreciated.
  19. deluxman

    deluxman TS Rookie Topic Starter

    Hello tech guys out there!!
    It has been a while since I posted this thread. I was able to replace the DC jack with a new one but the problem still not solved. Everytime I had used the laptop for about 10-20 min and if I plug the ac adapter, the ac light will be blinking and not charging but if I were to shut off the computer and plug the ac, it will charge but sometime it won't. It is really weird. Any ideas or suggestion will be greatly appreciated.
  20. lamo

    lamo TS Rookie

    deluxman, it can be problem with battery, or with laptop charging system. find the program called MobileMeter or Battery Monitor and check for parameter named "charge rate". it should be 23Wh or something else. also you'll need to check the increasing capacity of the battery. you can do it using these programs.
  21. deluxman

    deluxman TS Rookie Topic Starter

    I will try that and let you know the result. thanks though!
  22. deluxman

    deluxman TS Rookie Topic Starter

    I have an interest finding. Laptop is not charging the battery when on, charging light & on/off button light are blinking but when shut off, charging light is on permenantly. Any idea folks??

    At first, I thought it was the ac jack that had the problem but now looking at the above scenario, I really thought something is not right inside but I doubt it is the ac jack since I already replaced it.

    My guess is either the ac adapter...but could be something in the motherboard which I have no idea how to detect it. Please provide any input you tech guys out there.

    Thanks a bunch!!
  23. lamo

    lamo TS Rookie

    check this thing: turn off laptop, connect AC adaptor and let the battery charges for 10 minutes. after this, turn on laptop, and check if the battery percentage has increased. if so, thenm i suspect bad AC adapter(i.e. it can't give enough current to laptop).
  24. bozzy

    bozzy TS Rookie

    blinking power lights/battery not charging

    Hi deluxeman, I see we have a similar problem. My Presario r4000 boots for 1 sec then goes off. when it eventually stays on the power light blinks...just exactly as you described yours.
    I just wanted to know if you have solved yours and how. I was told my motherboard is bad and should replace the entire thing which i do not agree with.
  25. lamo

    lamo TS Rookie

    bozzy, why don't you try to replace AC adaptor first?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...