Compaq V6000 won't charge

By sungar
Mar 22, 2009
  1. I have a Compaq Presario V6000 that's worked (relatively) fine for several years. Over the last couple of days, when I plug the power cord into the laptop, it doesn't act like it's plugged in (runs off of battery, and the charge light doesn't come on.) If I move the cord around and get it in just the right place and hold it without moving, I can get it to charge. I tried a different power cord and it still doesn't work. Has anyone ever had this issue with a V6000 or similar system?

    I talked to someone that said on some laptops the power plug comes unsoldered from the motherboard after repeated use. If this is the issue, it's probably not worth having someone else fix it vs buying a new system (quote was ~$200-400 to repair). I'm willing to give it a try under the "it can't get any worse" theory. Have you ever opened up a V6000 - any tricks needed?

    Thanks in advance.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...