Computer won't connect properly to a wireless network

By kritonas ยท 9 replies
Apr 15, 2005
  1. Hello,
    I am running a belkin router, if i'm not mistaken the model is f5d7630uk with belkin pci wireless cards which i think is f5d7001.

    My problem is that I had to change my setup yesterday, and move the router. One of the pcs that was connected with a wire to the router now connects wirelessly, i've installed one of my pci cards on it. Everything works as before on my other wirelessly connected computers, but that particular pc wont access the internet.

    It tries ages to get an ip from the DHCP server of the router, and it wont take a proper ip(198.168.*.*) and finally it will assign one to itself(169.*.*.*) .
    Oh yeah and during the connection to the network, the computer sends a lot of data, but receives nothing at all. I think when the DHCP process finishes(failed) i get the "limited connectivity" messsage from windows.

    The strange think was when i tried to assign it an ip on my own (ie, it couldnt connect to the internet, but it could load the router's configuration page. But in the configuration page, i could see that the router assigned to that computer(or at least tried)

    Oh well, my other pcs are working just fine with the wireless network, and i can't understand why that happens with that particular one.

    Hope someone can help,
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Did you set the encryption right?
    Any MAC or packet filters?
    How about the distance/interference?
    Any firewalls on the PC?
  3. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    windows sais very good reception, belkin software sais good to very good (because it considers noise as well)
    No, nothing.the only firewall on the network is the router's firewall which is between the lan and internet.

    thanks for the fast reply:)
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You could try connecting with Windows instead of the Belkin utility or vice versa.
    How about driver versions?

    Did/does the same wireless card work in another computer?
  5. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Done that before, same thing..

    the ones supplied on the manufacturer cd

    yep, same card with the same drivers works fine on another computer.

    thanks for your patience!
  6. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I tried collecting some more details and here's what i've got:

    -The pc with the problem detects the network and tries to connect to it.
    -The router receives the request, and assigns an ip to it(or at least tries). I can see that in the DHCP clients list.
    -At that point, the pc's wireless connection status still displays "0" received and tries for a lot of time to gain an ip from the dhcp of the router, with no luck and it assigns a 169.*.*.* ip to itself.

    The problem lies to the fact that the pc won't get the router's packets.
    Why does that happen? I've double checked the encryption settings and passwords, tried without encryption, and still nothing.
  7. swker98

    swker98 TechSpot Paladin Posts: 1,077

    did u try to reset the router by unbluging it and pluging it back in, because i got the same message and i unplued the router and pluged it back in and it worked fine, i also unpluged the cable mode, , p.s im on a wired network
  8. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Yep..nothing happens, same thing..I can't understand why, other 3 computers work fine and that computer just can't receive any data, only send...
    Any ideas guys? somebody must know something more than me..
  9. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I found the problem. I figured out that since that pc was connected with a wire to the router before i changed the setup, maybe the router was receiving the stuff by wireless now, but tries to send back through the wire. doesnt make much sense, but it was the most logical thing i could think of.
    so i just reset the router to factory settings and all the computers can connect to the router and internet now..
  10. SoopahMan

    SoopahMan TS Rookie

    Thanks very much for posting this, I ran into this exact same problem with a Boot Camped Apple laptop (so, no support available!). The oddest part is that I had connected it varyingly between Ethernet and Wireless without issue, until I attempted to pair it unsuccessfully with a Bluetooth phone (to use its Edge connection on the laptop). It seems finishing the Wizard for setting up that connection initiated this problem on the laptop.

    But, unplugging my SMC Barricade Router and plugging it back in resolved it. How strange.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...