Tech Stocking Stuffers: 18 awesome gifts under $50

Constantly reoccuring CHKDSK errors

By old jc ยท 10 replies
Jun 13, 2007
  1. Every few days I run Chkdsk within XP and it tells me its found errors on the drive. I tell it to run at startup to fix the problem. This usually works for a couple of boot cycles, but then the problem occurs again. I let Chkdsk fix the problem again, but it only fixes it for a little while again. Eventually Chkdsk reports errors with the MFT. Once this happens it's not long before I can't boot XP.

    A typical example of the event log is:

    Checking file system on C:
    The type of the file system is NTFS.

    A disk check has been scheduled.
    Windows will now check the disk.
    Cleaning up minor inconsistencies on the drive.
    Cleaning up 38 unused index entries from index $SII of file 0x9.
    Cleaning up 38 unused index entries from index $SDH of file 0x9.
    Cleaning up 38 unused security descriptors.

    195350368 KB total disk space.
    4740252 KB in 22676 files.
    10036 KB in 1554 indexes.
    0 KB in bad sectors.
    96360 KB in use by the system.
    65536 KB occupied by the log file.
    190503720 KB available on disk.

    4096 bytes in each allocation unit.
    48837592 total allocation units on disk.
    47625930 allocation units available on disk.

    Internal Info:
    d0 5e 00 00 b1 5e 00 00 75 6b 00 00 00 00 00 00 .^...^
    56 51 00 00 00 00 00 00 4f 02 00 00 00 00 00 00 VQ......O.......
    2e e3 c5 00 00 00 00 00 5a 13 0b 19 00 00 00 00 ........Z.......
    0e 54 38 01 00 00 00 00 00 00 00 00 00 00 00 00 .T8.............
    00 00 00 00 00 00 00 00 0e 40 99 22 00 00 00 00 .........@."....
    99 9e 36 00 00 00 00 00 98 3a 07 00 94 58 00 00 ..6......:...X..
    00 00 00 00 00 70 52 21 01 00 00 00 12 06 00 00 .....pR!........

    Windows has finished checking your disk.
    Please wait while your computer restarts.

    (I've looked in the Windows folder and searched the c drive, but unfortunately can't find the minidump folder)

    In case it's relevant Event Viewer reports a warning after each shut down - event id 1517 - "Windows saved user JAMES-DESKTOP\James registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use."

    On previous installations of XP on this pc I've installed the user hive clean up program from Microsoft, but it didn't seem to improve the chkdsk issue.

    The only other warning in event viewer is event id 5603 - "A provider, Rsop Planning Mode Provider, has been registered in the WMI namespace, root\RSOP, but did not specify the HostingModel property. This provider will be run using the LocalSystem account. This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests. Ensure that provider has been reviewed for security behavior and update the HostingModel property of the provider registration to an account with the least privileges possible for the required functionality." From what I've picked up from various searches this is probably unimportant though.

    I've tested the HDs using Western Digital's diagnostic software and found no errors. I've tested the memory using memtest and found no errors. I've updated every peice of software I use. I've written zeros to the whole boot drive, fully formatted it as NTFS and reinstalled XP with nothing else but Zone Alarm and still get the errors. I even tried using nLite to create an XP installation disk without Internet Explorer.

    I've had the same problem for many months, but it's now really important that my system is stable. Despite spending several hundred hours searching google I've not found a solution that works, which is why I'm making my first ever post on a PC forum.

    Your help would be greatly appreciated.
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    PM howard_hopkinso or momok and ask for this to be switched to spyware section and particularly ask for help re root infections.

  3. old jc

    old jc TS Rookie Topic Starter

    Will do. Thanks CCT
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    try running crap cleaner instead of chkdsk. USe the registry repair tool.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    I had this problem once and it turned out to be the RAM that was faulty and there was nothing wrong with the HDD.
  6. old jc

    old jc TS Rookie Topic Starter

    Surely if the root of the problem were the registry then it would have been resolved by reloading windows on to a clean drive?
  7. old jc

    old jc TS Rookie Topic Starter

    Thanks for the lead Phantasm. I'll run memcheck again this afternoon
  8. jobeard

    jobeard TS Ambassador Posts: 10,856   +901

    YES! I too ran into this; memory errors mascrade as HD errors.

    Also frequent PFN_LIST_CORRUPTION stop codes were present and this lead
    to the understanding.

    I was able to run memtest as an application (ie not a boot-time program)
    and it discovered the issue quickly.
  9. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Yes... Kernel gets errors reading from file system because RAM is faulty... but thinks its a disk problem.

    So, it tries to fix the disk problem. So it reads good data, but gets bad data from RAM. So it thinks the file system is corrupt. So it runs chkdsk and basically screws your file system trying to fix the file system.
  10. jobeard

    jobeard TS Ambassador Posts: 10,856   +901

    Install Everest Home Edition and see the Storage->SMART

    If the drive supports the SMART feature, then true errors will be recorded
    in changing values.
  11. old jc

    old jc TS Rookie Topic Starter

    I ran memtest over night and after 29 passes it still hasn't found any errors. I couldn't find any info on running it as an app. Do you think it might detect errors it would otherwise miss if I were to run it within windows?

    Although neither of my drives support SMART, so I can't be entirely confident they're working ok, I have tried installations on both and had the same problems. The full WD diagnostic test didn't find anything either.

    I've installed Everest and everything seems to be normal except for +5V standby voltage. I've no idea what uses this, but it it's fluctuating by about 0.5V and averaging at about 3V.

    I've given up. Although I'm fairly confident I've ruled out all the software causes, there's still several possible hardware ones. I could spend a fair bit of time and money swaping out each individual component, but specing a new system is going to be a lot more fun (and hopefully a fair bit quicker).

    Thanks to Phantasm, Jobeard, CCT & Tedster for your help. It was much appreciated. It's good to know I've had a fair crack at trying to fix the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...