Could not clear DNS cache. Atheros AR5005G

By appolloburning · 13 replies
Apr 7, 2007
  1. Hello, I'm new in these parts.

    Got a problem with a Toshiba Equium A100 and its Atheros AR5005G Wireless network adaptor.
    Been trying to sort it for ages and have found no help anywhere online.
    I have narrowed it down to there something being wrong with the DNS.
    I can connect to the wireless network fine, but wont resolve DNS.
    When repairing the network i get a 'Could not clear the DNS cache'
    I have tried running ipconfig/flushdns in Command Prompt but function failed during execution.
    I have unistalled the atheros client and drivers, and then installed them after downloading form toshibas support site, but still get the same problem.

    Would be very greatful of any help!

  2. tek8

    tek8 TS Rookie

    It may sound like a faulty Wireless adaptor, but I do doubt that is the case. can you tell me the exact error message you get when trying ipconfig /flushdns

    also, can you tell me if you have any DNS records, by doing ipconfig /displaydns

    also, make sure DNS is set up on your router, and your router is also your dns server (if DHCP is set up on your router, it should automatically do that).

    thats all the help i am able to give without knowing more, sorry.
  3. appolloburning

    appolloburning TS Rookie Topic Starter

    DNS is fine on the router. and DHCP is set up. I have 2 other computers a ps3 and an xbox 360 that all work ok with it.
    Using a netgear DG834G router, and each machine has an IP address reserved on the router.
    The only error meagge i get in cmd prompt when i try to flush dns is:
    'Function Failed During Exexution'

    Thanks for trying.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    First, flushing the DNS cache is a local operation and has nothing to do with how your network is set up or even whether you have any network at all.

    Does networking work for you in general? Like if you use a wired connection, everything works fine?

    Maybe try Winsockfix?
  5. appolloburning

    appolloburning TS Rookie Topic Starter

    Networking does not work at all on the laptop.
    Only just tried it wired, but that does not work either, and the ethernet adaptor is a different one from the wirless adaptor. so i figure its something computer side.
    I tried running Winsockfix on it but that has not helped, just made XP run scandisk when it rebooted.

    What on earth could it be?
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    No, winsockfix shouldn't do any scandisk stuff.. It just resets all the Windows networking stuff.

    Looks like something is very broken in Windows or hardware wise..

    Test your RAM and the hard drive with the manufacturer utility?

    Format and reinstall Windows? (I know that's not real advice, but if Winsockfix couldn't get it..)
  7. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    First, verify your hardware/drivers are functioning correctly;
    use the Device Mgr and expand the Network Adaptors.
    There should NOT be any yellow or red marks. If there are,
    investigate your drivers.

    Second, get your networking setup to work using a wired connection to the
    router -- much easier. This post will assist you in testing the config

    Lastly, while still wired, use your browser to access the router config and
    setup the SSID, new password, channel (leave encryption off, come back to it later).

    Now you should be able to unplug the cable and go wireless successfully.

    Once you're at this point, you can WIRE the connection again and config
    the encryption
    and uncable again to prove you can connect.
  8. appolloburning

    appolloburning TS Rookie Topic Starter

    Cheers Jobeard,
    Drivers are working fine,
    Tried to get it working wired, using the post you listed for reffrence, as follows

    Using a router will change your tests 1,2,3,4 as follows
    1:- First, PING (the nic card itself) no change here Successful
    2:- PING (your LAN ip address)[*] Failed
    3:- PING (your router/gateway address)[*] Successful
    3:- PING aaa.bbb.ccc.101 (your public ip address) Successful
    4:- PING Failed

    EDIT:Also tried to Ping the computer from the router and got no response.

    any ideas?!?!
  9. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Give that network wireless card a static IP address once you see it listed in the DHCP Client table in the Router. Does the Router see the wireless nic?
    Are you using WEP 64-bit or 128-bit for security protection?
    Make sure all the password are setup correctly on wireless router and wireless nic adapter.

    Try pinging sometimes acts up when you try to ping it.
  10. appolloburning

    appolloburning TS Rookie Topic Starter

    Tried that, the router can see the wireless nic, Wep encryption is at 64bit and passwords are correct, but it wont work wired either.
    the Wired and wirless cards are seperate, so i'm figuring its a windows based problem. Just dug out my discs and im about ready to format and re-install!!
  11. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Are you using Windows XP Pro SP2 Wireless Connection or Third Party (the one that comes with the wnic)? I find the one that comes with your wnic doesn't hold up as the one that comes built-in SP2.
  12. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    >Using a router will change your tests 1,2,3,4 as follows
    >1:- First, PING (the nic card itself) no change here Successful
    >2:- PING (your LAN ip address)[*] Failed

    make sure this is your system's address (ipconfig will show it)

    >3:- PING (your router/gateway address)[*] Successful
    >3:- PING aaa.bbb.ccc.101 (your public ip address) Successful
    >4:- PING Failed

    the above says your settings are good for TCP-IP, but you're failing on
    getting the DNS address!

    When you set DHCP active, make sure it's both IP and DNS.
    ipconfig /all
    will show
    1. your ip address
    2. your gateway (which is your router address)
    3. one or more DNS addresses
    The DNS addresses should be from your ISP, but it is not uncommon
    to see your router here too. In that case, you'll see the real DNS addresses
    in the router WAN side details.

    btw: google is at
    so you can ping
    and then follow up with nslookup
    to show that your DNS can be found and return an address (my be different)
  13. appolloburning

    appolloburning TS Rookie Topic Starter

    So, i burned a dvd with all my data that i wanted to keep and had my discs out ready to re-install windows.
    When i had a brainwave.....
    Turned off windows firewall, and BANG! connected.
    checked through the registry, and an old version of Norton antivirus was still lingering.
    once i removed that, then i can connect with no problems.
    have since installed a proper firewall and all my problems are gone.

    Thank you to everybody who tried to help!!
  14. Justop

    Justop TS Rookie

    hi, toshiba laptops have a wifi switch on it, you need to turn it to ON. I think you install that adaptor yourself right? if you can not get it to start then it won;'t work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...