D-Link DI-624 doesn't work

By cronaldodm7
Aug 20, 2009
  1. yea so i just switched internet providers to comcast...yay... and i hooked the modem up and everything. now i had a d link DI-624 router connected to my previous provider internet and it worked fine now i tried to connect it to comcast adn it keeps messn up. i run the cd do as it tells me shut modem off then plug it bkac in adn start router and nothign =[ then they tel lme to restrat comp so i did and i restarted it adn still nothing i cant find the right connection it keeps finding a public connection. im 100% sure im doing everyting right cuz im not retarded bu the damn thing just wont connect to my network wtf??? can ne1 help. pleaseeee id rele appreciate it

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Totally uninstall the DLink. Use a registry editor. Start over.
    That is a rock-solid unit. Some of your settings have to be incorrect. It is easier to start from scratch, than to troubleshoot.
  3. cronaldodm7

    cronaldodm7 TS Rookie Topic Starter

    ..ok but ok look....old provider i had router hooked up got new comp ...alien ware =]....hooked it up by just switching cables...router works..makes me and my ps3 happy....no new provider comes and the **** doesn't work. so that means that no cds were installed previously and it still worked ...but ok....so i put the cd in tells me step by step instructions shut modem of connect cables turn modem back on and so on i do it and still no network connection it finds a network but its a public one thts not mine adn i cant change it i fkn hate vista it makes it all confusing adn **** but w.e. u said registry editor? whts that and how does it work
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...