Deleting something still shows until I refresh the folder

By MaXtor ยท 6 replies
Sep 9, 2009
  1. As the title says: If I delete something (in a folder, on the desktop, anywhere) it doesn't disappear by itself, I have to manually refresh for it to update... of for example if I extract an archive, the newly created folder doesn't show until I refresh the folder (or close and reopen it).

    I'm using Windows 7 Ultimate x64. This problem just started happening a few hours ago. I have no idea what caused it, I was just trying different virtual drives at the time (Clonedrive, MagicDisk, Alcohol 120, Daemon Tools, etc).

    Anyone know how to fix this problem, it's really annoying.

    edit: and yes I've uninstalled all virtual drives, didn't fix it. :/
  2. superty12

    superty12 TS Enthusiast Posts: 413


    Sorry, but it is a pre-release. Tell Microsoft about the problem.
  3. MaXtor

    MaXtor TS Booster Topic Starter Posts: 149   +39

    I understand it's a pre-release, but I don't think that's the issue. It looks to me like I may have a virus of some sort. I'm guessing this since I can't open System Restore (it says starting, then never starts, I left it for an hour). I scanned with AVG and SuperAntiSpyware but didn't find anything, I think I'll install a couple more anti-viruses and maybe a couple more anti-spywares to be sure.

    Hopefully I'll be able to fix it. Although before that I think I'll do some googling concerning the issue of not being able to open System Restore, if both issues are caused by the same thing, maybe I'll find an answer. *crosses fingers*
  4. MaXtor

    MaXtor TS Booster Topic Starter Posts: 149   +39

    Looks like I solved the issue. I ran a spyware scan with Malwarebyte's Anti-Spyware and it found the registry entry "NoActiveDesktopChanges". I let it delete the entry as was recommended, restarted my computer, and voila. Everything looks to be back to normal, I'm not 100% sure if that was what fixed it or if it was one of the other things I did (disabled services, disabled all startup items, disabled all visuals, uninstalled a few programs).

    I'll start re-enabling things and see if the problem recurs. Hopefully the problem was caused by that registry entry.
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Did you get the System Restore capabilities back?
  6. superty12

    superty12 TS Enthusiast Posts: 413


    Yeah, that entry would be it.
  7. MaXtor

    MaXtor TS Booster Topic Starter Posts: 149   +39

    Yes. Everything went back to normal. Only thing that was a little odd is that I know for a fact I created restore points. I opened System Restore to find absolutely no restore point. That made me kind of paranoid, thinking I did or do have a virus that deleted them. I've continued to search for viruses and spyware, haven't found anything. Been monitoring my connections with tcpview to make sure I'm not trojaned, looks fine. So at this point I'm left rather confused.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...