1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Dell 1520 Limited or no connectivity - can't renew IP Address

By BritB887 ยท 8 replies
Jan 7, 2009
  1. Hi,

    My laptop all of a sudden will not connect to the internet. After attempting to connect- it has a full signal but I get the "Limited or no connectivity. You may not be able to access the internet" message. When I try to repair the connection, it says that it can not renew my ip address.

    I have a linksys router that I've reset a couple times and also reset the computer... doesn't work. I figured it's an issue with my computer and not the actual connection, anyway, since it seems I can not connect to ANY wireless network now without getting this error.

    This has happened before but usually is resolved by rebooting, repairing, or resetting the router.

    I have a Dell 1520 running on Windows XP. It has a Wireless 1395 WLAN Mini Card.

    I've run diagnostics and everything seems to be passing. I can't find any obvious reason why this isn't working. I've even updated the drivers for the MiniCard and anything else i could find that it may possibly be but have had no luck.

    Possibly a problem with windows?

    If anyone has any clue, please let me know what you think before i try to have Dell fix it for me and it end up being something I could have done myself....

    Thanks in advance!
  2. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Have you tried a total new install of the mini card and linksys, after totally deleting or erasing the currently installed stuff then using a registry cleaner such as CCleaner?
  3. BritB887

    BritB887 TS Rookie Topic Starter

    I deleted and reinstalled the linksys stuff. . . but not the mini card, yet. I thought about that but now i'm am searching for the disc i received a year ago with the computer for the MiniCard.

    Could I possibly find what i need online?
  4. coalfire

    coalfire TS Rookie Posts: 28

    try resetting the IP worked for me when I had this problem.

    Open a comand prompt (click start, run and type in cmd)

    then type ipconfig /release
    then when that has finished type ipconfig /renew

    see if that helps any

    If not you can try

    On Win XP choose: Start --> Run and in the text box write: "netsh interface ip reset all"

    then click on "OK" button and you will see a "DOS Windows" that will disapeared quickly.
  5. BritB887

    BritB887 TS Rookie Topic Starter

    When i do the "IP /renew" step... it's telling me that the media is disonnected so it can't do it... and something about not being able to connect the the DHCP.

    any ideas on what this means i need to do.. so far nothing i've tried has worked....I start class on Monday... they happen to be online... lol... i'd love to find a way to fix this!!
  6. coalfire

    coalfire TS Rookie Posts: 28

  7. BritB887

    BritB887 TS Rookie Topic Starter

    I've messed with my computer so much that now it says "connected" but I still can not access the internet. Even if i try to plug in the ethernet cable, it recognizes that it's there, but it gives me the "limited or no connectivity" message. When I pulled up system information, it is saying the DHCP is disabled. This doesn't only happen at my house, I can't get connected to ANYONE'S wireless connection when other's computers can. I'm really trying to figure it out and so far everything i've looked into is not working.
  8. coalfire

    coalfire TS Rookie Posts: 28

    Network connections,find your LAN connection, right click-choose properties, select Internet Protocol (TCP/IP)-click properties,select "Obtain an IP address automatically" if that fails

    Try deleting all network connections, disable the wireless in device management then reboot. re enable wireless and set up fresh connections
  9. BritB887

    BritB887 TS Rookie Topic Starter

    yeah. It's set to obtain an IP address automatically but i still run into that problem. I am going to try deleting all connections and resetting everything today. I've done so much i can't remember whether that's been done. This all started out of nowhere, so i'm not even sure what I did to possibly cause the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...