Dell 531 will not sign on through Router

By WarriorMP ยท 9 replies
Jan 15, 2010
  1. Hi again all,

    I have a Dell Inspiron 531 that for some unknown reason will not sign on-line through a router. Only when plugged directly into the cable modem will it sign on.

    I've tried deleting the network adaptor (nVidia nForce 10/100 Ethernet) twice and updated the driver. I've swapped out ethernet cables and the very same one I'm using now is the same one that will not work once plugged into the router.

    Any Thoughts?
  2. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    If I understand well you told sign on-line on the internet though the router? If that is it, is the router connected to the internet wirelessly or though a cable?
  3. WarriorMP

    WarriorMP TS Rookie Topic Starter Posts: 23

    No, It WON'T sign on through the router. Only when plugged directly into cable modem will it sign on. It's a wired router but for some reason this comp will not recognize it. "Diagnose and Repair" says "A cable is unplugged..." Other computers (1 other Dell Inspiron w/Vista and a HP Lap Top also with Vista) have no problem connecting through the router, only this one.

    IPCONFIG dialog through router:
    Windows IP Configuration

    IPCONFIG Dialog directly through modem:
  4. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    I think the problem may be Vista have you tried it with XP? Because Vista got some problem with some routers and it depends on the router compatibility to work with Vista.
  5. WarriorMP

    WarriorMP TS Rookie Topic Starter Posts: 23

    I'm trying that now. I recently recovered a HDD with XP Pro that is currently in the Dell case but the board drivers aren't loaded on the XP HDD. So, I have to go back and forth to the dell web site to obtain drivers. So far I've no luck installing the required driver for the nVidia Network Controller. It installs fine but there's an error "CODE 39" on the controller in "Device Manager".

    As for Vista compatablity, I have 2 other machines that are on Vista (1 HP Lap-top Vista 32bit, the other Dell Inspiron 531 Vista 64bit) that don't have a problem seeing the router. Although the 531 does sometimes have difficulty; after reset it's usually fine.

    So as not to confuse anyone, the Dell I'm currently working on is the 531 with Vista 32bit desk top.
    Hopefully I havn't lost anyone in all this...
  6. HellfireXD

    HellfireXD TS Rookie Posts: 27

    have you tried hard resetting the router? if the router is filtering by MAC address it may be filtering your computers MAC address out.
  7. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    Vista had a big problem about Network. Sometimes Vista got lot of problem for detecting and connecting.
  8. WarriorMP

    WarriorMP TS Rookie Topic Starter Posts: 23

    Hi HellFire,
    Yes, I've tried hard resetting both the router and the modem with negitive results. Also, I was finally able to locate the correct driver for the network controller for Windows XP (recovered HDD O/S). After installing the driver on the XP HDD (remember it's also in the Dell) and booting the system to XP, the O/S was able to detect the driver and load properly however it too will not see the router. Same "Diagnose and Repair" message... "A Network cable is unplugged..." I'm beginning to thing that this problem is comprised of both an O/S AND Network controller issue.
    Connected to the modem, no problems signing on, connected through the router and N'ada.
    Now, either there's a configuring problem with Vista or with the router or both; or the controller is faulty. The ladder doesn't make sense though as it was my understanding that the system (at one time) was able to connect through a router.
    Remember, this computer (Dell) was given to me because it wouldn't connect to the internet.
    It will but not through a router.

    it's a nVidia network controller 10/100 ethernet
    and driver is up to date.
  9. WarriorMP

    WarriorMP TS Rookie Topic Starter Posts: 23


    To All those who assisted (or tried to assist) Thankyou!
    I belive this will be the last entery for this post as the problem of connecting to the internet through a router has at last been solved!

    It took some doing but after uninstalling, re-installing uninstalling and re-installing time and time no avail I finally stumbled on the culpret.

    I have this nifty little NVIDIA Network Test Utility that I've used in the recent past to test the connection. It would always "FAIL" when it came to the "LINK" test. I didn't make the connection to the note it had at the bottem until now.

    It advised "Link test failure: Ensure that the cable is good by trying with a different known good cable. If the cable is good and the link still fails to come up, then the recommendation is to make sure that the autonegotiation configuration for the PC's Ethernet adapter matches that of the other device to which the PC is attached."
    I took this to mean set the "Speed & Duplex settings" to "AUTONEGOTIATION". Well, on a whim I changed that setting from "auto negotiate" to "100Mps Full Duplex" and IMMEDIATLY the connection was recognized and the COMP went on-line! (I knew it had to be a setting of some sort somewhere, things like this don't just change by them selves.)

    here's proof
    IPCONFIG Dialog through router:
    Again all, thanks for your input and I hope this info helps anyone else out there with a similar situation.
  10. WarriorMP

    WarriorMP TS Rookie Topic Starter Posts: 23

    For those who don't know where that setting is...
    Go to:
    Device Manager
    Network Adaptor
    from there you should see:
    General, Advanced, Driver, Details etc...
    Under the "Advanced" tab
    go to "Speed & Duplex settings"
    Mine was set to auto negotiate to which I changed it to 100Mbps Full Duplex.
    try different settings according to your adaptor.

    Good Luck!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...