Dell GX280: Won't find the primary hard disk?

By hermtm2 ยท 13 replies
Oct 4, 2009
  1. Hello.

    I have a gx280 system, It won't boot up about 1 out of 3 times. The reason is not to find a hard disk. The messege shows me " No SATA hard drive". Whenever the computer failed to be booted up, I opened the case and replug the HDD cable in. It clears the problem so far. Also I replaced the HDD cable either but it still has the problem. The dell assistance in online say that the problem could be the cable or mothboard. I don't know what I should do now. Should I buy a new board or throw this Dell away? Or anyone has a solution for this?

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    That motherboard has a lot of trouble with bad capacitors which render the system to be now workable. If your capacitors (little barrel-like components about 1 to 1 2/4 inches high) are puffy, have rounded tops, or are leaking brown, black, or rust colored powered, the board is dead unless you have a tech nearby who knows how to replace them cheaply... about $60.

    Otherwise, replace the cables with the SATA cables with the locking plugs and sockets... very cheap...

    So again Dell is right, but not helpful.
  3. hermtm2

    hermtm2 TS Rookie Topic Starter

    But I cannot find any of abnormal capacitors on the board. How can I judge the capacitors are bad or not other than see the color?

    Also the SATA cable has the locking plugs but does not work for me.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    If they are not leaking power, and not puffy on the tops or along the seam on the sides, they are likely fine and not part of the problem.
  5. hermtm2

    hermtm2 TS Rookie Topic Starter

    Following the dell assistance, the HDD was diagnosed by BIOS. The system shows the HDD is fine. After I got the messege, it fails to boot up again. I would like to know what the exact problem is.
  6. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Good to know your hard drive is not the problem, but it could be anything... and too wide a variety of problems to do an online diagnosis...
    We don't know your system, so you would need to describe that in detail.
    It could be the EIDE or SATA cable or socket. It could be an incorrect jumper setting if this is an EIDE drive... but there are too many possibilities... that a knowledgable friend could find in three or four minutes.
    What we know so far is that the hard drive is good. And the motherboard detects it... so the cable is not bad, but the setup in the Boot order could be wrong, or the drive is jumpered as Slave... or is on the wrong cable altogether....
    The possibilities go on and on.
    Unless you can tell us the details of the computer brand and model, and setup, we likely canot help online.
  7. hermtm2

    hermtm2 TS Rookie Topic Starter

    I will provide every detail what I know.

    Model: DELL OPTIPLEX GX 280
    CPU: INTEL P4 2.8G
    RAM: 2 BG
    HARD: 250 GB SATA
    3.5" FDD

    Also what I found is that the computer does not recognize the CD-RW drive. I do not know when it was working properly. I tried to burn some music CD a couple days ago but Nero program does not find the CD-RW device. However device management in control panel shows there is no problem and working properly.

    If you need anything more, let me know.

  8. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Download Belarc Advisor, a free system inventory problem. Discover what it sees.
    CD-RW drives fail. Some brands, such as HLDS, HLD, Some Sony, HP, Acer and a few others fail early. The more they are used, the sooner they fail.
  9. hermtm2

    hermtm2 TS Rookie Topic Starter

    If I buy a brand new CPU in a retail box, does it come with the cooler or should I buy that?

  10. raybay

    raybay TS Evangelist Posts: 7,241   +10

    CPU is a separate item because they don't know which motherboard you will get, or case size, or whether you want a fan cooler or a water cooler or a non-H20 liquid cooler, or a...
  11. hermtm2

    hermtm2 TS Rookie Topic Starter

    The is the result from Belarc Advisor.

    C:\Program Files\Belarc\Advisor\System\tmp\(Homr).html

    I cannot see any problem on the that.

  12. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Only you can see the Belarc Advisor screens...
    It is not a tool for look for problems... but is very handy for getting an accurate inventory of the computer build.
  13. hermtm2

    hermtm2 TS Rookie Topic Starter

    The problems is solved.

    I parted all components out of the mother board and the reassemble them with
    Installing the lastest BIOS again (it's third time). I don't why and how but the problem is solved. The system works normally.

  14. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Good News! Thanks for the update.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...