Dell Inspiron 1525 not booting (Vista)

EXCellR8

The Conservative
One of my friends' laptop is being a bit temperamental. It's a relatively new Dell Inspiron 1525 with Windows Vista Home Premium (32bit) SP1 installed. Anyways, the computer turns on normally but when the OS goes to load it gets stuck at a black screen with just the mouse cursor moving around. Safe Mode doesn't work and the same thing happens if I select "Last Good Config that Worked." I've seen this problem before with updates, but my friend said it was working fine and he didn't install anything.

I popped in the Dell OS disk so I could try a repair/recovery but that was unsuccessful as well. The setup program didn't detect any problems with the OS and there were no restore points to revert back to. I have no idea what the computer is doing when it sits on the black screen. There is a little bit of HDD activity here and there but I think that's the normal behavior. Any ideas? I'm sort of at a loss here...

Thanks in advance for any help! :)
 

EXCellR8

The Conservative
If I get a Windows Vista Home Premium SP1 OEM disk can I perform a repair install without being able to boot the OS normally? I can't do anything with this computer at the moment--it just sits and does nothing. I slaved the HDD to another system and was able to read and write normally, so it's definitely a problem with Vista. Problem is I have no idea what is causing the computer to hang so I can't pull any errors and startup repair says there's no problems.
 

EXCellR8

The Conservative
I've been using the Recovery Console with the Dell OS DVD but it's not doing anything. It detects no problems with startup and each time I repair the problem persists. I've also done a chkdsk and fiddled with the registry a bit. Nothing. I can't do a Uprade/Repair install of the OS because it wont boot and there are no restore points to revert to. Since I don't know the actual problem I can't really do anything.

Thanks for responding