1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Detect Drives:done, no any drives found

By Dimitur
Mar 19, 2015
Post New Reply
  1. Hello,
    I have a PC with 2 HDD
    -250GB not IDE
    -80GB IDE
    I could boot normally with both connected. Everything worked, even tho in the Jmicron thing before booting I see only the 80gb drive.
    So I bought a new PC and decided to sell this old one but only with the 250GB HDD. So I removed the 80GB IDE hard disc and now the computer can't boot.
    Jmicron thing says this error "Detect Drives done, no any drives done" and after a second I get a black screen with message that says I need to select a proper boot device. I've selected this 250GB HDD, on which the Windows is installed, in BIOS (it is set as primary boot device).
    Things what I've done:
    -Changed SATA to IDE/RAID/AHCI - when RAID the HDD can't be found.
    -Reset BIOS to Defaults - no result
    -Removed the battery - no result
    -Added back the IDE drive - no result
    -Changed the cables in the motherboard ( there are 2x2 sata cables 2 red 2 black. the red ones I guess are for Jmicron so I connected the hdd on all of them and no result)
    -Disabled Jmicron thing in BIOS and the message where it says that no drives were found is now skipped and I get to the black screen with message about Selecting proper boot device.
    -Connected this 250GB HDD to the new PC - booted without problems. So I guess this is something in the BIOS that IDE drive I removed changed and I dont know how to fix it. The BIOS detects the HDD, it's set on first position in the boot device priority ( I even disabled the others - still nothing ) but I get the error that there is no boot media.
    Please help
  2. Dimitur

    Dimitur TS Rookie Topic Starter

    Ok I fixed it . What I did:
    -used windows 7 disc and ran a repair ( note I have a windows 10 installed xD) so the first repair couldnt find the drives so it did something.
    -after this repair it restarted I opened the repair again and now I saw my C:\ drive with windows 10 enterprise installed. I clicked and I pressed repair and now it said I need windows 10 repair disc.
    -I changed SATA type to RAID and booted successfully.
    -at the boot it asked me whether I want to start windows or repair. I clicked on repair.
    -after the repair it restarted. Message apeared "Getting Devices Ready" - took about 5-10 mins
    -PC booted successfully with no Data loss
  3. nickc

    nickc TechSpot Paladin Posts: 921   +11

    In the BIOS, change the drives AHCI. That should fix it where u can take thetake u're drive out without a problem.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...