Disk Boot Failure, Insert System Disk and Press Enter

By pdavda ยท 13 replies
May 11, 2008
  1. Hello, I'm new to the forums and I hope you can help me. About 6 weeks ago I built my
    first custom PC, here are the specs:

    Intel Core 2 Duo E8200 2.66Ghz
    ASUS P5N-E SLI Motherboard
    Corsair 2GB RAM 800Mhz (1GB x 2)
    XFX GeForce 8800GT 512MB GPU
    Antec EarthWatts 500W PSU
    Windows XP Professional

    The PC was running fine until a few weeks ago, I got a blue screen while I was using Firefox. This happened a few times and I could restart the PC and it would be fine. At first I ignored it but it happened again, the PC would restart when Windows loaded up and do this a few times until it would be stable so to speak.

    Today the same thing happened when I switched on the PC so I let it restart and choose Last Known Good Configuration, it was running fine for a while until I got another blue screen which looked like a 0x07, the PC restarted and I got the message Disk Boot Failure Insert System Disk and Press Enter.

    I don't have a floppy drive so I can't boot via floppy so I went into BIOS to set CD as first boot priority when I realized that none of my devices were detected in BIOS. I have a SATA DVD drive and Hard Drive but they weren't showing in BIOS.

    I tried using a HD from my old PC with Windows on it. BIOS detected it under Primary IDE and when I tried to load it I got a boot screen with Safe Mode, Safe Mode with Networking etc. I tried Start Windows Normally, Safe Mode, Safe with Networking and Last Known Good Configuration but each time I would get a brief blue screen and the PC would restart immediately.

    Your help would be appreciated, please let me know if there is anything else you need to know.
  2. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    Cold system boot

    Best i can do,
    After succesfully installing an OS
    do not have any disks in any drives during bootup
    only when there being used after.
  3. pdavda

    pdavda TS Rookie Topic Starter

    Thanks but that doesn't help me, can anyone else help me?
  4. captaincranky

    captaincranky TechSpot Addict Posts: 13,012   +2,536


    First, you should probably try and reset the CMOS by removing the system battery for about 5 minutes. Before you restart, disconnect all the drives from the motherboard, and let the computer boot into BIOS. Then run memtest86+ Here; http://www.memtest.org/
    You might also have a bad PSU.

    If any of this helps your situation, you could consider reinstating the system with a completely clean HDD, either by wipe or new purchase.
  5. pdavda

    pdavda TS Rookie Topic Starter

    Thanks for your reply, I will try and reset the CMOS. I was also going to try setting the BIOS to default settings and also flashing the BIOS to see if that would make any difference.
  6. captaincranky

    captaincranky TechSpot Addict Posts: 13,012   +2,536

    I would consider flashing the BIOS as a last resort. If the machine was working with the BIOS which came with the board it's unlikely it would stop for no aopparent reason. By flashing the BIOS, you would create too many variables to evaluate at once. BIOS updating can be risky as well. Try the other stuff first.
  7. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    SP3 news

    Broadcast on ABC. Have you installed SP3 ?
    Quote news,

    SP3 can cause your computer to continually start and restart.
    This problem has been posted in SP3 available.
  8. pdavda

    pdavda TS Rookie Topic Starter

    I have an update and I'm sorry I know it's a long post but I hope you will take the time to read it. I reset the CMOS by taking the battery out. I put it back after 5 mins and started the PC. I got a message in the POST saying CMOS set to default, press F1 to continue.

    Windows actually started! I got onto the desktop and decided I should backup what I can, while I was backing up some files the computer completely froze, I couldn't move the cursor or anything so I reset via the switch and the computer was stuck on the POST screen, this has happened before and I can't do anything but turn off the PC and wait for a few mins before I start it up again and then it will begin to load past this screen.

    Again, Windows booted and I'm actually on the PC at the moment as I type this, I think I will try and run memtest to see if it was my memory that caused this problem because I don't understand what the problem was.

    I don't know why it worked after I reset the CMOS because I'm still a newbie so if you have read this entire thread then please post and help me understand or give your opinions on what the problem was or is.

    Since the PC seems to be running ok at the moment with all my data intact, it makes me question whether there is anything wrong with my HD, I will most likely reformat with a clean install of Windows just to make sure any of these errors don't return.

    Since I am on the PC I have a lot of dump files that I have saved from various blue screens I've gotten. I would appreciate it if someone could take a look at them and tell me what caused the problems.
  9. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    Try pasteing the contents

    Not if theres a warning to decide.
  10. pdavda

    pdavda TS Rookie Topic Starter

    Thanks for the replies captaincranky and zipperman. I left the PC on the reply screen for a while while I took care of a few things so I didn't see your posts.

    Zipperman, I don't have Windows XP SP3 installed, I'm currently running SP2.

    Captaincranky, I have updated my BIOS once before because I got a message saying "CPU undetected, BIOS update required to unleash full potential" when I started the PC up for the first time but I haven't done it since then because I've had the most recent update. As I mentioned in my previous post I reset the CMOS and that seems to have done the trick so I won't need to flash the BIOS although I'm not convinced that the problem as gone.

    I have more dump files so I have attached them to this post since 5 is the limit.
  11. captaincranky

    captaincranky TechSpot Addict Posts: 13,012   +2,536

    The system reset would have returned the BIOS to it's default settings. Now, can you think of anything you might have changed (in BIOS) which could have caused your problems?

    I'm guessing that your Windows CD came with SP2. I'm a big fan of updating incrementally, so you still have the process of elimination to work with if you run into problems. SP3 doesn't offer that much more than SP2, so I would approach it with a great deal of caution.
    When you say, "none of my devices were detected", what did you have connected, other than the HDD and optical drives?

    If resetting the CMOS resolved the problem, (at least for the time being) you might consider springing for a fresh battery. Hey, can't hurt.
  12. pdavda

    pdavda TS Rookie Topic Starter

    Hi there, yes my CD is Win XP Professional SP2 and I am upto date with my Windows Updates. I can't really think of anything that could have changed in my BIOS that caused my PC to work again.

    When I said none of my devices were detected I meant that BIOS didn't recognise my SATA HD or SATA DVD Drive, thats all I had connected. Everything had None next to it, for example SATA 1, SATA 2, SATA 3, SATA 4.

    However when I tried using a HD from my old PC which is IDE, BIOS recognised it but when I tried to boot it the PC would blue screen and it would return to the boot menu with the options Safe Mode, Safe Mode with Networking etc. I tried Safe Mode, Safe Mode with Networking, Last Known Good Configuration and Start Windows Normally and for each attempt I would get a blue screen and the PC would restart.
  13. captaincranky

    captaincranky TechSpot Addict Posts: 13,012   +2,536

    Some boards auto-select the method of transfer from the HDD. Either SATA or IDE can be selected without input from you. That said, when you reset the CMOS, the board may have re-selected the correct interface.

    An improper choice of interface can make a HDD disappear. A single SATA drive cannot be run as SATA under XP. With 2 SATA drives connected (your DVD drive) the board could have gotten "confused" about which interface to implement. I know this sounds like Voodoo. But it's why I always recommend people use the IDE buss for optical drives and leave the SATA ports for the HDD(s).

    The XP install on the IDE drive may have half-a***** worked just well, because. OK,that's not scientific either. But, IDE is IDE, and SATA can be IDE, AHCI, or RAID.

    If this thing (board) strikes out on it's own like this, we need to consider the possibility of a defective SATA controller.
  14. pdavda

    pdavda TS Rookie Topic Starter

    I agree, I think it may be a faulty SATA controller. I've spoken to a few friends and they agree that it could be the Motherboard because it worked after I reset the CMOS. I'm going to do a memtest to check my RAM soon then I will report my results.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...