Drive letters changed themselves. NTLDR is missing

By Chegwell ยท 4 replies
Mar 5, 2009
  1. This will be the third time this has happened since Christmas and nobody has a clue what has happened.(I hope this is the right forum for this post).
    To try and cut a long story short- Decided to build a computer. I am new to this and dont know much but got help putting it together. Worked fine for a week or so, then wouldnt boot. Got NTLDR file missing errors. Took out 1TB drive, found it faulty, dealer replaced it. Installed new drive, it was faulty from the off (I could hear it), and was changed for a different make of drive (1TB). Now 2 weeks after install and working fine, I turn off one night, turn on the next morning and the computers asking for a boot disk. Went to do a reinstall over the top of the old OS, and discovered that what was my C drive (with Windows XP32) was now the E drive, and the D drive(with XP64) was now the C drive. And it wont boot up from it because "NTLDR is missing".I have a feeling this is what happened to the first install but I never noticed the drive letters.Any idea what may have caused this?

    Asus P5Q Deluxe Motherboard
    CPU Intel Quad Core Duo Q9550 (overclocked to 400)
    Zalman Reserator1 V2 Fanless Water Cooling System
    4 X OCZ 2GB Reaper 1066Mhz PC2 8500 Memory
    Coolermaster 850W Real Power M850 Powersupply
    BFG GTX280OC Graphics Card
    1TB Samsung SATA HD
    300GB Samsung PATA Drive
    750GB Seagate SATA Drive
    Creative Fatlity Platinum sound card
    Internal card reader
    PCI-Express 2 x FireWire and 3 x USB Ports I/O Card
    Sony DVD Rom Drive
    LG DVD Drive
    Dual boot (if it would ever work properly)Windows 32 and XP64
  2. Taff

    Taff TS Rookie Posts: 38

    Hi Chegwell,

    My first reaction to this is that the battery that holds the PC's BIOS settings (and system date, etc.) whilst the machine is switched off, is faulty.

    Try accessing the Bios (usually by hitting DEL or F1, F2) while the PC is booting, set the hard drive priority to SATA, save and reboot.

    Good Luck,

  3. Chegwell

    Chegwell TS Rookie Topic Starter

    I cant face another complete reinstall

    Thanks for the response Taff. The PC is, and has always been set to boot from SATA. And it has worked fine, so I dont think thats the answer. Could the overclocking have anything to do with it? or the power supply? I have Acronis disc director installed (its like norton partition magic), but Acronis swears its nothing to do with their software. i really am at my wits end, I cant face another complete reinstall (This will be about 14, and i still dont know what causes it).
  4. Taff

    Taff TS Rookie Posts: 38

    Hmm, overclocking can and does cause odd problems, next suggestion was to be set the bios to defaults :)

    Any 3rd party partition/boot manager software can also go buggy - I've learned that to my own cost :(

    How about booting with only the boot drive connected (no opticals) ? If that works, it may give us some leads.

    If you're unsure as to which is the boot drive, try one at a time, each will give differing errors (I hope).
  5. Chegwell

    Chegwell TS Rookie Topic Starter

    Excellent. I will; give that a go and let you know what happens. I will also be getting back in touch with Acronis because Im not convinced. Thanks, I will let you know.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...