Driver Issue with Sims2 err frustrating

By jadeca
Mar 2, 2008
  1. Hey,

    I have been researching this issue all night and day and I haven't been able to get any help with this one. I just bought the SIMS2 and it comes up with that error message about the directx driver 9.0. As you know there seems to be an issue with that. I have done the following things and nothing has worked.

    I changed it to a 16 bit then tried to get the game to run by right clicking and putting the space then the -w and it didn't work for me. Then someone said that they unistalled their driver and reinstalled. I did this which gave me bigger problems so, I restored my computer. Now, all of the programs I deleted show back up but none of them will work.but I can't seem to uninstall them or reinstall them. the DVD's play, and the Music CD's work. My husband plays Civilization 4 or 5 (the latest one) on the computer and he had no problem. I am going to list my computers components so maybe someone can decipher this mess. Anyone willing to help the clueless? Oh, and when I had the computer built I told them it was for gaming so, I think that it should have whatever it needs. It's about 2 years old. From DELL

    System Information
    Time of this report: 3/2/2008, 17:00:27
    Machine name: LA-A2AC69E4E96B
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: Dell DV051
    BIOS: Phoenix ROM BIOS PLUS Version 1.10 A03
    Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz
    Memory: 502MB RAM
    Page File: 378MB used, 849MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    DxDiag Notes
    DirectX Files Tab: No problems found.
    Display Tab 1: The system is using the generic video driver. Please install video driver provided by the hardware manufacturer. Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.
    Sound Tab 1: No problems found.
    Music Tab: No problems found.
    Input Tab: No problems found.
    Network Tab: No problems found.

    DirectX Debug Levels
    Direct3D: 0/4 (n/a)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (n/a)
    DirectMusic: 0/5 (n/a)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    Display Devices
    Card name:
    Chip type:
    DAC type:
    Device Key: Enum\
    Display Memory: n/a
    Current Mode: 1024 x 768 (32 bit) (1Hz)
    Monitor Max Res:
    Driver Name: vga.dll
    Driver Version: 5.01.2600.0000 (English)
    DDI Version: unknown
    Driver Attributes: Final Retail
    Driver Date/Size: 8/10/2004 06:00:00, 9344 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: vga.sys
    Mini VDD Date: 8/10/2004 06:00:00, 20992 bytes
    Device Identifier: {D7B70EE0-4340-11CF-B063-282AAEC2C835}
    Vendor ID: 0x0000
    Device ID: 0x0000
    SubSys ID: 0x00000000
    Revision ID: 0x0000
    Revision ID: 0x0000
    Video Accel:
    Deinterlace Caps: n/a
    Registry: OK
    DDraw Status: Not Available
    D3D Status: Not Available
    AGP Status: Not Available
    DDraw Test Result: Not run
    D3D7 Test Result: Not run
    D3D8 Test Result: Not run
    D3D9 Test Result: Not run

    Sound Devices
    Description: SigmaTel Audio
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: HDAUDIO\FUNC_01&VEN_8384&DEV_7690&SUBSYS_102801C4&REV_1022
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: sthda.sys
    Driver Version: 5.10.4548.0000 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 6/6/2005 03:40:48, 180736 bytes
    Other Files:
    Driver Provider: SigmaTel
    HW Accel Level: Full
    Cap Flags: 0xB5B
    Min/Max Sample Rate: 44100, 192000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No
    Registry: OK
    Sound Test Result: Not run

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...