By Gazza ยท 11 replies
Oct 13, 2005
  1. Hey Folks,

    I've been having the DRIVER_IRQL_NOT_LESS_OR_EQUAL error Msg in several computers since this week.

    First of all I am going to tell you a bit of the Story.

    I have a Small Network consisting in three workstations with WinXP SP2 installed. All of these 3 computers are the exact same configuration (eMachines Model T5010):

    Intel PIV Processor 516 2.93Ghz 533Mhz FSB 1MB L2 Cache
    512 MB DDR SDRAM Dual Channel
    Intel Graphics Media Accelerator 900
    Intel Pro 10/100 Network Adapter
    200GB 7200RPM SATA HD
    DVD+/-RW Double Layer
    8 in 1 Digital Media Reader
    7 USB ports, 1 IEEE 1394

    Additional to this I installed them a wireless network card from D-Link: 108G (DWL-G520)

    When I first bought the computers they came with WinXP Home Ed but as I needed them for my workplace i bought the WinXP Pro licences and upgraded them from scratch.

    After installing the OS I used the drivers & Resource CD to install all of the drivers for the hardware components listed above. Also installed all of the hotfixes from MS Update site and all.

    The result: I get this anoying blue screen with the stop Msg stated above. The error does not occur always. It has happened a couple of times (in every computer) but I am concerned and haven't been able to identify what the problem is.

    With these 3 computers failing I can live with (sort of) but here is the deal, I have a fourth computer running Windows 2000 SP4 Server Ed wich is sending me the same error and this IS A REAL problem as it is my data server and I receive calls every couple of hours from my users telling me that the server stoped responding!

    The server's config is:
    Intel PIV 2.4 w/512K Cache
    512MB PC2100 DDR SDRAM
    Biostar u8668PRO P4M266 SDR/DDR USB2 w/LAN MoBo
    80GB Ultra ATA 7200 RPM HD
    1 Firewire 3 Port
    56K V.92 Modem
    Pro-III Flash Card Reader
    ATI Radeon 7000 64MB DDR Graphics Card w/TV output
    16x DVD Rom Drive
    48X12X48X CDRW Drive

    Also, I installed a wireless network card (same as the other computers).

    So, what do you think the problem could be?...

    I am attaching the minidumps for one of the Xp computers and the Win2K computer.

    I hope someone can help me.

    Thanks a lot.

    Attached Files:

  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    All your mindumps crash at A3AB.sys. This is the driver for your wireless network card from D-Link.

    Try updating the drivers for the device, or try a different wireless card, in case of compatibility issues.

    Regards Howard :wave: :wave:
  3. Gazza

    Gazza TS Rookie Topic Starter

    Hello howard_hopkinso,

    Thanks for your reply...

    Just one las question... are you talking about the minidumps for the WinXP computer, the Win2K or both???...

  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Both the WinXP computer, and the Win2K computer crash with the same problem, A3AB.sys.

    Regards Howard :)
  5. Gazza

    Gazza TS Rookie Topic Starter

    Damn... then I have real problems... as the drivers that are installed in both computers are the latest (Downloaded them from the vendors site and they were actually the same version as the CD)!... : :dead:

    Thanks Anyway... And if you have any suggestions besides buying adapters from other brands let me know...
  6. dsm

    dsm TS Rookie


    I've been wasting time trying to get d-link tech support to own up to this issue. The problem is Dlink doesn't actually write the drivers for this card. They rebrand drivers provided by Atheros (the chipset maker). There is much discussion of it on the DLink forum at

    You can find much newer drivers from Atheros on the dslreports forum, but they all have this problem as well. The one set that works without crashing is 3.3. This one is pretty good, but sometimes I need to "repair" when the connection stops working. Dlink had a 3.3 based driver posted at one time but it disappeared from their download site. On the forum you can find a dowload link for the 3.3 version of the drivers direct from Atheros.

  7. Gazza

    Gazza TS Rookie Topic Starter

    Hey there...

    I am back asking for your generous help...

    I have changed the network adapter on my Win2K server ed to an Air-Link (changing from a d-link) and Today I had another reboot. Here is the dump file, I hope it aint the network driver again!...

    Here is the newer minidump file.

    Thanks in advance.

    P.S. I have tried D-Link support and it sucks big-time!...
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your latest minidump crashes at N3AB.sys. I can find very little info on this driver, but it does look like it`s something to do with wireless lan cards.

    Try doing a Google search for N3AB.sys and see what you think.

    Regards Howard :):)
  9. Gazza

    Gazza TS Rookie Topic Starter

    Thanks Howard...

    Well, I should say that it is the network card driver. Reading the spects for the Networkcard i realize that it uses the same chipset as D-Link (Atheros), which narrows the problem to this specific chipset!...

    Now I really don't know what else to do!... :S... I am going to try Tech Support from Air-Link hoping to get better results than with D-Link...

    But still... if there are other suggestions, please tell me.

  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I`m afraid I can`t think of anything further that`s going to help you. I wish I could.

    Regards and goodluck Howard :) :)
  11. Gazza

    Gazza TS Rookie Topic Starter

    Believe me Howard... you've been more helpfull than what you think...

    Now... this may be a stupid question, but are there any WLAN adapters that work @ 108Mb but whithout using ahteros chipset?... does anyone know?...

    Thanks again.
  12. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I can`t answer that question.

    It might be worth starting a new thread for that particular question in the storage and networking forum. I`m pretty sure someone will have the answer for you.

    Regards Howard :) :)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...