Driver_irql_not_less_or_equal - tcpip.sys

By romazon ยท 12 replies
Mar 3, 2011
Post New Reply
  1. hi guys,

    i have this problem an hour ago, i tried system restore to restore my computer 2 days ago and i t didn't work.. tried to copy "tcpip.sys" which located in system32/drivers from another computer using the same windows xp sp3 and it didnt work.. so i am seeking help here please, if any professional could give me any help, please do and i'll be thankful..

    i'm attaching minidump files as i saw it's required.

    Attached Files:

  2. robin_bga

    robin_bga TS Rookie Posts: 171

    Hi, Romazon,
    You leave us hanging if you don't tell why you are doing what you are doing, I mean i would love to know why do u want to restore your computer or what went wrong with it that prompted you to do so...
    And why did you decide to replace the that specific file and not any other.
    Plus we also need to know the specs of you computer...
    Thank you bro
  3. romazon

    romazon TS Rookie Topic Starter

    thanks Robin for your reply,
    i am having the bsod every time i use internet using firefox through home wireless..
    i have an acer aspire laptop using windows xp sp3, i tried restore cause it tells me that maybe you installed a new program which affected your system and cause system crash.. then i tried to replace the tcpip.sys file cause i thought it is damaged, so it will open internet without bsod..
    looking for an answer from you
    thank you bro
  4. romazon

    romazon TS Rookie Topic Starter

    anyone could give a help? please..
    anyone can proof himself before i fix it by the stupid way (formating) :p
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    tcpip.sys is a Windows OS driver that has to do with internet/wireless connection. I'll read your minidump for you.

    UPDATE: Your issue is with your Atheros wireless network driver ar5211.sys.

    Go to Acer's website, find the exact model of your laptop and update their latest offerings for wireless drivers.
  6. romazon

    romazon TS Rookie Topic Starter

    thank you a lot Route44.. i was checking this every hour for a solution without any!! hope yours will do :)

    i'm gonna to try that and till you later..
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Okay, remember, make sure the updates are for your model laptop. Keep us updated.
  8. romazon

    romazon TS Rookie Topic Starter

    it didn't work

    i download last driver of Atheros wireless network driver from Acer website and install it and same problem ..

    this is the screen :

    i try also uninstall and dellete all ar5211.sys files in my labtop to make sure that my OS will take a ar5211.sys file from the new driver that i install it , and the same problem and same bsod :(

    i attached again the new minidumb that appear to me ..

    "" the problem appear only when i try to access the internet over my wireless card ..

    please is there any thing i can do to repair my laptop before i format it ?

    thanks for your help ..

    Attached Files:

  9. romazon

    romazon TS Rookie Topic Starter

  10. romazon

    romazon TS Rookie Topic Starter

    i try to upload a picture for a bsod and it didn't post very well , :(

    i hope the minidumb files enough for gave me the solution ..

    any one can help please ? :(
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Please try to keep in mind that all of us who help are all volunteers and we try to give as much time as our schedules allow.

    Question: Do you have Hotspot Shield installed? If so then uninstall it. The driver HssDrv.sys was cited as the cause of your issue. Hotspot Shield has been known to cause problems and it seems to be causing you internet connection issues.
  12. romazon

    romazon TS Rookie Topic Starter

    thank you man!! it works :) I uninstalled Hotspot shield and finally i can open my pages there..
    I thought of it when I was trying with my wireless adapter cause I saw it there in my device manager (hotspot shield adapter or something like that) but I have installed it since May 2010 so why did this problem happen now??
    anyway, thanks again Route44 for your support and sorry if i were annoying but Windows (actually computers) make your crazy sometimes :p

    Regards :)
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Ah, you weren't being annoying! We understand the frustration of PC issues.

    As for your question, for some reason software will leave remnant drivers behind and at the weirdest time they will begin engaging again. Two years ago there was a poster who came here and after reading her minidump files I told her it was her Norton.

    Get this: She stated they uninstalled Norton 6 years prior! Yet some old drivers were left behind and for some unknown reason they began to try to "work." Once she did a complete uninstalling all returned to normal.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...