1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

DVD audio, but no video. Suggestions?

By Luna M ยท 6 replies
Aug 2, 2006
  1. I'm trying to resolve a customer's problem without a wipe and reload of windows. Ideas would be appreciated.

    Customer has a Dell Dimension 4300 with an NVidia MX/400 card, running WinXP Home SP2. PowerDVD 5 is installed, as well as the program patch that is supposed to resolve various issues with PowerDVD and Windows XP.

    When a DVD is inserted, PowerDVD opens, and sound will play, but there is no video and scanning forward/backward is disabled.

    I attempted to open the DVD in WMP, and recieve this error message:

    '%1 is not a valid Win32 application.'

    I downloaded Media Player Classic and attempted ot play the DVD from there. I recieved this error message:

    'Failed to query the necessary interfaces for DVD playback.'

    I installed ffdshow and k-lite to be certaint there were no missing codecs.
    I have uninstalled the Nvidia drivers (using Nasty File Remover to be sure I got it all) and reinstalled the lastest drivers.

    I have uninstalled PowerDVD 5 and reinstalled.

    I have tried multiple DVDs.

    Still the problem persists. I cannot play DVDs from any application.

    THe customer wants their computer back by tomorrow. I've come as far as my experience and Google will take me. Are there any more experienced suggestions or ideas I haven't yet tried?

    Thank you.
  2. mailpup

    mailpup TS Special Forces Posts: 7,103   +421

    I believe this might be a symptom of the optical drive reverting from DMA (or ultra dma) mode to PIO mode. At least it is similar to what happened to me once. Anyway, look in the Device Manager and check under IDE ATA/ATAPI Controllers and see if the drive in question has reverted to PIO mode. (right click and check properties) If so, uninstall the device from within Device Manager, restart and let Windows reinstall the driver. If that doesn't work, check this link for more information.
  3. Luna M

    Luna M TS Rookie Topic Starter Posts: 19

    Thanks for the suggestion; I reset all IDE devices to UDMA mode.

    Unfortunately this did not solve the problem, either. :(

    I would back up, wipe and reload, except the custormer is very insistant that it isn't an option.
  4. mailpup

    mailpup TS Special Forces Posts: 7,103   +421

    Did you recheck to see if the devices stayed in UDMA mode after a restart?
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    Try a repair install. that wil preserve your customers data. I would also download and try powerDVD6 to see if the problem is issues with PowerDVD5, first.
  6. Luna M

    Luna M TS Rookie Topic Starter Posts: 19

    I usually don't like doing repair-installs, as in the past I've had problems with it screwing Windows up MORE in the process.

    I did end up doing a repair install this time, though, and it seems to have fixed the problem for now. I just wish I didn't have to resort to that. :\

    Thanks for your input.
  7. redmistpete

    redmistpete TS Rookie Posts: 38

    Get an update patch from Cyberlink - worked for me!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...