DVD Duplicator Fails just before...

By greenbuilder
Nov 20, 2007
  1. I have a DVD duplicator and it has worked fine up until recently. I've tried to copy a couple of DVD's recently and the process appears to be working. However, the process fails before the copy can be finalized usually at 90% or somewhere in the middle enough to ruin the blank DVD, and the message I get is Source disk read error. I referenced the troubleshooting portion of the mannual and that message is supposed to indicate the DVD ROM portion of the unit is defective. Basically I'm just trying to varify this.

    Also, I checked and the DVD I'm trying to duplicate is not copy protected.

    Thank you,
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Try a different brand of blanks.
  3. GameJunkie72792

    GameJunkie72792 TS Maniac Posts: 274

    Yes try different blanks, or rip the DVD (Video_TS) to your HDD and burn from there, i had this problem last night as a matter of fact trying to back up my copy of RENT.
  4. mscrx

    mscrx TS Rookie Posts: 310

    I would try a different blank as well but instead of ripping I would make an iso of the disk and then burn it. should be faster than ripping :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...