1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

DVD-RW drive reads as blank CD drive when disc is inserted

By MysterioMask ยท 14 replies
Sep 28, 2012
Post New Reply
  1. Ok im having this problem on 2 desktops. The drives are both DVD-RW drives. They show up properly in device manager and in my computer. That is, untill I stick a disc in it. Then it will spin and act like its about to read then it says its a CD drive with nothing inserted into it. If I explore the drive there is nothing in it. I went to device manager disabled and enabled it. also updated the driver and rolled back the driver they still do the same thing. Wondering if anyone has any ideas or solutions
  2. xcylent

    xcylent TS Booster Posts: 230   +17

    What sort of CD are you using? it could just be that your drive can't read the specific type of disk.
  3. MysterioMask

    MysterioMask TS Booster Topic Starter Posts: 128

    Im using a linksys wireless card driver install disc. Works fine on 4 other computers which have the same type of disc drive.

    I had forgotten to mention that when I put my flash drive into the usb port, it says it cannot be read. But reads fine when I boot up in safe mode. The disc drive works fine in safe mode as well. But fails to work properly in normal boot up mode.
  4. xcylent

    xcylent TS Booster Posts: 230   +17

    That's a curious little problem we have here! :)
    can you tell me what you've already done (to try and fix it)?
  5. MysterioMask

    MysterioMask TS Booster Topic Starter Posts: 128

    It is a veritable conundrum! But yeah, went to device manager, enabled and disabled it, updated the driver, rolled back the driver *in safe mode and normal* Chose which driver to update and picked the newest and oldest ones. Tried different discs. Pulled the IDE cable and power from it and started the comp up then restarted and then plugged them both back in. Ran virus scan in safe and normal mode. Blew canned air into it. I think I did something else that but I cant remember what. I didnt try to fix the usb flash drive problem I just assumed both were connected somehow.
  6. xcylent

    xcylent TS Booster Posts: 230   +17

    Alright well I've had the USB ports failing experience twice, and unfortunately, after tearing my hair out to try everything to fix it, I had to resort to reinstalling windows :'(. I hate to say this, but I may not be able to offer any advice other than 'reinstall windows'.
  7. MysterioMask

    MysterioMask TS Booster Topic Starter Posts: 128

    My best guess on what has happened was that a virus of some sort has deleted or impared the things from running in normal mode. The problem is I just dont know how to fix it or where to look to fix it. As a last resort I ran combofix in both safe and normal modes and even that didnt fix the problem. I have been thinking im going to have to reinstall windows but I havent wanted to do that but without a clear solution to the problem and being under a time constraint im probably going to reinstall.
  8. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +244

    Have you tried just a windows repair?
  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    2 things -

    1. Its pretty unlikely that 2 drives died at the same time, but it could happen. Have you confirmed the drives can still read disks? An easy way to check this would be to reboot and try to boot off a bootable cd/dvd. If it can boot from the disk, you know its a software issue rather than hardware.

    2. Have you recently installed/uninstalled any virtual drive software (like Virtual Clone Drive or Daemon Tools)? I remember an issue similar to this I had many years ago caused by Daemon Tools.
  10. slamscaper

    slamscaper TS Addict Posts: 235   +62

    My guess is that you had some software (or malware) installed that was intercepting calls to the cdrom.sys driver (via class UpperFilter or LowerFilter drivers), but now that software\malware is no longer functional on your system.

    There are a lot of legitimate applications that install upper and lower level filters. They do this so they can modify how your DVD-RW\CD-ROM drive interacts with Windows, so I won't be so quick to blame malware in this case.

    Here's a guide that explains how to delete these filters from the registry. It's worth a shot anyway, especially before resorting to more drastic measures.
  11. MysterioMask

    MysterioMask TS Booster Topic Starter Posts: 128

    The drives worked fine in safe mode so they didnt go bad. The comps never had any virtual drive software on them. I just reinstalled the operating systems and the drives work perfectly fine now.
  12. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    It was probably what smamscaper said then, which is what a virtual drive software could have done too, but his explanation mentioning that more software could do that too was likely correct.
  13. mouzool

    mouzool TS Rookie

    Sngx1275 I used a daemon tool and mine is having the same problem (my usb ports are working fine)
  14. nickc

    nickc TechSpot Paladin Posts: 921   +11

    If u read the solution to what he did it was reinstalling Windows, I have the same problem years ago and the only way I got it fixed was reinstalling Windows. I am going to say that is the easiest way but make sure u have things backed up and have the drivers u need.
  15. I m also facing same problem when I put a cd in dvd rw drive it shows the disc is empty but when I try to install windows the dvd runs in the drive but no further process starts so wht should I do for this I have tried this by using two discs of windows please help...

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...