Error when installing Windows

Not open for further replies.


TS Rookie

to start with i am not a wiz with computer hardware.. I will try to explain the problem as good as possible.

oke, so..
two months ago my motherboard stopped working for some reason. i dilivered it to my dealer, and they placed a new motherboard inside. Once done, i connected my old HDD and for some reason it did not work. Although i kept trying, ending up with some part of the HDD burned..

So i thought it was the fault of the HDD, and decided to buy a new one. Now i have a pretty WD Raptor X connected, and tried to install XP once again. This time everything goes well. Windows starts detecting the hardware as usual with the install CD inside when i reboot the comp, but it doesn;t finish. At the same point every time i get this error msg: An unexpected error (769) occurred at line 5218 in D:\nt\base\boot\setup\setup.c.

Could this be a problem caused by a different part then the HDD?
This is an expensive HDD, and i don;t want to blow this one as well..

I googled the error, and the only thing i found was another thread on this forum, and thats how i got here.

Before i start to recover or zero my HDD, i would like to ask if some1 here has an idea if this is infact a problem caused by the HDD itself or not.
And of course, What to do?

Thanks in advance, Jo.


Hi Jonostra and welcome to TechSpot.:)

Windows XP (assuming that's what you have as you haven't actually said) needs to be reinstalled when the mobo (motherboard) is changed.

At the very least it will need a windows repair done on it.


TS Rookie
Hi Rik, thanks for your fast respond.

I have tried to reinstall Windows XP (yes) on the old HDD, but it was acting very slow and i couldn;t get windows re-installed, while that same HDD was acting normal on a diffirent PC. So i kept trying. But it burned for some reason when it was connected to My new 'mobo' ;)

Now however, i have this new Western Digital (WD) HDD. It is fresh, and there is nothing on the disk. Every time i try to install Windows XP on it, i get that error written above.

I just scanned it with the Western Digital software, "No errors found".
Also tried installing the HDD on my new system via DOS (with WD 'Data Lifeguard Tools' CD from WD homepage), but there he can;t seem to find the CD drive - where the CD is stationed - for some reason (error as well).
Then as my last resort i zero'ed the HDD but the results are still the same, at some point when Windows XP installation is scanning the hardware configurations: (tried with two different Windows XP Discs)

An unexpected error (769) occurred at line 5218 in D:\nt\base\boot\setup\setup.c.

I suspect it is the new mobo that causes these problems, but before i go back to my dealer again, i would like to gather some information on my own, and try to fix this by myself. If it is in fact the modo's fault, then i got some unfinished business with the dealer..

it has been a drag :(


You could have faulty ram. Google and get memtest and run it for atleast 7 passes (it will take many hours) then post what happens here.


TS Rookie
Think you are on to something here.

It was a matter of seconds before the results popped:

Test: 0. Errors: 56. Lowest Error Address: 00000000000 - 0.0MB

Test: 1. Errors: 24. Highest Error Address: 000ffffffff - 4095.9MB Test: 1

Test: 2. Errors: 40. Bits in Error Mask: 0001fffc

Test: 3. Errors: 56. Bits in Error - Total: 15 min: 0 max: 14 avg: 8 7

Test: 4. Errors: 72. Max Contiguius Errors: 2

Test: 5. Errors: 88. ECC Correctable Errors:

Test: 6. Errors: 104. Errors per Memory Slot: 84208028

Test: 7. Errors: 120.

Test: 8. Errors: 136. 2: 0

Test: 9. Errors: 152. 3: 0

Test: 10. Errors: 168.

Edit: They did include a new set of RAMs together with the mobo.


TS Rookie

Thank you very much for the time.

I will try and replace the memory, and will tell if it did work or if there is still a problem.

Could these wrong RAMs also be the cause of the destruction of my previous HDD? Cause if they are...

Thanks again!! :D


TS Rookie

I recieved the new set of RAM's, tried everything exactly the same again, and there is no change in the situation.

I still get the error when Windows XP installation is scanning the hardware configurations. I did the memtest once again, but it keeps giving the error messages like it did with the old RAM's.

What could cause this?

regards, Jo.


TS Rookie
hi Jonostra, Rik... seemingly i am having the same problem, but slightly different error..

"An unexpected error 32816 occurred at the line 5218 in d:\nt\base\boot\setup\setup.c"

This is an 80 GB IDE hard disk BARRACUDA 7200 P ATA 80 GB , ST380011A, 4JV4BNS2.

The story goes like this... i tried to connect my IDE 80 GB hd to an SATA hd at my office, but somehow it was detected even after trying jumper settings.. eventually the day worn off with other work.. but at night when i tried to connect it to my Intel D865G motherboard, to my surprise it was not detected, thought OS must have been corrupted, at first bios showed the name of my hd as "!!ST" something... (that was last week).. now bios does not even detect it.. i tried to find in google by putting the above error, at a site i got a similar thread, it said that he did something in the boot sector and it got solved... i am blank about what he did and with what tools.

i have 2 rams 256 and 512 of diff frequency.. this is not optimal i am told and i know, but i have been using these 2 for the past may be almost for 2 years now without a single problem, other than a required smps change, i am really confused as to what to do now.. please help. i am not tensed much as it is still in warranty... but i still want to get to the bottom of this problem. Thanks in advance.

i have another 40 GB hd of seagate which i used as salve for the past 2 years, i tried the same with this hd as i did with the above one.. on the same day... but this hd does have os installed. but again surprisingly bios and ms-dos does not detect this, but Active boot disk live cd does..., i can format this drive but during os installation, files get copied, but as the setup finished and system restarts, bios fails to detect the hd.

80 Gb does not have any data but 40 GB is filled to 95%.

Please help.. if any more info is needed please let me know... Thanks
Not open for further replies.