Explorer- Illegal operation: system freezes;immediate help required!

By Vinodkumar ยท 5 replies
Jul 9, 2005
  1. Hi friends

    I am using Windows98SE on a Celeron 400mhz system (old, of course!). When I switched my computer on the other day it booted up to show the desktop. Then it showed an error message with the word "Explorer" on the title bar and the following below it: "This program has performed an illegal operation and will be shut down. If the problem persists contact the program vendor."

    There were two options in the dialog box: Close and Details. I tried to close the dialog box but, though it closed, the same message returned the very next second without allowing me to do anything else. This repeated every time I tried to close the dialog.

    So I clicked the Details button and expanded the dialog. Immediately the Details button became greyed out and inactive. However I got the details and the beginning of it goes like this: "EXPLORER caused an invalid page fault in module OLE32.DLL at 017f:7ff21a32." Below that there were many numbers given under the headings 'Registers', 'Bytes at CS:EIP' and 'Stack dump'. I couldn't make out what these meant.

    The system was almost frozen. I could only move the mouse around over the screen and do nothing. Clicking the Start button to get into my programs didn't work. Right-clicking anywhere also didn't work. My keyboard also was helpless to get me into my programs. I couldn't even shut down the computer as the keyboard and mouse were unable to do their job. Even Ctrl+Alt+Del didn't work.

    So I pressed the Reboot button on the cabinet to restart windows and see if the problem goes off. It didn't. Again I rebooted the system and entered Safe Mode. But in Safe Mode too the problem popped up and the same things described above happened.

    Then I put the startup disk in the floppy drive and booted from there. From the command prompt I extracted and replaced the file OLE32.dll and then booted the system normally. But it too was in vain.

    The last thing I resorted to was to reinstall Windows98. I didnot reformat the hard disc because there were many valuable files on it which I needed. So I reinstalled Windows98 with the hope that it would cure the disease. But still the ailment persisted.

    I am unable to do anything on my system except sit gaping at the screen!

    Please don't blame me for using an old system as I have been using it for more than five years without much problem. It was, in fact, a good friend to me. But now...

    Please help me.

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Looks like a memory problem.

    Open the PC, earth yourself to prevent static, and remove the memory sticks.
    Clean the contacts with an eraser, blow off the remnants and put them back in.
    For good measure, reseat all other cards (video, sound etc) after cleaning their contacts as well. Check all HD/CD/Floppy cables.

    Get Memtest86 from www.memtest.org
    The program will create a boot-floppy. Run that and let it go through at least 7 cycles.
  3. Vinodkumar

    Vinodkumar TS Rookie Topic Starter Posts: 24

    I cleaned the contacts of the memory sticks and all PCI devices. But it was of no use. Then I downloaded memtest and ran it according to the instructions. It reported no errors.

  4. just_a_nobody

    just_a_nobody TS Rookie Posts: 182

  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try running a Scandisk or Chkdsk, can'r remember which one W98 uses.
    Then do a defrag if it lets you.
  6. Vinodkumar

    Vinodkumar TS Rookie Topic Starter Posts: 24

    The problem has been resolved. I found the solution at annoyances.org. The link you provided also contained the same solution. Thank you.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...