External HD won't show up on PC

By mooseknuckle21 · 39 replies
Jan 29, 2011
Post New Reply
  1. Ok, so I brought my external HD to my parents house to give my sister some family pictures and when i brought it home the next day it won't show up on my computer.

    The computer sees that a device is present under "disk management," in the "other devices" category. I figured it was just a device driver that was the problem so i went to the acomdata website and downloaded their usb 2.0 driver and restarted. The computer still wont recognize the hard drive. To make a longer story short heres what I have done and checked:

    1) Restart HD and all connections including different USB ports
    2) brand new USB cable and power supply
    3) installed new driver and tried device on multiple computer with the same problem.

    At this point im at a loss. The hard drive will still powerup when i plug-in the USB cord, but wont stay spinning (i believe thats because the HD doesnt believe its plugged in or something? no?). The drive is a Acomdata HD500UFAP and the desktop PC i have is running windows vista 32-bit. Any and all suggestions are welcome

    Thanx for the help in advance
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    List any Problem Devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Also, what you describe is very odd as USB 2.0 drivers come in XP, Vista and Win 7 in the first place. So you shouldn't need to be downloading drivers from the vendor for your Vista 32

    But, in any case, Problem Device report should show me what appears under Other Devices.. so tell me and we;ll just take it from there
  3. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Under the "Problem Devices" there is nothing listed.

    I thought I already have the drivers as you had mentioned, but I downloaded them thinking I could point windows to the driver and it would recognize and/or read the drive after. Even when I run the driver or point windows to the folder the driver is in it still wont do anything. It says the driver isn't recognized as being in the folder.

    I am looking under the system information (msinfo32) page and i dont see anything that says "other devices." I do however see the "other devices" menu under the device manager, but I dont see an error report.

    I just looked under Event viewer-> Windows Logs -> Application and it has an error report about something related "DMI USB Device." I am not sure if this is exactly what you want, and if so could point me to the correct location? Heres what the error report says:

    "Fault bucket 52267088, type 5
    Event Name: PnPDriverNotFound
    Response: None
    Cab Id: 0

    Problem signature:
    P1: x86
    P2: USBSTOR\OtherDMI_____________________3.53

    Attached files:

    These files may be available here:

    Oh yea if you happen to want to see a screen shot of anything id be happy to post it. Ill do a lot to get these pictures and stuff back.

    Thank You for all the help
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm.. you see an Other Devices category in Device Manager?

    Odd in that they usually also show up in Problem Devices report. So try this

    Rt click the device under Other Devices in DevMgr, select Properties, what id Device Status= ? Tell me the error code #

    Next, click the Details tab, copy/paste the Device ID you see into the next post
  5. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    I tried to make it a little easier to show u what im seeing. heres a few pics. hope this helps.

    heres 4 pics from imageshack. Check them out and let me know what you think.
  6. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    need a couple more posts before i can use links i guess. I will put the link to the pics in the next post.
  7. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    one more lol
  8. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for that but one thing: On the Details tab i need to see either the Device Instance ID or Hardware ID. Use the pull down to menu to choose either one is OK. You should be able to click on the value and then just copy/paste into next post if that's easier
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A bit more info for you, on THIS image of Disk Management

    The top pane is showing you logical storage volumes. You have 3

    Now look at the lower pane. It shows you physical disks. Note All 3 of your logical storage volumes are on Disk 0! Your hard drive is Disk 0. It has been partitioned into 3 different partitions. So what you're seeing in top pane is actually just a partition on your hard drive
  11. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Yea i figured it out after. I forgot i added a third partition on this computer a long time ago. I guess im just more hoping and praying to get it resolved :)
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sorry for the double posts, but to make sure you see this....

    Look again in lower pane of your Disk Management. You also have a disk 1 and disk 2 there with "No media". Do you know what these are?? Are they maybe card readers??

    When you plug/unplug your ext drive from USB
    > Do you hear the USB connect/disconnect ding-dong??
    > Do so while Disk Management is open. Do you see Disk 1 or Disk 2 appear or disapper as you plug/unplug the USB drive?
  13. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Yes you are exactly right. There is a card reader in the front of this computer. I told the computer to stop those and the computer told me they were "safe to remove".

    Now when i plug in my device the same things keep happening. "Found new Hardware" comes up (none of the options on it work though) and nothing new in device management happened. It does make the sound like new hardware has been installed also.

    Oh yea and nothing new comes up in DM when i plug-in or unplug the drive.

    I just saw your posting for the device Instance ID or Hardware ID. heres a pic with what selections they give me.

    This is what it says under Hardware lds:

  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Why don't you first see if this might help [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]

    Also, are you running Vista SP2? Do you have all Windows updates installed?
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    One more thing, if problem persists

    Please double check this... Look at the USB Storage Controller section of DevMgr
    > Look before and after pluggin in the drive. Are you sure a new USB Mass Storage Device doesn't appear when your external drive is plugged in?

    ALSO, if problem persisits, do u have any other USB storage devcie to plug in you can test? (like a USB flash drive or different USB ext hard drive) Is it possible to check if any other USB storage device is recognized or if it's ONLY this one particular drive
  16. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Ok and just to clarify, i meant that nothing new came up in disk management and not the device manager. Nothing happens either way in disk management if i unplug or plug-in the HD.

    There is new a couple new devices under "USB controllers" when i plug-in the HD. I have attached a picture before the drive is in, and after the drive is in. Hope this helps.


    I believe the first pic is with it plugged in and the second is without it plugged in.
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    The good news: OK. That makes more sense that nothing changed in Disk Management and that Device Manager shows the changing devices

    The bad news: What Device Manager is showing in your snapshots is helpful for the "big picture" but still leaves me puzzled!!

    A couple things please:
    1. I can't find that model number on Acomdata website. Are you sure it's correct? Could you provide me a link if you see it on their site?

    2. BEFORE you connect your drive, in DevMgr, i see an USB Mass Storage Controller with a yellow icon. Could you rt click it
    > Select Properties, on the General tab look for Device Status. hat is the error code #?
    > Now look at the Details tab, select the Hardware ID again from the pulldown and then copy/paste the values

    3. Now you can connect your USB drive again
    ==> Download USBDeview to your Desktop (to download the 32bit version click HERE) and fyi HERE's info about the tool itself
    ==> Unzip the file. Rt click USBDeview.exe select Run as admin
    ==> Select any of the items, then Ctl-A to select all items
    ==> From the top menu bar, click File->Save Selected Items, change the Save As Type pull down menu to Tab Delimited text (.txt), then save the file to your Desktop
    > Now please attach the file to your next post (use the TechSpot paper clip icon for attachments)

    Normally a USB drive under Vista shouldn't be so difficult. ARGHH! ;)

    /** EDIT **/
    just fyi...
    Yea, that's a common misunderstanding with Windows.
    > Every driver has a driver INF file (this is the driver's Installation Setup File). It contains the instructions that tell Windows how to install the driver files
    > Vendors typically provide driver EXE files for download. The INF files and other driver files are buried inside the EXE file. (That;s usually because vendor installer do more then just run the driver's INF file)
    > When you run New Hardware Wizard if you look at the file type, it only will accept INF files (which is why if you point it to the EXE file, it says no driver file found).
    > Just another misleading/confusing way that Windows does things!
  18. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    I'm sorry I didn't write the whole serial number from the HD. Here is a link to the exact one i have. Its HD500UFAPE5
    1.) http://www.acomdata.com/app/stx.productdetail.asp?did=127

    Heres a link to the user manual:

    2.) Ok, the next piece you wanted was the error code on the Device Status:
    "Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47)

    To fix this problem, unplug this device from your computer and then plug it in again."

    The Hardware ids under the details tab says this:

    3.) I attached the file you wanted with the USBDeview

    That is also some great information about the inf files. I heard something about them being related to the drivers, but I didnt know windows was that tricky. The part I like about Vista was it was so easy to plug n play. Now this problem.

    I really do appreciate all the help you have given me so far.

    Attached Files:

  19. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Small Update

    So for some odd reason I guess I had skipped over your earlier post about the DriveCleanup program so i went ahead and ran that.

    The good news is the the USB controller that had the yellow warning sign on it went away.

    The bad news is my HD still comes up as "DMI USB device." I really hope all that data isn't lost.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for that update. Based on the USBDeview data you provided, i didn't think you had run that tool yet. (I could still see the drive used to assigned letter J from the old storage data!) And while i'm still not yet certain why you're having this problem, my guess at the moment is probably corruption on your Vista OS. I think the data on your drive is probably still OK. In fact, you might feel better if you plugged it into someone else's computer to make a copy before we try doing anything else so you have it safely stored somewhere??

    Happy to try and help :) (i'm a geek ;) so it also gives me the chance to learn some of the different and quirky ways that Windows does things - as i've noticed for your computer)

    The first USB Mass Storage Controller (that had the yellow icon) is your card reader. Yellow icons flag a device problem. But now that's cleared so is good

    Your ext disk presented TWO devices under USB
    > USB Mass Storage is the USB Mass Storage interface
    > USB Composite Device - this one threw me at first. Never saw this for USB drives (they're common for stuff like USB wireless mouse/keyboard)
    ==> But i look at spec for your ext drive and it has a "push button" backup function
    ==> The push button function is most likely the reason for the extra device (as the push button itself is not a mass storage issue - like a flash, or drive or CD/DVD are. It just implements simple button/notification functions)

    I'm curious about more and may ultimately need to try to run a Vista repair install to fix your problem (i don't really know at this point). But you'll probably feel best if you can recover all your stuff from your ext disk before trying much more

    You can EITHER: plug it into some else's computer OR you can try this which is also a handy recovery CD to have around See [post=766270]How to recover your folders/files when Windows won’t boot[/post]. For your case
    >> No need to run chkdsk on your HD as that's not the issue
    >> Just boot into Knoppix and you should be able to connect your ext drive and see your data again (which would also prove it's a Windows problem)

    /* EDIT */
    So under Knoppix you should be able to see your data again on the drive is my guess, but that should also let you copy it somewhere to another disk for safe keeping if you want
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    One quick follow up

    Look for this file on your computer C:\Windows\inf\setupapi.dev.log

    If you find it, please attach it to a post.

  22. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    So I re-ran USBDeview and I will attach that file, if it helps any. And I did find the log file you asked for and will attach that also.

    I would like to copy the files off this HD onto a new HD that I already own but I cant view the files at all. I have a MSI laptop running windows 7 that won't even recognize the drive and my g.f's MacBook says the drive isn't readable. I dont know how else to get anything off the drive besides taking it out of the casing and maybe setting it up as a slave drive? Or im really considering your Knoppix idea. I just really dont want to lose the data. It has videos of family and stuff I can't get back again.

    Attached Files:

  23. mooseknuckle21

    mooseknuckle21 TS Rookie Topic Starter

    Log file wouldn't upload in the other post for some reason.... The file size is 20.5mb, too big?
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oh yea. I forgot. That log file will be to big "as is" (TechSpot has a 200KB file limit). But we'll forget about that log for the moment (as not sure it would have any clues for me or not) :(

    This problem has me stuck :(. One thing that's different about your ext disk (from what i'm used to seeing) is because it has the "backup button". So the IDs the device sends to Windows are a bit different/more involved then a more simple USB ext drive. But of course it SHOULD still work. And best as i know (which is still limited to what i know about Windows) those IDs affect installing drivers and not the data on the drive.

    That said, i can't speak to how things should work on a Macbook but odd same problem is on both your Vista and Windows 7 computers :confused:
    => As for Knoppix, i know Knoppix handles simple USB ext drives but can't say for certain about your drive with the "backup" button
    => It's probably still worth a shot as it can also be useful just to have a Knoppix CD available sometimes to connect ext USB drives when there's problems (certainly for simple drives, you'll have to test to see if Knoppix installs drivers correctly for the button version as well)

    1) I assume you're logged in with user accounts that have admin privileges??
    2) Any chance that someone was playing with Local Policy settings on the Vista and Windows 7 machines to restrict device install policies?
    ==> See HERE to check all the Device Installation Rrestriction settings are set to default or Disabled on the vista machine

    Yes, removing the drive from the case you can set it as slave or connect it to a simple USB adapter cable could get you to the drive data (if you're comfortable doing that - sounds like you have already done so before)

    I'll think about this more and see if anything else hits me tomorrow
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'll double post to make sure you see this.. could you clarify re: your windows 7 machine when you say "doesn't even recognize". Do you mean its not showing up in Disk Management?? or have you check Dev Mgr as well?

    in dev mgr, when the drive is connected
    > Are you hearing the ding-dong on connection?
    > Are you seeing the USB Mass Storage and USB Composite device again or no??
    > If you look throughout dev mgr, any entries with yellow icons?? do you see an Other Devices category again or no???

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...