External HDD not being recognized by Win7

By tovette · 9 replies
Oct 23, 2010
Post New Reply
  1. I have an external Antec 1Tb HDD and after recently cleaning my computer from malware it is not being recognized by Windows 7.

    I plugged it into my netbook and it came up with Unknown Device and I couldn't get it to recognize it there either.

    Is there a solution to getting my HDD recognized with windows again??

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Is your netbook plugged in when you connect your drive?

    2) Does the ext. drive have its own AC power? Is it also plugged in?

    3) Have you tried your drive on other computer to verify it's not the drive itself?

    4) You can also try disconnecting the drive (and all USB storage media) and see [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]
  3. tovette

    tovette TS Rookie Topic Starter Posts: 22

    1. The power to the net book was active when I plugged in the ext HD. The USB socket detected the hardware but then errored because it couldn't tell what it was.

    2. Yes, the ext. drive have it's own power supply, which was plugged in- although strange is that there is usually a power light that is active on the casing and it also flickers when the drive is being read, but now it's dark.

    3. I disconnected the drive from it's original host computer and then plugged it in on the netbook to test if it was something else other than the drive.

    4. I have just completed a fresh install of my OS. There shouldn't many USB storage drivers present, but I will try cleaning it if you think it's a good idea...
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm... Strange..

    Other things comes to mind

    > See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]

    Also (tho i don't know if should apply as both the netbook and disk had their own power) but i've seen Unknonwn USB device issues occur when computer can't supply 500mA power per USB port (which is spec) and / or the device requires more power then spec. (Tho, in your case, i would think it should get all its own power since it relies on its own AC adapter)

    Even still, given Unknown Device occurs only on the one computer, you might want to get a 1000mA USB connection (They provided twice the power as min USB spec and i've seen sometimes remedy this problem)

    Either get USB Y cable (so you can draw power from 2 USB ports of the one device) OR get a USB hub which provides 1000mA on its ports. Google
    usb hub 1000ma
  5. tovette

    tovette TS Rookie Topic Starter Posts: 22

    hmm alright I'll look into this...
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oh. A couple other thoughts

    We can confirm my guess that Windows can't identify your USB device correctly
    > Open Device Manager. Is the Unknown device appearing under USB category?
    > Rt click the Unknown Device, Properties->Details. Do you see USB\VID_0000&PID_0000? (Normally you should be seeing something other then all those zeroes)
    > You can also try rt clicking the Unknown device select Uninstall and try connecting your USB device again

    1) Do try reinstalling the USB controllers and chipset drivers per earlier link
    2) I've sometimes found 1000mA Usb ports helped (per earlier post) but of course don't know for sure about your case. And as they don't cost too much i also found it's been handy to have one around to be able to use & test with it for problematic USB devices
    > I've found a WD Passport drive and an other device that (at least in my case) were flaky when plugged into normal USB ports but worked much better in a 1000mA hub i bought

    /* EDIT */
    Oh. just recalled you said you just recently did a full Windows reinstall... so trying the "reinstalling driver" link may not apply well for your case

    Tho one other interesting experiment i think. Try booting into Knoppix and see if your USB drive works on your same computer under a different OS. If still consistently a problem, then would think most likely be hardware/power. See step #2 in link below for how to create a bootable Knoppix CD if you want to try that. See [post=766270]How to recover your folders/files when Windows won’t boot[/post]
  7. tovette

    tovette TS Rookie Topic Starter Posts: 22

    I got my drive to work. I had a reboot switch in the back and that's all it took for windows to see it again. :)
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    Great news. And thanks for the update. Is good to know.

    Tho could you clarify... When you say "reboot switch" you mean a reset switch for the hard drive???? Which model Antec did you have? As don't think i saw any Antec hard drive enclosures with reset switches on their product page. Or was i looking for the wrong thing?

    Or did you mean you toggled the power switch off and on?

    In any case, i'm just curious.. and quite glad your problem is fixed :)
  9. tovette

    tovette TS Rookie Topic Starter Posts: 22

    I couldn't find it on that link. But I guess reboot switch isn't the most accurate description. It's a power switch on the hard drive casing. I switched it off and then plugged in the USB connector and then powered on the drive via that switch. And then everything worked fine again. If you want I can continue searching for that drive...
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for the info.

    Sounds like you "power cycled" (turned it off then back on) and re-plugged the drive. Good to know that helped! (in fact, don't know why that didn't occur to me to suggest it as well!)

    Glad it works!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...