Failed to query TCP/IP settings?

By ruju ยท 6 replies
Jul 12, 2009
  1. can somebody help me with this?...I tried to repair the internet connection of my laptop but the response was this....."windows could not finish repairing the problem because the following action could not be completed. Failed to query TCP/IP settings of the connection cannot proceed" .Windows Firewall/Internet connection sharing (ICS) could not be started.. can someboby help me fix this?
  2. Spyder_1386

    Spyder_1386 TS Booster Posts: 498

    hi ruju

    Do you have a static or dynamic IP address? Are you using a proxy server? Why were you trying to repair the connection? What were you doing when the problem first started occurring? What are your system specs including operating system?

    We need a little more information to help you out. Please try and give us anything that might be informative.

    Spyder_1386 :)
  3. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    log in using an Admin id

    use CP->Admin Tools->Computer Mgmt

    at the bottom->Services & Applications->Services

    You need Windows Firewall/Internet Connection Sharing started, but
    first ensure that these are already started; if not start them first and set
    the Startup Type of each to AUTO
    • Remote Procedure Call (RPC)
    • Windows Management Instrumentation
    • Network Connections

    Now start Windows Firewall/Internet Connection Sharing
  4. ruju

    ruju TS Rookie Topic Starter

    sorry for a delayed reply. thanx spyder_1386. I was actually trying to make a network connection when i suddenly deleted some files. i am not an IT expert, but i guess im using a dynamic Ip add, and my laptop system specs are CPU 440 @ 1.86GHz, 504 MB of ram Intel (R) celeron(R) M.

    your response is highly appreciated!
  5. ruju

    ruju TS Rookie Topic Starter

    thanks jobeard...TCP/IP

    thank you jobeard. I done all that but still windows firewall/internet connection sharing (ICS) service coulc not be started. It says "error 2001, The specified driver is invalid"

    your response is highly appreciated.
  6. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    Then this is the first problem to be solved.

    use run->eventvwr.msc
    click on the System in the left to see events in the right

    find the Error 2001 and open it
    click on the little document icon on the lower right

    come back here and follow-up with a PASTE of the data
  7. ruju

    ruju TS Rookie Topic Starter

    Error 2001

    thanks jobeard,

    I can't find err0r 2001. instead i checked error 7000 which says the same problem: " The TCP/IP protocol driver service failed to start due to the following error. The specified driver is invalid."

    your response is highly appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...