1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Failed to Write to Disk - Delayed Write

By Bluemouse ยท 10 replies
Feb 19, 2007
  1. Hey all,

    I am having an issue with a Western Digital 320Gb SataII drive that I purchased a little while back. The store I purchased it from insists that there is nothing wrong with the drive, but I think there has to be?

    The first time it happened, I was downloading files from a P2P application. Failed to write to disk on the partition and something along the lines of G:/$mft kepy popping up(I guess to do with the boot table on the disk?). Figured that there was just an error, so I ran a chkdsk, but it didn't find anything. I rebooted the comp, and tried chkdsk again, but this time it couldn't access the partition. I had a couple more errors or problems with it (tried partition magic, but that wouldnt even open because the partition table was screwed up or something), so I decided to backup and then format the partition. Great, everything eventually worked again, and I copied everything back.

    A couple of days later, I was copying some files over, and I had the same issue again, random popup saying something like "failed to write to disk - delayed write failed" and then my system crashed and I rebooted. Couldnt access the partition when I tried to chkdsk again. However, I still cannot find any bad sectors on it when I finally managed to get chkdsk working again (after a couple more reboots). It also took me three reboots/tries to get an image of the disk because it had problems reading it.

    Is there any way I could convince the retailer that there is something wrong with the disk or, if there isn't, fix what was causing the problem?

    Thanks :D

    Edit: Comp specs:

    2 Gb DDR2 Kingston Ram
    Asus P5NSLI Motherboard
    Core 2 Duo E6600 cpu
    500W psu
    2x 7600 gt Gpus
  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 316

    Well what you need to do is get a copy of Diskeeper. Go to www.diskeeper.com and get a trial version. Then you open that up, and analize the drive your having trouble with. Soon you can go into your options and run a program in there called Frag Shield or something like that. That will change your MTF size to a proper size (Cheoose Recommended settings) and the problems will go away. I had the same thing happen to my old 250 GB drive. But that should take care of everything.
  3. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    You don't have to convince anyone. Say it doesn't work and take it back. At the very least, the manufacturer (WD) will send you a new one - no questions asked - and send you a box to ship your old one back to them with.

    Lots of things can cause delayed write errors. Cable problems, voltage problems, electronic problems, mechanical problems... Delayed write errors happen when the operating system is not able to write to the drive and this is almost always a problem with the hardware itself. Take it back and get another.
  4. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I have tried that, they won't do it (well, I haven't tried the manufacturer, but the store I bought it from 10 days ago won't take it back unless it is defective). They insist that it is caused by something else, but I dont see how, since Ive tried other drives copying over the same files and they worked fine.

    For anyone interested, the retailer is Canada computers, just fyi.

    Wouldnt increasing the MFT size take away more of my disk space? Why would it only happen to this drive and not others?
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Just try to perform a standard NTFS format on the drive... If it still has delayed write errors, the drive is faulty. You might try the all 0's write too
  6. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    I tried to merge the two partitions together/format and I got an error as well.
  7. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    It is defective and I don't see how any reputable store would do such a thing... It doesn't even really cost them anything. They just send it back and get a new one from Western Digital whether it is bad or not.... I'd never shop there again.

    You can run the Western Digital drive diagnostic to determine if the drive has bad sectors or any other obvious physical problems: https://www.techspot.com/vb/topic7602.html

    Run the diagnostic a few times. If it fails once, then it is - without a shadow of a doubt - failing. In fact, I think you should just skip the test, take it back and tell them it failed the drive diagnostic test. They should deal with it accordingly.

    Western Digital will take it back for sure. So if you can't go through the retailer, then called up WD. 1-831-438-6550
  8. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    Yea, they said that they did a scan on it (they did) and apparently didn't find any bad sectors.

    They wanted to charge me an extra 15% so they could put it back on the shelf or something at a cheaper price.
  9. gavinseabrook

    gavinseabrook TS Rookie Posts: 316

    Still say just let Diskeeper place the recommended MTF size on there using the Frag Shield portion of the program and it will fix it. It will take up a little more space but only by a very small ammount. Its better then paying a restocking fee. BTW the reason I see it happening is because it is a big drive, and having windows perform the mtf get kinda odd. As I said, had the same thing happen to my 250 GB western digital (internal). Besides, what have you got to lose? If it dosnt work, then send the drive back.
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    I say do an all 0's write and that will fix it... This utility is included in a lot of hard drive diagnostic software
  11. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 180

    ok, ill give it a try. thanks guys
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...