Floppy just keeps searching

By vassil3427 ยท 10 replies
Mar 6, 2002
  1. The Floppy that just keeps searching

    my friend has an old slow computer, and its worked fine for him for the last 4 years, but now his floppy drive just wont work right.
    Stick in a floppy, and the light just stays on, it makes no noise, and the Hour glass mouse pointer just sits there, and it'll do it for hours on end and never get access to the floppy,

    I personally think its either DEAD, or severly dirty, either way I'm getting him a new one, I just wondered what you guys thought?
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Well, aside from the fact that your floppy disk cable is the wrong way round, I think either the drive or the cable has had it.

    Its best to replace both the drive and cable. They are not expensive and that way you should be sure that it works, unless of course you have a faulty floppy drive controller, in which case a seperate PCI or ISA card (probably taken from some old 486) is your only way to go.
  3. svtcobra

    svtcobra TechSpot Paladin Posts: 761

    have you tried different floppy disks? I had a disk that just died on me and it did the same thing that you just descibed on 3 different computers. At first it was the drive but after I tried it on a second computer and then a third computer I concluded that the disk was bad.
  4. uncleel

    uncleel TS Rookie Posts: 980

    If it's not the cable or the configuration, a floppy is cheap enough.

    Check w/ one of our sponsors www.jncs.com Floppy Drive, Teac OEM $15
  5. vassil3427

    vassil3427 TS Rookie Topic Starter Posts: 640

    Its definitly not the cable, as its been hooked up(and never un-hooked) for 4 years and never once malfunctioned before, I'll just get him a new drive, thanks for your responses:grinthumb
  6. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    That is probably the easiest solution, especially with these drives as cheap as they are. :)

    BTW....:wave: :wave: Welcome to 3D Spotlight forums :wave: :wave:
  7. Ai Hate

    Ai Hate TS Rookie Posts: 302

    so is my ASUS 52x CD-ROM cable. i've never unplugged it, but one day, it start to do funny things. swapping the cable cured it.
  8. erwin1978

    erwin1978 TS Maniac Posts: 290

    I think it's the floppy disk itself. I've often experienced the OS telling me the floppy disk needs to be formatted even though I just did it a second ago. I take it that floppy disks are losing their integrity and have reached their limits.

    Even the installation disk that came with my new harddrive was unreadable and I had to download the utility from Maxtor's site and save to disk again.
  9. vassil3427

    vassil3427 TS Rookie Topic Starter Posts: 640

    You know, we replaced the floppy, and it still didnt work....so i did what i should have done in the beginning, and disabled all programs that start up automatically when pc is booted.And it ended up being Norton:eek: Antivirus, lol. But thanks for the help
  10. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Thanks for posting your solution.
    Quite strange that Nortom was causing this problem..
  11. Th3M1ghtyD8

    Th3M1ghtyD8 TechSpot Paladin Posts: 664

    Try the cable, they only cost a couple of quid. Failing a new drive is only about a tenner, and they do get quite dusty after a few years.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...