Found New Hardware Hell & Create Longer Restore Point

By Suzy600 ยท 58 replies
Oct 21, 2013
Post New Reply
  1. Good Morning
    My Windows Vista is being invaded by Found New Hardware everytime I try and install printer/camera or connect ipod or memory card. I've been trying to reinstall after laptop had to be returned to factory settings. I've tried installing from disc and downloading which works ok until I have to attach to usb then get New Hardware Found which always fails. I've tried following this

    but don't know what chipset drivers are or where to find them. And I only appear to have the option to restore to 19 Oct even when I try to create new one for 12 Oct.

    I've been trying to sort this out for 2 days now and it's getting desperate!

    Please help.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Your printer will require its own driver. You should be able to find it on the manufacture's website. Have you installed/updated iTunes for your ipod?

    Let's look at the memory card next. Who makes it? what model is it? Plug it in the computer then List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
  3. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Good Morning LookinAround

    Thank you so much for getting back to me.

    OK - I've tried to install the printer driver from the disc and download it from Canon website but each time I'm required to connect printer to usb as part of installation I get Found New Hardware Wizard, which fails to find driver and I'm unable to get any further.

    I've downloaded an updated version of itunes which works fine until I connect my ipod via usb - again I get Found New Hardware - unable to find driver. On my itunes my ipod fails to show up when it's connected.

    Ok - I'll try the memory card - it's a Kodak SD card from my camera. Will update you on findings.

    Thank you
  4. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    I've connect ipod, camera, sd card & printer, completed the above steps and there is nothing in probem devices.

    There are however lots of Found New Hardware windows.

    I eagerly await next instructions.

    By the way - I've also looked at the and looked at the USB Mass Storage checks you advised. Of the files you mentioned, I only have the last one.


    My Windows Vista is Home Premium 32bit if that helps at all.​

  5. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, If I could add to this, until you have the correct printer driver ( & it's the Vista 32 bit & version) downloaded from the web site, then the 'Found new hardware wizard' will open until you have the correct driver installed.
    When the wizard tries to search you computer, it's not likely to find it, so the next option in the wizard is to 'browse' your pc for the driver.....that's the point where you need to point the wizard to where you have saved the printer driver. (Could be 'downloads' or somewhere of your choice. I normally use 'Desktop'.)
    Also printers are unusual in that some brands need the driver to be installed first, then the printer to be connected afterwards. The instructions do normally point this out though.
    One other point/problem is that a driver maybe downloaded as a 'zip' file, and that will need to be 'extracted' first, otherwise Windows won't be able to use it.
    Fairly easy to tell, just check the driver's filename... could be something like,
    'Cannon1234.exe' and that would be fine 'as is' because it's '.exe' rather than ''.
    *Regarding ipods, I have heard that you need to register yours with Apple first before it will work with itunes? And/Or install itunes first? I remember the same problem with a Christmas present a couple of years ago...... is this worth reading?...
  6. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello - Thank you for your advice.
    I have the installation disc and instructions for my printer still and there is no mention of installing the driver seperately, I've never had to do that previously. The printer installation file is Msetup4.exe and if I try and download the printer driver from the Canon website it's also an exe file.

    The printer instructions clearly state that if the Found New Hardware message appears to stop the installation process, disconnect usb cable, turn off printer and and start again.The Found New Hardware messgae pops up every time I get to the point in installation of the printer or the driver when I have to connect the printer to the usb.

    When I have tried Locate & install driver software on the Found New Hardware message, it prompts me to insert the install cd, it then is unable to locate driver & suggests going to manufactureres web site. I do not get an option to browse manually unless I go in through Device Manager but I cannot do this as part of the driver install process.

    I've tried to install the driver from the Canon website, I save it into Downloads, go in to Downloads select and run it but I'm not sure the driver is installing properly as when I try and find it through Device Manager it's not in the Download file even tho I can see it (and other files that do not show in Downloads through the wizard) in Programs and Features and if I open Downloads elsewhere I can see it there too.

    I hope this makes sense. I'm really confused by it.

    I'll have a look at the ipod link but my ipod has always worked before with my ipod so if it needs registered I must have done it at some point.

    I had to have my laptop returned to factory settings before all of these problems which is why I'm now having to reinstall it.
  7. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Ipod update
    My ipod didn't come with a disc. I've run a diagnostic test in iTunes the results included:
    Failed - No audio CD found (Audio CD was in drive)
    Failed - in device connectivity no ipod found but USB connectivity verified.
    Ipod does not show up on my iTunes or in Computer (neither does my camera or printer if I connect them).

    I have saved the full list of results if helpful.

    I also have a iTunes message (along with Found New Hardware) that says
    "The registry settings used by the iTunes drivers for importing and burning CDs and DVDs are missing. This can happen as a result of installing other CD burning software. Please reinstall iTunes"

    Would this stop iTune recognising my ipod too? I'll see if I can find other CD burning software - may be my camera software but it worked together previously.
  8. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, The CD/DVD burning software clashing issue can happen, I have seen this before.
    Guess it would only affect itunes if you wanted to create (burn) an audio CD from an itunes playlist. I have a relative who received an ipod 'touch' for christmas, and it took several days to work out why it wouldn't transfer files from the PC.
    I seem to remember it was the part about registering the device with Apple, then everything worked. ( I don't own an ipod so it's out of my knowledge.)
    I think the order was; 1) Download and install itunes 2) Connect ipod via USB
    3) A registration page appears, where you enter the details (serial nbr on back) of your device, then the drivers download.
  9. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello Mike

    Thank you for your suggestion

    I've uninstalled all camera sofware (Found New Hardware issues there too so it won't work either) so the CD/DVD message gone and it now finds my CD when inserted. I removed all previous iTunes files and reinstalled latest version from iTunes website yet again.

    But as I keep saying as soon as I connect anything to my laptop I get Found New Hardware message that pops up straight away. This stops any downloads or installs until I click on the Locate and install driver software tab, it then tries and fails to find drivers and I can't get any further.
  10. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, I think Apple stopped supplying driver CD's many years ago, you will only get the driver as a download, after your device is registered with them.
    It should look like this;
    Even if the 'new hardware' wizard launches, you can stop and cancel it, as you are not going to have the ipod driver on your pc anyway.
    But I would thought that in itunes there is an option somewhere in the menus to 'register your device'. (I would check but don't have it installed right now.)
    * There can be a problem with Windows storing info about too many USB connected device drivers on each port; and there is a small program that will clear out all the USB driver history... it might be worth trying.
    It's called
    There is a good guide for this to read;
    ** I use this one and I put a shortcut on the desktop to run it.
    When they say "elevated command" they mean; right click and 'run as administrator', on the drivercleanup.exe file.
  11. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Thanks again Mike

    I think the issue is that iTunes is not recognising that I've connected my ipod. If I cancel the Found New Hardware and go into iTunes nothing happens - no prompts to register. No ipod icon as usual.

    I can't find anywhere to register my ipod - I've definitely registered it previously anyway. iTunes help says I register when I connect my ipod...I can find no other regisration option but I'm not sure this is the problem.

    I've run the above clean up, logged off, turned off at plug, rebooted, connected my ipod and Found New Hardware appears for my ipod.

    My ipod does show in Device Manager with a ! and no driver set...code 1 message. I've tried pointing it to the itunes & ipod files but to no avail.

    I've also tried downloading the printer driver again. It all works until I connect printer, if I cancel Found New Hardware and go into device manager it shows my printer again with ! no driver set - I go thro the wizard to point to it in Downloads file and there's no file even tho I can see it if I open Download at the same time. My printer is still connected at this time.

    Any other ideas? I'm desperate as I'm missing out on work due to .I.t issues.
  12. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Hi, I'm now thinking that the printer driver might be a program that installs itself, in the way that some graphic drivers do.
    If you use the green and white tick USB uninstall icon in the taskbar, 'Remove hardware' so that Windows knows the printer has been unplugged, then find the printer driver, right-click on it, 'run as admin' as see if it installs.
    If it seems to install, then plug the printer back in, and check back in Device manager, or MS Word to see if the printer option has appeared.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I believe you have one, if not more, different problems going on. If you're really missing the usbstor.inf and usbstor.pnf files per above, then your USB storage driver is corrupt.
    > CD/DVDs, external disks and memory cards are all USB storage devices and need the driver to load

    Are your running Vista SP2?Look in C:\Windows\System32\DriverStore\FileRepository\ for folder names that start usbstor. These folders contain the different versions of the usb storage drivers that windows saved on your machine.

    Can you show me a screen shot of the usbstor* folders and their modified dates that you see? We'll first try to recover the latest version of the driver from the repository.

    /* EDIT */
    p.s. Did you run msinfo32 to check for problem devices while the New Hardware Wizard was open? I'd expect the device the hardware wizard is complaining about to appear as a problem device, so just wondering. Double check
  14. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello LookinAround, thanks for getting back to me.

    Yes it Vista 32bit SP2.

    I've located some usbstor in C:\Windows\System32\DriverStore\FileRepository but I'm not getting the option to paste when I print screen so...

    usbstor.inf_72a6a3e5 09/10/2013 17.58
    usbstor.inf_8416e98e 09/10/2013 16.03
    usbstor.inf_b9f18584 09/10/2013 17.18
    usbstor.inf_bb2778a0 02/11/2006 12.18

    09/10/13 is when the IT man had my laptop.

    I've double checked and no usbstor inf or pnf's in C:\Windows.

    I've tried the Run msinfo32 again, I tried each device-printer/camera/ipod/sd card seperately and cancelled the Found New Hardware message that came up when I conneted each device. I wasn't running find driver wizard through device manager. Nothing shows up in Problem Devices.

    Then I left the Found New Hardware message up having connected my camera again ran msinfo32 again - still nothing in Problem Devices.

    I left camera connected, went into Device manage where my camera shows up in Other Devices with ! (code 1). I started the driver finder wizard then also ran the msinfo32 - still no Problem Devices.

    Thank you so much for your help - it's very much appreciated.
  15. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello Mike

    This may be relevant I no longer get the USB uninstall icon in the task bar which suugests to me devices aren't being recognised.

    I've run the downloaded printer driver file yet again - it appears to install but as I've said the when I connect the printer it shows up with a ! (code 1) in device manage and when I try and find the driver it's not in the download folder where I've just run it as admin from! Once again if it's not showing up I'm assuming it's not fully recognising that a device is connected?

    I can't look for the printer in Word as when I try and install Office from the disc it freezes, I can only shut it down through task manager, which often takes 5-10 minutes then I have to shut my laptop down which can take 30 mins. When I go back in my CD DVD drive shows as corrupt (code 19) in device manager - I've used a help to resolve the corrupt CD DVD drive and not tried reinstalling Office since!

    Thanks for trying!
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    We're going to use usbstor.inf_72a6a3e5 folder as it has the most recent date/time stamp.
    > Download, unzip and install Hashtabs.
    > To verify C:\WINDOWS\system32\drivers\usbstor.sys is identical to the usbstor.sys in the most recent usbstor folder, right click each one->Properties->File Hashes tab. Their MD5 checksum should be equal. (You can copy one version's MD5 value and paste it into the Comparison box for the other. It'll turn green if identical)
    > Then simply copy the ubstor.inf and ubstor.pnf files from that same most recent repository folder to C:\Windows\inf.

    Now try again. I don't think you need reboot. Test each of your devices again. If still any problem, then reboot too and test.
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I just re-read your last post. Perhaps it was a typo, but you should check to see if usbstor.inf and pnf exist in the C:\Windows\inf folder not C:\Windows
  18. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello I did mean C:\Windows\inf - sorry for confusion.

    Can I just confirm - I've installed Hashtab

    I opened C:\Windows\System32\DriverStore\FileRepository\usbstor.inf_72a6a3e5 and highlighted USBSTOR.SYS - Properties - File Hashes

    I then compared this with USBSTOR.SYS in

    Tick went green.

    In C:\WINDOWS\system32\drivers\usbstor.sys - there are no usbstor.pnf or usbstor.inf's so I only compared usbstor.sys with Hashtab.

    In usbstor.inf_72a6a3e5 there is no usbstor.inf's just a usbstor.pnf and a usbstor.sys.

    Do I copy the whole usbstor.inf_72a6a3e5 into C:\Windows\inf ?

    Sorry LookinAround - my head is overloaded!
  19. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Apologies I made a mistake...I meant

    In C:\WINDOWS\system32\drivers\usbstor.sys - there are no usbstor.pnf or usbstor.inf's so I only compared usbstor.sys with Hashtab.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No worries. You're doing great.

    1. You compared the right copies of usbstor.sys and they match - which is good.
    That tells me your repository is corrupt as well. Folder usbstor.inf_72a6a3e5 contains the latest version of the USB Mass Storage driver files. Normally, the 3 files (which make up the driver) should be there: usbstor.inf, .pnf and .sys

    Do you have access to another Vista 32-bit SP2 machine to copy them from there?
  21. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    You are very generous about my it capabilities!

    Yes, I think my brother may still have his Vista 32-bit SP2...I will copy them and have another go. Will update you tomorrow.

    Phew the excitement of IT issues!
    Good evening.
  22. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Ok - files copied.

    This is promising...the following occurs when I connect flash drive or external hard drive :

    Found New Hardware message,appears.
    Safely remove Hardware icon appears (this has been missing)
    In Device Manager flash drive appears twice under Other Devices - both times with ! error code 1 No driver set...
    I now have a usbstor.pnf in C:\Windows\inf

    Awaiting further instruction. Thank you
  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Phew! Well, one problem down. I was hoping the USB storage driver would be the only driver issue. Windows loads multiple drivers for those devices and I'm less familiar with the driver sequence that follows but I'll give it my best shot!

    Tip: For Windows Vista an up, Device Manager logs a trace file in C:\Windows\inf\ We're going look at a trace and see if it provides more clues as to what's going on

    1. First we want to remove any USB storage drivers. Remove the flash/external disk etc. from computer and use the DriveCleanup tool Mike referred you to earlier

    2. Next, delete the current trace file C:\Windows\inf\

    3. Plug in your external USB disk drive. Windows will create a new trace file.

    4. Give it a couple minutes for all the Device Manager activity and messages to end. Then rename the trace file to and upload it in next post so I can take a look
  24. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Ok LookinAround what am I doing wrong?
    I've done 1-2
    The file I deleted was C:\Windows\inf\ (not dev.log but I didn't have dev.log & in Properties showed as .log file type.
    I've renamed it but I can't upload it as it doesn't show up in C:\Windows\inf. Or if I type in C:\Windows\inf\ and try and upload I get...
    The following error occurred

    The uploaded file does not have an allowed extension.

    Am I being a duffer?
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No, not at all! I know what's going on only because I've been down that road before!
    I forgot. By DEFAULT, Windows Vista and up hides extensions of well known file types. I HATE that option as it makes it easy misinterpret filenames and harder to change a file extension!! So I keep it turned off on my PCs

    Go to ControlPanel->Folder Options. Click View. Uncheck the box for Hide extensions for known file types. Now you should be able to see file file (with its extension), change the extension to txt and make TechSpot happy when you upload :)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...