Fuss with Intel Audio Studio

By WaveExistence ยท 6 replies
Sep 8, 2008
  1. I recently had to replace my motherboard the Intel D945GPM and format my hard drive due to an electrical failure in my house. The problem I am experiencing is that my audio is no longer directly controlled through Intel Audio Studio like it was before. I think it has something to do with having downloaded the newer version of the IDT 92XX driver from Intel.

    IAS is treating my 5.1 theatre as PCM Stereo under its digital output format and I'm only getting L & R readouts on my consoles digital input display. I am using an optical cable and if I'm playing music it seems my speakers can't handle all the audio levels anymore and if I open my cd drive or try to use a heavy app on my computer the audio chops up similiar to how you hear helicopter blades.

    Specifically I am using XP service pack 2 and a Panasonic SA-HT05 home theatre system. Before this IAS worked like a dream and I was in gamging heave, please help me solve this.
  2. X DarthMonkey X

    X DarthMonkey X TS Rookie Posts: 76

    If the older version of the driver worked fine, see if you still have a driver disk for it.

    Either way, you will want to remove the current unworking driver and reinstall it (either the old version or the new one) as the first step. If the issue persists, it could be a few things.

    If you've already done that, let us know.
  3. WaveExistence

    WaveExistence TS Rookie Topic Starter

    I tried uninstalling and reinstalling the one I have, and I can not get the old one off of my Intel Express Install CD that came with my motherboard. And for anyone who's wondering it is not my speaker system or my optical cord as I have tested them on my 360 and an old PS2. Also another thing I have noticed is that when I start my computer the New Hardware thing pops up in the corner and says something about IDT High Def Audio Codec which is what controls the output to my speakers but it always just disappears even if I click on it.
  4. X DarthMonkey X

    X DarthMonkey X TS Rookie Posts: 76

    Look in your computer's Device Manager under Sound, video and game controllers.

    WinXP: Control Panel > System. Click the Hardware tab, click "Device Manager"

    We're looking for anything which could denote an error, such as a yellow "!" icon. Also, if you could, list everything that is under the Sound controllers branch.
  5. WaveExistence

    WaveExistence TS Rookie Topic Starter

    Alrighty, the only things listed under unknown devices is Ethernet Controller and Unknown Device on Intel(R) 82801GH (ICH7DH) LPC Interface. As far as Sound and Audio devices I have this:

    Audio Codecs
    IDT High Definition Audio CODEC - This is the thing I got from Intel that has Intel Audio Studio in it.
    Legacy Audio Drivers
    Legacy Video Capture Drivers
    Media Control Devices
    Video Codecs

    I am fairly certain the Legacy drivers are for my old intel mic and webcam I've had since like '98, but I don't really know. Also on the IDT codec when I doubleclick and go to properties it has Audio Devices, MIDI Devices and Instruments, and Mixer Devices that all open up into one more subgroup. When I click on those it gives me an option to use/disable them or to not map through them. I don't know if any of this information is useful but I hope so.
  6. X DarthMonkey X

    X DarthMonkey X TS Rookie Posts: 76

  7. WaveExistence

    WaveExistence TS Rookie Topic Starter

    I have attempted to download the driver link you sent me but when I try to open it, it says it is a corrupt or unknown data type. I have WinRAR installed although I don't know if that is a problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...