Gainward Radeon 4850 HD Black edition problems

By crotchy
Oct 13, 2009
  1. Hi...
    So like tons of others,in the end my Gainward Radeon gave me a headache.
    The picture tells it all: all settings have dropped to zero and i can't access anything on it. I have to use "personalize" in vista to get some way of doing what i want. I've tried changing the drivers and i've cleaned it etc,but nothing works. Anyone got some idea what it could be?
  2. mailpup

    mailpup TS Special Forces Posts: 7,155   +458

    Before you installed new drivers did you uninstall (through Add and Remove Programs) the old drivers? Are you installing the full Catalyst package or driver only, leaving the old CCC? Where are you downloading the drivers and which version are you using?
  3. crotchy

    crotchy TS Rookie Topic Starter Posts: 18

    yes i removed everything by uninstalling (and looking for traces/leftovers). Rebooted and installed new complete package (suit). The problem became worse...with the new package installed the main monitor was not recognised as "1" but "2",and i had to use my tv as main. Tried to select my monitor as primary but then both monitor and tv went black. Did a system restore and now i'm back at the original problem.
    This is against all logic:-/ A simple setup that wont work. I'm all lost on this one...
  4. crotchy

    crotchy TS Rookie Topic Starter Posts: 18

    Today after using my pc i used my windows+L as always and now a few hours later when logging in...the tv was set to main again (another safemode with networking and system restore). Do i really need to go all the way and re-install?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...