1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Games running TOO fast on ATI Radeon 9800 Pro

By RockyRan ยท 13 replies
Oct 19, 2005
  1. Hello, I'm a new user, just registered in the forums about 10 minutes ago...anyway, I have a problem with my graphics card I believe.
    About a year ago I got an ATI Radeon 9800 pro graphics card and recently I decided to run some old games I had with them. By old I mean released in around 2000 or older. I noticed, however, that the games run TOO fast. In games such as in 3D the speed of the game can be around twice as much as the speed should be, I'm thinking because the graphics card is SO good, it runs the older games faster because it's capable of it.
    Is there any way that I can get the card to slow down in drawing and things like that so the games run in regular speed? Thanks in advance!
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    what do you mean, too fast? the frames per second (fps) rating is a standard way to measure a card's speed. your fps spec can never get too high, as it can only better the smoothness and appearence of the game. you'll have to be more specific about these games and in what way the are 'too fast'
  3. mailpup

    mailpup TS Special Forces Posts: 7,102   +419

    Maybe your old card was too slow and by comparison it only seems too fast now. A game can only run as fast as it is supposed to. A good card just allows it to.
  4. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    If you think it's a probably with framerate, you can try lopping Antialiasing on plus higher resolutions in order to help curb this.

    Try 4x/6x AA + the highest resolution the game and your monitor can handle. That should beat that poor 9800 Pro up a bit. :)
  5. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,404

    Strange. It doesn't sound to me like he is saying the fps are too high. It sounds like it is playing the games on "fast forward" with everyone running around much faster than they should be, and their voices sounding like chipmunks. I assumed he meant that kind of "too fast", not fps.

    I don't know what would cause this. Something strange is afoot. [insert evil chilling laugh]
  6. RockyRan

    RockyRan TS Rookie Topic Starter

    DonNagual, what you said is EXACTLY my problem. Mostly in 3D games, the speed of the game goes way too fast, as if the game was on fast forward, and the characters and enemies run way too fast and move way too fast. The sound is fine however, nobody sounds like a chipmunk. :p
    I know there can be some speeding up in other games and it might seem faster than normal because the old graphics card ran it slow. However, a lot of the "speeding up" problems are very noticable. In one of the 3D games for example, I remember a character walked like 2 steps before stopping and talking, but with this card, the animation is the same speed but he doesnt even go through his walking animation once and he "slides" really fast to his location. It's kind of confusing, I hope you guys can understand what I'm trying to say.
    For a more common game, I played SimCity 3000 U. with this card and when I press the arrow keys to move the map, the map moves way too fast. To move around, I'm forced to lightly tap the arrow keys to move the map or else the map moves way too much and way too fast.

    Any ideas on what could be causing this problem?
  7. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    HEY! This happened exactly with my GeForce FX5200, i learned something after i fooling around with nFORCEWARE v56.72! I set my AA and AP in 8X, this caused my DOOM, DOOM2 and HEXEN, HETERIC run in 20fps ^_^

    Should work with your ATI RADEON Catalyst Overdrive for RAdeon 9800 ^_^

  8. LNCPapa

    LNCPapa TS Special Forces Posts: 4,247   +448

    This problem as far as I've ever seen has to do with the speed of your processor and not your video card. Even an old Opengl or D3D game should only get an FPS boost from a faster video card. Have you changed processors since you last played these games?
  9. RockyRan

    RockyRan TS Rookie Topic Starter

    As a matter of fact I have. It's actually a completely different computer (self-built), so I also changed the graphics card while I was at it. So that means that it's the processor?

    bushwhacker, I'm glad to know someone has the same problem AND fixed it! I tried downloading the Radon catalyst driver from the site, but when I installed it I couldn't find any option that could change my AA.

    Also, I'd like to say I don't know much about changing graphics card settings.
  10. zephead

    zephead TechSpot Paladin Posts: 1,569

    yes, this sounds like a driver problem to me. some old games (i'm going wayyy back) use a timer function to determine the game speed coefficients based on the cpu speed. perhaps you should tell us what games in particular you are trying to tun, and what OS/service pack you are running them under.
  11. RockyRan

    RockyRan TS Rookie Topic Starter

    I'm trying to run games like DOOM (released 1992-ish), Spider-Man (released in 2000), Simcopter (released 1997), SimCity 3000 Unlimited (released around 1998), Age Of Empires (released 1997). All of these experience the "fast forward" problem.
  12. zephead

    zephead TechSpot Paladin Posts: 1,569

    yeah, driver problem. have you updated?
  13. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You can slow down your old games by using the CPU Killer programme from HERE

    When you have finished playing, just click stop, and everything will return to normal.

    Regards Howard :) :)
  14. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I used to program in QBASIC and one of the ways I would insert a sort of "pause" or like a make-shift timer was by creating a really long loop such as:

    for i = 1 to 900000000000: next i

    This basically would make my CPU "count" to billions or whatever the number was. On a 200mhz CPU, I could change the number to make the pause however long I wanted. Now then, LNCPapa's statement is exactly correct for this situation, because if the CPU is faster, it will count that number, well, faster! And thus my make-shift pause timers would go much quicker on a faster CPU. And thus I had to raise the number or just program a real timer!

    The programming for those games expected CPUs to be a certain way, and nobody new the CPUs of today were possible back then. So it is certainly true because your CPU, as well as video card, process those calculations so much quicker, it makes the game move faster. I've experienced this phenomenon as well.

    Couple things you could try:
    One is to try loading the game in XP compatibility mode. Create a shortcut for your game, unless you have a shortcut already. Right-click the shortcut and choose Properties. Then go to the compatibility tab, and select for Windows 95. This just might work.

    The other option is to find some sort of emulator that will process the game in the same speed of an older computer, or basically limit your PC. But I've not looked in to those. I will if you're interrested, I might be able to find something.

    good luck!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...