Games won't start after installing a new vga?

amon47

TS Rookie
[SIZE=13px][FONT=Helvetica Neue]Hi ! [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]I've just bought a new vga (Radeon HD 7850). I had GT 240 before. [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Everything was fine, I downloaded the drivers, played some games and everything was ok. [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]After testing it, I decided to uninstall the Nvidia drivers because it seems to me that I didn't need them anymore. I did it using the programs and features in Control Panel. after restarting the PC, the 2 games I tried didn't start. [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Assassin's creed IV Black Flag: when I tried to start it, nothing happend. and nothing changed in task manager. [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Battlefield 4: It says that I need directx 10, which is weird cause I have the newest directx installed on my PC.[/FONT][/SIZE]

[SIZE=13px][FONT=Helvetica Neue]Also, KMplayer won't work... it doesn't show any video but plays the sound, VLC and jetaudio work just fine [/FONT][/SIZE]

[SIZE=13px][FONT=Helvetica Neue]System Information: [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]OS: Windows 7 Ultimate SP1 [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Processor: Intel Core i3 CPU [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Motherboard: J&W JW-H55T-PRO [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]RAM: 8 GB [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]VGA: Radeon HD 7850 [/FONT][/SIZE]

[SIZE=13px][FONT=Helvetica Neue]So... what should I do? [/FONT][/SIZE]
[SIZE=13px][FONT=Helvetica Neue]Thanks in advance[/FONT][/SIZE]