Having a problem with my mass storage devices

By Stevey ยท 6 replies
Aug 18, 2014
Post New Reply
  1. HI, I'm having a problem with my mass storage devices. I updated my bios on my Asus z87 pro motherboard and since I did any of my usb sticks or WD My Passport wont open... PC says it tries to download drivers but can't. It sees the unlock disc for WD My Passport but wont let me open it and has the yellow exclamation mark by it in the device manager. As for the usb sticks.. they don't even show up even though they do in the bios page and they make a sound when you slot one in to a usb port.. so I don't think its the ports. especially as other items like flight yoke, pedals and mouse etc all work in the various usb ports.. its just the mass storage devices. I have looked at the files you suggested might not be there (as above) and all are. so bit lost as to what to do. :(

    Any ideas?
    SuperSoph_WD likes this.
  2. SuperSoph_WD

    SuperSoph_WD TS Rookie

    Hello, Stevey!

    I think the issue you are facing is due to faulty installation of drivers.
    The yellow exclamation mark in the device manager indicates that there's some kind of system or driver issue.
    You mentioned you updated the bios on your motherboard, but did you update the drivers for it as well?

    I suggest to take a look at these links:

    In case you forgot the motherboard drivers update:
    You can try running the fixit from the following Microsoft article:
    Another thing you can try is running the Hardware and Devices troubleshooter and check if it works:
    Or refer to this WD article that explains how to change the drive letter of the external drive and see if it helps: http://wdc.custhelp.com/app/answers/detail/a_id/137

    If you need further assistance, let me know.
    Hope this helps.

  3. Stevey

    Stevey TS Rookie Topic Starter


    I tried all of the above. When I did the hardware troubleshoot it said it noticed a problem with the drivers...I applied to fix it but it said it couldn't download them and the box that came afterwards showed red crosses by the actions it was trying to do.
    A friend of mine came round with windows 8 on a usb stick and booted my PC up from it.. everything worked fine. We could see the usb storage devices and access them. So it must be software and not hardware issue?

  4. SuperSoph_WD

    SuperSoph_WD TS Rookie

    Hey, Steve!

    Yes, I think so too. It looks like a corrupted driver problem to me, so it must have been a software issue.
    Probably if you have recently performed any changes to the drivers or installed some new software, it may cause error bugs to the drivers.
    It's not an uncommon problem and many times users end up solving the problem with a system repair or system restore, and from what you say I guess this is exactly what you did as well.
    If everything runs smoothly now, I think you shouldn't be worried about any hardware problems.

    Glad you found a solution.
    Let me know if there's anything else I can help with!

  5. Stevey

    Stevey TS Rookie Topic Starter


    Yes, bit of a relief that its not hardware.. I didn't like the idea of sending my motherboard back to Asus...I've heard you have to wait a long time to get it back with some companies.. don't know about Asus.
    I'm going to keep trying to find the file that is corrupt.. if I still can't find it then maybe a wipe and reinstall windows 7 to fix it?

    My restore dates don't go back far enough.. any suggestions on how to find the file? Or would you just do a reinstall?

    SuperSoph_WD likes this.
  6. SuperSoph_WD

    SuperSoph_WD TS Rookie

    Hi again, Steve!

    I think you should try System File Checker in Windows.
    It's a utility that allows you to scan for corruption in Windows files and replace them with a cached copy.
    To do this you need to run sfc /scannow in Command Prompt
    I found this Knowledge Base article that explains exactly how to do it:
    I really hope this works for you.

    Let me know if this helps. :)
  7. Stevey

    Stevey TS Rookie Topic Starter

    Hi SuperSoph

    I tried the sfc scan but it still wouldn't work..
    However, we have now re-installed windows 7 and its sorted the problem for me.
    But thanks for your help!

    SuperSoph_WD likes this.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...