HDisk Boot Failure Insert Disk And Press Enter Problem!

By lvl70druid ยท 12 replies
Jul 31, 2007
  1. Hi, I was building my first machine today, everything seem to go smooth except when I went for the final run/test. It boots the Logo and starts going through a ...scan, of some sort detecting devicers and whatnot. And prompts me with "HARD DISK BOOT FAILURE INSERT SYSTEM DISK AND PRESS ENTER"
    Now the only problem i had building this thing was the directions on the hard disk-to mobo directions. Its a WD 160g Sata2, theres no ribbon cable slots on the back of the drive, so i figured the red SATA cable that came with the mobo was for the different type of Drive instead. It was connected from there to the mobo, and itself to the power supply from 2 wires. And this is where im lost as to how to fix the prob.

    Restated Q. How Do I Get Rid of "HARD DISK BOOT FAILURE INSERT SYSTEM DISK PRESS ENTER." Error. / What should i be connecting on this Hard Drive of mine.
  2. captaincranky

    captaincranky TechSpot Addict Posts: 12,974   +2,527

    Getting The Boot.........

    WD Sata (retail boxed) drives come with a proprietary cable. it has a wide end at the drive and must be used with a 4 pin "legacy" connector for power. This is the same power cable you would use for a standard IDE drive. Using a standard SATA cable it should just connect to the board (at SATA 0, for 1 drive) with no other cable used. That is what you're calling a flat cable.
    It won't boot from the hard drive because there's no OS present. The BIOS must be set to boot from the CD (or DVD) drive first which should have the Windows CD inserted when you power up. Some boards will run Sata as IDE automatically and some boards require you to install a SATA driver before they'll recognize the drive. If you're running XP and don't intend installing RAID drivers, you must run the drive as IDE. Usually, this is in BIOS under drive configuration. What you're calling a "ribbon cable" is an IDE only connector. A ribbon cable (40 or 80 pin) has no use whatsoever in a SATA installation!
  3. lvl70druid

    lvl70druid TS Rookie Topic Starter

    Well I purchased it form Newegg and it came as the harddrive alone, with a nero cd. I have 3 ...i believe sata raid cables, that came with the mobo, each having 2 black ends with a power supply connector. But what your saying is i dont need that cable? I just need to connect my "flat" SATA cable from the Mobo to the HD and the power supply directly to the HD? ..Did ig et that right?

    ....Im installing Vista and have the CD in hand ready. Ill take a look at the BIOS setup and see where to make sure its set to boot from CD. It reconizes my HD and notifys me theirs 153g free. I'll load a picture of the mobo i have with the problems i had first mentioned in a visual manner.

    ..Now that i look at it on web the picture isnt as big....So if you cant see it...the Primary (blue) slot i have used to plug in my ROM Drives (2) ..just want to make sure that is ok.
    And the red Raid slots is left alone witht he black slots having one cable connected from there to my HD. Ill go check on that BIOS crap now..
  4. lvl70druid

    lvl70druid TS Rookie Topic Starter

    Well, no luck yet, I looked closer towards the mobo and i only see SATA 1-4...Dont see a SATA 0...am i not seeing something? I set my Boot Sequence to ROM/Hard Disk/Removable...which is what i was to do to have my OS be installed..correct?

    ...Now i hopped in the Raid Config...and it doesnt even seemt o reconize my Hard Drive is even there...god im soooo lost.

    - Frustrated Eddie.
  5. garreg_ddu

    garreg_ddu TS Member Posts: 19

    Have you looked on the Western Digital web site? Go to http://www.westerndigital.com/en/ and then search for the drive (I think you must have a WD1600JS - look on the label) and then follow the links to the interface guide. Can you test your cables on a known good working machine?
  6. lvl70druid

    lvl70druid TS Rookie Topic Starter

    I checked out the interface guide, my HD is actually a WD1600YS, WD Cavier RE16 ...The connector side of the Hard Drive has a SATA port, no EIDE ports. And Im using a SATA cable that came with my MOBO. If you notice the picture link above, thats ym MOBO, i installed the wire in the bottom right (SATA 1) black slot, and connected the power supply directly to the HD. Butthe pc does nothing.

    ...Should anything else be connected to this HD beside that SATA cable shown in the guide, and 4pin power supply connector? Everything i do leads to the HD not beign read it seems. In the Boot section of BIOS under Hard Disk Drives, nothing shows up except for "Add-In bootable cards"

    .....Ive tried to of the 8 red SATA cables it came with in the same machine....neither worked.
  7. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Move the hard drive to SATA1. You'll need two cables running to the hard drive You'll need the SATA data cable (red cable) and the power cable from your PSU. The power cable can be either the SATA power cable type OR the regular molex cable if your hard drive has both, BUT ONLY USE ONE OR THE OTHER NOT BOTH! When you turn on your computer you'll see how large the hard drive is during post. If you see that then you have installed the drive correctly. To actually get your computer running you need to install the OS. Put the OS disk into the ROM drive and boot the computer. Watch the motherboard POST and when you see something like: push any key to boot from disk, PUSH a key. You don't have a RAID array unless you have at least two hard drives, so don't worry about that. Let the disk run and follow the prompts.

    The reason your computer will not boot from the hard drive is because it doesn't have a boot sector yet. Installing the OS will create the boot sector, and then your computer will boot from the hard drive.

    The error message you're seeing just means that your boot sector is missing, not that your motherboard can't find your hard drive.
  8. lvl70druid

    lvl70druid TS Rookie Topic Starter

    At first i saw how much it had...it would say 153gigz out of my 160 drive...now it says nothing...even under BIOS hard disk drives...
    right now i have the Molex cable from my PSU put directly into my HD...and the SATA (red) cable plugged into the hard drive...and its not reconizing.....is it a bad drive then?
  9. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12


    The molex port was covered at first wasn't it? If it was covered, cover it back up and reinsert the SATA power plug. The old molex socket may not be active any more and WD just covered it up instead of redesigning the drives rear plate.

    *EDIT*Because you changed the disk controller device to it's RAID function you will have to chage it back to PATA or Emulate PATA in the BIOS. RAID functions are not usually present unless you change functions in the BIOS first, so change it back. You may also need the driver from your motherboard install disk put onto a floppy disk so the operating system will recognize the disk controller. In just a minute I'll post a link to the non RAID driver if i can find one. /*EDIT* I could not find one.
  10. lvl70druid

    lvl70druid TS Rookie Topic Starter

    Nah..it wasnt. It was left open. I may have plugged 2 power cables one from the 2Sata ended/power wire along with the psu wire into the drive itself...would that instantly kill it? Nothing came with the drive except for a Nero cd...right now i just have the drive installed with psu plugged into the drive and one Sata cable to the Sata1 slot on my mobo.
  11. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    I'm sure it didn't do anything to the drive as long as you didn't power-up the computer with both power cables plugged in. I'm not sure how quickly the drive would be effected if both power cables where plugged at the same time because I've never done that before. Does your drive still get warm? Set your disk controller back to PATA and try again.
  12. captaincranky

    captaincranky TechSpot Addict Posts: 12,974   +2,527

    Cunfused in the Colonies......

    The PSU of the computer (if i'ts ATX 2.0 compliant) should have a separate buss with a Sata type connectors. As Cinders says you can use one of those, or a Molex (The 4 pin connector you would hook up to a CD/DVD drive. But not both. Manufacturers strongly caution not to use 2 power cables, but they generally say the drive won't function, no that it will go up in smoke. The WD cable COVERS the SATA power input to the drive and that's why you need to use the "legacy " power connector. It's just a BS locking scheme because the standard SATA cables fall out occasionally. If you bought your drive as OEM, it would come wrapped in an antic static bag and not much more. A "retail boxed unit, would be just that and come in a fancy box with pictures and a WD cable WD installation disc, like that. Most digital devices are numbered from 0, not 1 and your board must be the exception that proves the rule. My Intel board has 6 SATA connectors, numbered from 0 to 5.
    If you are installing Vista you should be able to run the drive native as SATA without using a raid controller. This mode is called, AHCI, you can try setting the BIOS to that.
    What Cinders is calling "PATA" is the mode I'm calling "IDE", they should be identical, but different board/BIOS combination may refer to them in different terms.
  13. garreg_ddu

    garreg_ddu TS Member Posts: 19

    Might be a silly question, but when you power up the machine can you tell if the drive is actually spinning? Are any of the connectors bent or damaged?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...