1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Help with hard drive & USB caddy

By Twigkat ยท 7 replies
Aug 13, 2007
  1. Hi

    I'm helping out a friend to try and recover data from her crashed computer. i have a USB / IDE caddy, have removed the hard drive and plugged in - having removed the jumper from the back panel as advised (in fact I've also tried it plugged into the slave part).

    I connect up, the blue light comes on on the caddy - I have seen drive letter H assigned to it in disk management but can not see the drive assigned within my computer so cannot access the drive. So it's as if the drive is seen *somewhere* on the pc but not in a way that I can access it or download the data from.

    As I have already done this for my own pc (connected a hard drive and downloaded all data) I know that I CAN do it :) but not on this hard drive for some reason.

    I've even downloaded tweak ui in case a drive letter wasn't able to be seen but that doesn't help either.

    When I connect the hard drive the whole pc slows down as well - so it is seen somewhere by this pc.

    Any thoughts much appreciated!
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    Is it possible that your system is formatted to FAT when your external drive is formatted NTFS?
  3. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    My system is NTFS - as I believe the other one was. In fact my system has been partitioned at source - the OS is located on NTFS (XP pro) and there is also a FAT partition. My PC is an ACER; the drive from the PB computer is a seagate if that makes any difference. I've had a look on there and it's not really obvious what to look for; whether I need some supporting software to read the disk.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    IDE hard drives mounted in external (usb) cases need to be set as Master... The brand of IDE drive makes no difference
  5. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    If you can see the drive as drive H in disk management but it is not otherwise visible, chances are that the system cannot see the partition. When it is shown in disk management, does it show a status (eg: healthy)?
  6. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    All's well now, thankfully - it just seemed to take some time to be recognised. Have now rescued all the data which is great!

    Found lots of temp files etc clogging up system, along with a few trojan viruses. Cleaned up, found boot.ini file seemed to be corrupt as well and have altered.

    Then put disc back into original pc, fired up but screen completely blank even though whirring away quite happily. Won't even bring up BIOS screen; put windows XP home disk in to see if that made a difference - again seemed to be happily whirring away but screen still blank.

    Any other ideas that I can try - maybe another file is corrupt? The screen is fine btw as it works with my normal home pc. Could there be some other graphic software corrupted? How can I check / test? Help!!
  7. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    Does it pass the POST?
    you say you altered the boot.ini file - if this was corrupt chances are the rest of the boot structure is too.
    you may have to reset the BIOS to get it to boot.
    Can you get at the BIOS settings at all?
  8. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 17

    I have a suspicion the video card may be at fault, but just scratching around at the mo.

    I cannot get into the BIOS with the hard drive in its original case; when I put the drive into another PC I can get the BIOS up no problem - to try get it to boot from either CD or floppy (although it won't - my win xp disk is not the correct on in any case, and the boot disk I tried to create wouldn't work either); I have also tried booting in safe mode with / without networking and it gets stuck at a file called mup.sys (I think!).

    It may just be the boot structure that is corrupt but even so if I can't even get the bios up, nor boot using a Win XP disk... I'm a little stumped!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...