Tech Stocking Stuffers: 18 awesome gifts under $50

How to change resolution in Ubuntu 9.04

By DjKraid
Sep 24, 2010
Post New Reply
  1. Hi!

    So I have this tiny problem...I just installed (activated) the nVidia drivers in a computer and then it wanted me to reboot...ok so far...but when the computer booted up again the resolution was set to 600x400 or something like that so everything is f**ing big and no windows can fit in the screen...
    Usually to change the resolution I press "System -> Preferences -> Display" but then it says "It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?" and if I press No I come to the "old" resolution changing screen but I can't do anything with it...i can only see the upper half or the window...And if I press Yes I come to NVIDIA X Server Settings but I can't do anything with that...if I click somewhere the windows just jumps around, so it doesn't "understand" that I press btns in the window and's a bit annoying...
    I also tried to disable the graphics driver but hay...I can only see the upper half of that window too so I can't do anything with that either...

    SO how to do or what to do..?

    some specs:
    ubuntu 9.04 (fresh install)
    AMD Athlon XP 2600+
    3x128Mb DDR Ram
    nVidia GeForce4 MX420 (agp x8), driver version: 96.43.13


    I updated to ubuntu 10.04lts and still have the same problem...
    xrndr --newmode and xrndr --addmode does not what then?

    I also managed to remove the graphics driver once and then averyting looked just fine but it was realy then I reinstalled the driver and same again...

    One other thing...the resolution is 640x350 (9:5) and that s*cks
  2. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    Its purely a driver problem, which the installation below should hopefully solve:

    sudo apt-get install nvidia-96
    Once completed, restartx and once logged back in, you should show native resolution.

    If you need to adjust the settings for the Nvidia driver, fire up terminal...

    P.S. Anything can be removed with this command in terminal..

    sudo apt-get remove *package-name*
    Terminal is fun, and simple once you get used to using it. :D
  3. DjKraid

    DjKraid TS Guru Topic Starter Posts: 548   +25

    #Leeky - didn't work...same problem still but I finally (after a big fight) got to change the resolution in NVIDIA X Server Settings. I got to grab the top of the window so I could move it a bit down and when it wasn't pinned to anything (side of the screen / bottom of the screen) it stopped to jump around so I got to see that it had the resolution on Auto and there I then got it changed and now it seems to work fine, so I guess I'm happy with it now.

    thx anyway :)
  4. DjKraid

    DjKraid TS Guru Topic Starter Posts: 548   +25

    I take the recent post back...after re boot the resolution is the same again...but I'll see it it works better with an other graphics card...

    When I press "Save to X Configuration File" it says "Failed to parse existing X config file '/etc/X11/xorg.conf'!" ...what does that then mean?

    Now it works (like life, in mysterious ways)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...