I think my new Vid Card doesn't have a temperature sensor

By Drivenby
Nov 10, 2007
  1. I recently bought a Jetway X1950 Pro -256mb ... i have tried using riva tuner and ati tool but i can't get temperature readings on any of those programs.

    On a side note : For some reason now i'm getting 4 video cards in display settings, Primary and secondary for my card and primary and secondary for my internal card (which is disabled in the BIOS but still shows up)
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    What about Everest Home Edition, SIW and Speedfan? Also, have you tried checking it from the Overdrive option in the Catalyst Control Center.
  3. Daveskater

    Daveskater Banned Posts: 1,687

    all graphics cards will have a temperature sensor on them, it would be more likely that yours is broken but then you should be getting problems e.g. pc shutting itself down

    however, riva tuner and atitool don't give temp readings as far as i'm aware, and i have both :)
  4. Drivenby

    Drivenby TS Rookie Topic Starter

    Apparently the company that made my CARD (Jetway) isn't very OVERDRIVE friendly... my card doesn't support it. So all sensors are locked away .
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...