Installing Applications in Ubuntu

By saif ยท 8 replies
Jan 13, 2007
  1. I use Ubuntu Dapper 6.06. I have many games and various software on a CD. They all are in tar.gz format. When I extract them, there is no installer or anything through which I can install it. Are these files compatible with ubuntu? If yes, please help me install them....
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Didn't you get any instructions for these things?

    tar.gz is just a generic compressed archive like .zip. It could contain anything. They might be official software packages that are actually installable (a la Slackware), statically linked binaries you can just run directly, source code that you have to compile..

    Do you know anything more about this "a CD"?
  3. saif

    saif TS Rookie Topic Starter Posts: 48

    Thanks a lot for the reply Nodsu...
    Actually what I wanted to say is that when I extract the tar.gz file, I find nothing except for some files and there is no installer with it. I have a screenshot of what it looks like. Please help me install these. I have games like Racer and Torcs but they too look somewhat like this...

    Attached Files:

  4. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    screen shot is useless -- think you posted the wrong one :)
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    LOL, yep useless.
  6. saif

    saif TS Rookie Topic Starter Posts: 48

    Oh, sorry, I uploaded the wrong image...Here is the correct one...
    Also. there is a text file in it with instructions on how to install. It goes like this

    1 - decomress the tarball:

    $ tar xfvj torcs-xxx.tar.bz2

    2 - build and install:

    $ cd torcs-xxx
    $ ./configure [--prefix=PREFIX (default /usr/local)]
    $ make
    $ make install # installs in PREFIX/share/games/torcs PREFIX/bin and PREFIX/lib
    $ make datainstall # important!

    3 - run TORCS

    if PREFIX/bin is not in your $PATH

    $ cd PREFIX/bin
    $ ./torcs

    But I tried it and cant understand it..

    Attached Files:

  7. saif

    saif TS Rookie Topic Starter Posts: 48

    Why is'nt anyone replying? Is it because no one knows to solve my problem?
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "But I tried it and cant understand it.." is not a very helpful hint. And if you can't make any sense of it, then you are better off not trying to compile that stuff.

    Throw away that CD, fire up Synaptic and install the binaries.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...