Installshield Error 5004 : 0x80070005

Not open for further replies.


TS Rookie
Hi, can anyone help me with this problem.
I've recently been getting this error while trying to uninstall anything via CCleaner or Control Panel's Add/Remove Programs:

Error Code: -5004 : 0x80070005
Error Information:
>SetupDLL\SetupDLL.cpp (2013)
PVENDOR:Futuremark (
@Windows XP Service Pack 2 (2600) IE 6.0.2900.2180

I've been running my AVG virus scanner, Spy Sweeper, Spy Bot, AVG Anti-Spyware and various mechanic tools but I can't seem to fix this issue.
Could anybody shed some light on this for me?
Many Thanks


TS Enthusiast
Not sure I can help with the specific error, but before you format again you might try sfc /scannow and reboot to fix any problems with your OS.

A Google search found this that might help.


TS Rookie
Some Solutions


I was able to find information on this error online. This is a very rare error message.

I found a resolution regarding permissions in the registry under HKEY_LOCAL_MACHINE\SOFTWARE that gives the following steps:

Propagate the permissions of the key HKEY_LOCAL_MACHINE\SOFTWARE down to its child objects with these steps:

1) Right click on the key HKEY_LOCAL_MACHINE\SOFTWARE
2) Click on 'Permissions...'
3) Under the tab 'Security' click on 'Advanced'
4) Tick on the checkbox of 'Replace permission entries on all child objects with entries shown here that apply to child objects'

When I followed these steps a message came up saying that it could not change the security in some of the keys/subkeys.

When I ran the install shield it gave the -5004 error again.

The next solution was as follows:

In cmd/command prompt you type in "at [time] /interactive cmd.exe" replace time with a valid time either 1 or 2 minutes ahead for example its 12:00 so I'd use 12:01 (i.e. at 12:01 /interactive cmd.exe), at the time you specify a command prompt console will appear. This is not a normal command prompt it has system rights and if you browse to the install package you are trying to run and run it, it should install Correctly.

After doing this step I was able to advance in the installshield without the -5004 error but would kick me out of the installshield saying I had used an invalid key, even though it is a valid key. So I moved on to the third solution I found.

I deleted the C:\program files\common files\installshield directory.

I then tried running the bmisuite.exe without the special dos window and got the -5004 error again. I then ran the .exe through the special dos window from the second solution and was able to install the program. I then tried running the exe outside dos (to initiate an uninstall) and the -5004 error happened again.


Based on the steps above I am concluding that there are registry settings that we did not have rights to without using the special dos window that had the needed rights. Also the Installshield was holding things up as evidenced by the inability to use our backdoor product key until the c:\program files\common files\installshield directory was deleted. I assume that the proper rights could have been applied to the registry but did not take the time to figure out what specific items in the registry would need to be changed.

The problem seems to happen when users or their rights have changed. The registry seems to have a problem giving rights to needed entries.


TS Rookie
All of theses are wrong

I got this from a wiki article, but I can't post links until I have 5 posts, which I don't have yet.

SOLUTION to error -5004: Renaming Program Files/Common Files/Installshield/Professional, or Program Files (x86)/Common Files/Installshield/Professional. Any name other than Professional will do.

I changed the name of the folder from "Professional" to "Pro." I can't believe IT ACTUALLY WORKED. What a simple solution to a very menacing problem. InstallShield failed big time letting this error go unnoticed.
Not open for further replies.