1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Intel mobo will not POST

By deluxman ยท 9 replies
Jun 1, 2009
  1. Hi guys,

    I have been having issues with my desktop computer for a while. Here is my specs:

    -Intel D975XBX2
    -EVGA 7600GT
    -Memory DDR2 800 4gb Crucial Ballistic
    -Seagate 160GB SATA (2 drives)
    -Win iXP Prof Edition

    Lately, my computer will not POST when I had it cooled for over an hour. When the computer is turned on, all I get is a blank screen. It will not POST to the BIOS.
    However, if I did not shut it down, instead just put it on "Stand By" Position even for days, I could get it to on again instantly. So with this problem, I have been always putting it to sleep position instead of turning it off completely and this has been fine for quite sometime.

    But today when I had it turned off completely and turn it back on it never gets back to my BIOS. Looks like to me the BIOS is corrupted.

    I tried resetting the BIOS with the jumper and also removed the battery for an hour, it still does not solve the problem. So until now, the computer will never get to POST. All I get is the fans on but no video signal and no POST.

    Any idea?? This is really killing me. I am very certain is the BIOS problem as the video card seems to be working fine and like I said if I were to put it to sleep and use it in the next second or hour, I can use the computer for hours without any hiccups.

    I need advice from someone who used to have this problem and able to resolve this. I am so desparate to get it fixed. By the way, i had tried to took everything apart by removing all drives, cd rom, and just test the mobo but it still shows the same result, which is just blank no video signal and no beep either.

    Thanks again....
  2. captaincranky

    captaincranky TechSpot Addict Posts: 14,348   +3,583

    Bad RAM or Bad PSU.

    Sometimes one voltage segment of a PSU will fail, giving symptoms such as you describe. Sort of like the fans are on but nobody's home.

    I >think< Intel's RAM beep code is 3 short.

    Tutorial "No POST"; https://www.techspot.com/vb/topic53866.html
  3. deluxman

    deluxman TS Rookie Topic Starter

    I did try replacing the psu and same effect....power on, fans on but no POST.

    I also tried puting the ram one by one but same thing happened. I had 4 X1gb of DDr2 800

    U think the BIOS is corrupted? If that is the case, is there anyway to save it? or do I need to get a new mobo?
  4. captaincranky

    captaincranky TechSpot Addict Posts: 14,348   +3,583

    Did you go through the "No POST" tutorial?

    Some boards have a socketed BIOS chip. If this is the case, the chip can be replaced. If the chip is soldered in, that's a "send me to the shop", (or trash) situation.

    It's just a guess but I doubt that your Intel board has a socketed BIOS.

    Check out this site for BIOS info; http://www.biosman.com/
  5. deluxman

    deluxman TS Rookie Topic Starter


    Before I actually ordered a new bios chip, do u think most likely is the BIOS or just a bad mobo? I really hope my diagnostic is right but really not sure. i wanted to try recover the bios through a floppy but the computer won't post to the cd rom nor floppy.

    I really hope someone in the forum have the same issues with me and able to pinpoint exactly what the source of the problem is.....
  6. captaincranky

    captaincranky TechSpot Addict Posts: 14,348   +3,583

    Well, you have gone through a process of elimination with the rest of the hardware. So, it's down to 3 suspects; the board, the BIOS, or the CPU.

    I don't actually know. But, I've seen a lot more boards fail, than CPUs or BIOS chips.

    BIOS problems usually arise after a failed update. At least when it happens that way, you can directly correlate cause and effect, it's not guess work.

    I guess that it's a stretch to think you might be able to pull the CPU and test it in another board. Is there a reason that that could have failed? Overclock maybe?

    Does this board actually have a socketed BIOS chip?

    Is the CMOS battery dead? did you check or replace that? That's the cheapest thing you could eliminate first.....Because that might just do it.
  7. deluxman

    deluxman TS Rookie Topic Starter

    I did check the CMOS battery and it is good. I have not checked the CPU though. As far as BIOS, I did not do any update to it. So I am so confuse as to what could be the cause of this blank screen. Are you familiar with this motherboard I have? I was reading some forums saying that you actually need to install the Marvell or Intel driver before you installed the OS.

    I don't think I did that but it works fine since I installed my Win XP.

    Can't think of anything else here???
  8. captaincranky

    captaincranky TechSpot Addict Posts: 14,348   +3,583

    If you say it was working before you shut the machine down, then it's probably not the CPU, just a bad guess on my part.

    Have you tried to boot the computer with either no HDD or a clean HDD, (Nothing on it whatsoever)?

    I had a G965WHMK "Media" series board. It was unusual in the fact that it needed to have drivers installed before the ACPI would function. Before the driver was installed, the computer wouldn't go into standby. Never saw that in another board. Intel has a "chipset identification utility", that needs to be installed, but I'm not sure of the order.

    As fate would have at, I fried the BIOS on that board trying to update it. I'm pretty sure all the info I had on that board was trashed, but I'll look around for it.
  9. deluxman

    deluxman TS Rookie Topic Starter

    hello folks!!

    I have great news for everyone. After having a chat support from Intel technician, he suggested finding a different ram and apparently it works. VIOLA!!

    So the main problem of my computer is that the memory I have is actually 2.0v and my mobo (Intel D975XBX2) is only supporting 1.8 - 1.9v. What is weird though, i have been using this memory for almost 2 years and only now it gives me problem booting. But as soon as I installed a compatible ram, the system boot right away.

    I guess for those who have the same problem as me, might want to check their ram just in case it was not the right specs for the mobo but it still works though sometimes.

    Good luck guys!!
  10. captaincranky

    captaincranky TechSpot Addict Posts: 14,348   +3,583

    The RAM voltage was a problem with the 965 chipset also. Sometimes the board wouldn't POST here also. However, other boards, by other manufacturers, (it was claimed) were able to deal with higher voltage. In one discussion it was suggested that because the G965WHMK board had onboard graphics, that might contribute to the issue. I used "Kingston Value RAM" from the outset, and never had a problem. Many reviews of that board mentioned posting problems. KVR will always post, but it's looked on with disdain by the "enthuiast" faction, since it doesn't overclock well.

    OK, here's what I don't get, the 975 chipset is supposed to be high performance, overclockable, and has a 1066Mhz FSB (or better?). Now, the only RAM I was able to locate that actually ran at 1066Mhz and 1.8 volts was Kingston Value RAM, and the timings are very loose. All the other 1066Mhz RAM I saw, needed about 2.1 volts to acheive that speed. At 1.8 they revert to 800Mhz..

    Anyway, I'm glad you managed to solve your problem, without resorting to "physical violence", such as unsoldering the BIOS chip.
    And I'm also sorry I missed the diagnosis. On the other hand I did say bad RAM, BIOS was your baby! :rolleyes:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...