1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Intel wireless adapter won't detect networks

By Poppa Bear ยท 10 replies
Mar 5, 2012
Post New Reply
  1. I am running Windows 7 64bit retail on an Intel DX58SO2 extreme mobo with i7960 CPU and Corsair SATA3 SSD hard drive, with 12GB KIngston DDR3 1300 RAM.

    The mobo comes with a module that connects to an internal USB header which runs Bluetooth and a WiFi 802.11bgn wireless adapter.

    I had used Bluetooth without problems for some time, but just recently decided to install the WiFi adapter for the first time. It said it had installed successfully, and showed up on Device Manager as working properly. However, it could not detect networks, and in particular, the WiFi external modem/router on my other PC.

    After exhausting all possible solutions, I decided to load a bare bones installation of Windows 7 and it installed and ran perfectly in this environment. And it continued to run OK after all my various programs were loaded.

    However, as a test, I uninstalled it from the fully loaded OS, and then successfully reinstalled it. But once again, it could not detect networks despite Device Manager saying it was working correctly.

    So it seems the only way to get it to work is to load it on Windows before any other programs or updates are added; and never uninstall/reinstall.

    I also had exactly the same experience on my other PC which runs Vista Ultimate OEM. I was using a Belkin N 300 adapter on this OS. It could only be loaded and run successfully on a bare bones installation, but once running, was OK even when all other programs were added.

    Has anyone got any suggestions on how to fix this problem?
  2. jobeard

    jobeard TS Ambassador Posts: 12,812   +1,515

    specifically WHICH wifi device did you use? I've found some are just 'flat difficult' to make work.
  3. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 228   +8

    Originally I bought a Belkin N300 to put in my backroom PC which had Vista running on it. The purpose was to connect to the WiFi router/modem of my main PC which has Windows7.

    I installed it exactly as instructed by the manufacturer using the disc that came with the adapter. That is, run the disc first and install the adpater when prompted. It said it installed successfully, and Device manager said it was running properly, but in practice it could not detect any networks. Network discovery was turned on, and no yellow warning triangles.

    After about an hour of fruitless attemtps to fix the problem, I did a bare bones installation of Vista and installed the adapter on it and it worked perfectly. And it continued to work even after all the various 3rd party software and Windows updates were installed.

    I was curious to see if the problem was an incompatibility issue with Vista, so I installed the Belkin adapter on my main PC which already had Windows7 fully loaded. And then tried to connect with my back-up wireless router/modem on the Vista PC. And I got exactly the same result ... everything green lights, but in practice it could not detect my WiFi modem on Vista, or any other modems in the vicinity.

    So I repeated the process of installing the adapter on a bare bones installation of Win7, and as on Vista, it now worked perfectly. And continued to work when the other applications were installed.

    It then occurred to me there was a WiFi wireless adapter module that came with the motherboard of my Win7 installation. On the Intel installation disc that came with the mobo, It was labelled: WiFi 802.11bgn Wireless Adapter. I installed this adapter on the fully loaded Win7 installation using the Intel mobo installation disc,and it was exactly the same scenario as the Belkin ... that is, all green lights, but not able to detect any networks.

    In like manner, it installed and ran perfectly on a bare bones installation of Win7. And continued to run even after all other applications were loaded.

    In summary, the only way to get it to work was to load it straight after loading Windows and before any other applications were installed. After eveything was loaded, if it was uninstalled and reinstalled it would not run.

    This was true for two different adapters on two separate computers with different operating systems. This makes me suspect the conflict is in a Windows update.
  4. jobeard

    jobeard TS Ambassador Posts: 12,812   +1,515

    It is extremely easy to overlook the mode issues for WiFi b/g/n mode support.

    1) make sure you know the modes supported by your wifi router

    2) your system adaper *MUST* be able to match that mode

    3) there are many cases the N+G should work - - but don't, so coerse the
    router to G-Mode only and then use the WiFi Connection Wizard to access it.
  5. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 228   +8

    The thing is:

    1. If the modes are not supported, then it would never connect to them under any circumstance, but it does on bare bones, and on fully installed installations, provided it is installed before other progams are installed.

    2. Even if the modes are incorrect, it should still display any other networks available, whether it can connect to them or not.

    3. In bare bones installations, both adapters connect to both my D-Link and Thomson modems. And display 4 or 5 other networks in the vicinity.

    The issue seems to be one of detection rather than connection.

    Normally when the adapter is turned on, and the Network adapter icon in the notification area is clicked, the WiFi connection wizard show networks available. The wizard is not showing up at all. Even by going into Network and Sharing Center in Control Panel, and right clicking the adapter icon, and clicking "Connect to a network", the message comes up: "No networks available." Maybe the WiFi connection wizard is not working?

    Previously I had a NetGear adapter, which recently died and caused me to buy the Belkin. On first installing, the NetGear would frequently detect my modem on the other PC, but not connect, even when the correct password was put in. Often a reboot would fix this, or sometimes reinstalling the NetGear software. Usually in the end it would connect.

    I certainly agree with your statement:
    Ain't that the truth! I hate wireless adapters!

    Anyway, thanks for your input. I may just have to live with the workaround of installing adapter on bare bones, and making sure it doesn't get uninstalled after programs are loaded. Cheers Bernie :wave:

    Off topic: Computers are ornery critters! When I first installed Nero 11 Burning ROM on Win7, and tried to burn data on a write only DVD blank disc, it would fail and the disk would become un-useable. I discovered that if I first burnt a wrtie/rewrite data disk, it seemed to switch something on, and I could then successfully burn write only DVDs. if the PC was rebooted it could not burn a write only DVD until I had first burnt a write/rewrite one.

    Quite by accident, I discovered that if I installed RAID Rapid Storage from the Intel mobo installation disc, then the problem with Nero was fixed. I hadn't installed Rapid Storage because I never used RAID and didn't think I needed it. But then I read that Rapid Storage also gives improved performance and reliability with systems using SATA. And hey presto!
  6. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 228   +8

    Update: SOLVED!

    This thread is a bit old, but hope this might help others.

    After many email/online chat exchanges with tech support for Belkin and Intel, I finally found a solution to this ongoing problem.

    This is what I had tried:
    • Downloaded the latest software.
    • Ran the software as Administrator.
    • Had both Avast anti-virus, and Zone Alarm firewall, disabled while installing.
    • Set both Avast and ZA to allow the Belkin adaptor to run after the program was loaded.
    • Tried loading in safe mode but got an error message that Windows installer could not run for this program in safe mode.
    • Tried running it in different compatibility modes.
    • Checked all Belkin settings immediately after it was loaded and working properly on bare bones installation of Windows. And then checked that the settings were the same when I tried to install it after all programs were loaded ... and they were the same. So the settings were not the problem.
    But nothing worked.

    Then it suddenly occurred to me to uninstall all anti-virus and firewall software. So I started with free Zone Alarm, and hey presto, after ZA was uninstalled, both Belkin and Ralink loaded and ran seamless! It would not work when ZA was simply disabled.

    What a relief not having it hanging over your head that the only option to fix either WiFi adaptor if it went astray was to reload Windows from scratch.
    misor likes this.
  7. misor

    misor TS Evangelist Posts: 1,397   +303

    Thanks for providing input in solving your own problem. :)
  8. jobeard

    jobeard TS Ambassador Posts: 12,812   +1,515

    Then this is a USB connection?? There are other threads with issues of USB-Ethernet devices having install issues which seem to be solved by disabling or uninstalling the AV product on the system.
  9. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 228   +8

    Hi Jo, yes it is a standard USB2 socket.

    Cheers PB :)
  10. jobeard

    jobeard TS Ambassador Posts: 12,812   +1,515

    This is one reason I don't like USB-Ethernet connections - - the driver's are frequently problematic.

    An Ethernet connection needs no extra driver and is much easier to manage. Connect the PC to the router via cable and 90% of the time you're done :)

    Sure glad you have it sorted out.
  11. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 228   +8

    Yes I agree Ethernet cable is normally the way I connect. However, I have two PCs in different parts of the house, and a WiFi modem/router on each one, but only one land line. Which means I'm restricted to one wired connection from land line to modem. So if one modem is connected via Ethernet cable to the land line, the other PC can only connect via WiFi wireless adaptor to the WiFi modem in use.

    I have two modems with either as back up if the other fails and I need urgent inet connection.

    The funny thing is, if the backroom DLink modem is wire connected to the land line, and the back room PC is turned off. And the flagship is wirelessly connected to the Dlink modem via the RaLink WiFi wireless adaptor, I get 6MB in 10 seconds.

    Land line > Dlink modem > RaLink adaptor > Flagship via USB = 6 MB in 10 secs

    Land line > Thomson modem > Belkin adaptor > Backroom PC = 6 MB in 12 secs.

    Land line > Modem > Ethernet cable > Either PC = 6 MB in 12 secs.

    So my fastest speed is Dlink modem wire connected to land line, and RaLink WiFi wirelessly connected to it. In effect this means there is no wire connection to the PC. And that is weird, as the ISP techo said the best speed is land line wired to modem, and modem wired to PC.

    The RaLink is a dedicated adaptor that came with the Intel DX58SO2 extreme board, and serves both as a WiFi wireless adaptor and Bluetooth receiver/transmitter.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...