IRQs and DPCs consuming 90% of CPU time

giannisk

Posts: 10   +0
My computer (Compaq Presario 2500, win xp-sp3) experiences some serious speed problems.
It delays at boot time. It takes about 20 - 30 minutes to complete it. Lunching of applications is tedious, sometimes 5-10 minutes, and execution and switching between applications is really slow. Process Explorer indicates that IRQs and DPCs consume up to 90%of cpu time.
At arbitrary times it crushes just freezing or with a screen that says that it has to shutdown because of a serious problem.

Please help me to resolve these problems.
Thank you in advance.
Giannis
 

Zoltan Head

Posts: 245   +27
Assuming you have scanned for malware, I would suggest a system file scan, using "sfc /scannow" &/or "chkdsk" from a command prompt, if no good a repair install of xp, if you can get hold of a disk. Otherwise, might be looking at hardware failure (could try reseating RAM too?)
Hope this helps. :)
 

giannisk

Posts: 10   +0
  • Thread Starter Thread Starter
  • #3
Hi Zoltan,
I can't run sfc since I don't have a xp disk handy. Laptop came with xp installed and a few Recovering Disks that install everything from scratch . I'll try to find an originall xp disk. I'm trying chkdsk. It is very time consuming....
Thank you for your suggestions. I'll come back with the results.
 

giannisk

Posts: 10   +0
  • Thread Starter Thread Starter
  • #4
Well,
digging the internet I found a small utility that cures the problem. http://winhlp.com/node/10.
Anyone interested can download and use this. It seems that it works. At least my old computer is usable again.

Giannis