Issue with USB Hub

By the.ronin · 15 replies
Mar 27, 2008
  1. I am using a Vakoss 7-port 2.0 USB hub using it’s own power.

    I used to run 2 printers, PDA dock, mouse, and an external WD HD through the thing. Everything worked perfectly fine when I used the hub to access these devices from an old Vaio running 1.2 GHz Pentium III-M / 512mb RAM – downgraded at USB 1.0 standard.

    Now I’ve got the hub connected to an HP slimline running at 2.3 GHz Athlon 64 X2 4400+ / 2.0 GB RAM and the computer won’t even recognize a single printer (HP 1020 Laserjet) let alone print. However, when I connect the printer directly to the computer, it works flawlessly.

    For what it’s worth, I am using cheap 2.0 USB cables if that makes any difference. Does it?

    Thanks for any advice.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try this HP drivers post
    This detection is for computer and printer hardware
  3. the.ronin

    the.ronin TS Rookie Topic Starter

    Thank you for the reply, Kimsland. That is a very handy link! However, the correct drivers are installed.

    Unfortunately, I'm now running into the same problem even with the printer connected directly to my computer. I've come across posts suggesting power management issues to the type of USB 2.0 cable to certain printers simply working better at the 1.0 standard.

    Very confused ...
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I think any newish printer would have to be USB2
    So you have detached it then fully uninstalled the printer software (add/remove programs)

    Then restarted
    Then re-attached

    Then run the automatic detection?
  5. the.ronin

    the.ronin TS Rookie Topic Starter

    Yes ... both by way of add/remove programs and via printer/properties removing the driver.

    What gets me is when I plug the printer back to my aging laptop, it works flawlessly. This leads me to believe that when the printer is forced to downgrade to USB 1.0, there are no issues. Could it also be that the USB 2.0 cable I am using is causing problems? It is a very cheap, generic cable.

    Of note, I am also having issues with my Canon Pixma MP210 when I try to scan. Same cheap cable. Both printers are High Speed USB compliant.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    With the same cable?
    I suppose Yes, therefore I don't believe using it on USB 2 will make any difference.

    Still seems like driver issue, maybe not the printer driver, maybe some other hardware driver installed.

    By the way, did you check for hidden devices in Device Manager (view-Show hidden) I'd also check in Safe mode too, for any other drivers mysteriosly showing up.
  7. the.ronin

    the.ronin TS Rookie Topic Starter

    Thanks again Kimsland, for continuing to provide your feedback.

    Yes, same cable.

    I have not checked for any hidden devices - I'll do so once I get home. Of note though, with the Canon printer/scanner, that was installed directly from the prepackaged disc.

    If you have a spare moment, can you walk me through specifically what I should do to "start fresh" on the USB ports? ... in case I overlooked something.


    Ok this is interesting ...

    [I would have posted link to the source but I do not have that privilege yet - sorry.]

    I will pick up a USB 1.1 cable later today just out of curiosity ...

    [edit 2]

    Ok, on the other hand I came across another post (sorry still no linking privilege but I am saving these if anyone wants them) with the *exact* situation as mine and the guy just got a better cable and it works fine.

    So correction - I will be buying a better USB 2.0 cable and seeing how that pans out.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That post (I didn't look up the source, but I'm sure I know anyway!) is stating that the USB Hub made his printer show on his computer as USB 1.1 (I suppose an old hub?)

    This would mean that the driver again was at fault, ie he needed the USB 2 updated drivers (or hardware)

    Now you're going to get a new cable, and say it's working now!! Stranger things have happened. But I still cannot see how the cable can help.
  9. the.ronin

    the.ronin TS Rookie Topic Starter

    Hi Kimsland ... I know it sounds ghetto. I should mention that I've used other USB 2.0 devices such as a WD External HD through the same port and it works fine.

    Let's see if I can link the other post I came across now that I have 5 posts ...

    Ack ... still can't do it. Sorry to spam but I will post a reply after this with the link.
  10. the.ronin

    the.ronin TS Rookie Topic Starter

  11. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    hum; A poor quality USB 2.0 cable would likely degrade the device into USB 1.1 access and thus fail to be treated appropriately as a 2.0 device.

    the adage rings in my ears: "You get what you pay for!" :)
  12. the.ronin

    the.ronin TS Rookie Topic Starter

    Evidently, Jobeard, that may very well be the case.

    I was always of the school of thought that since it is digital, it either works or doesn't. As such, I may have to also reconsider my choice in HDMI cable for the HDTV ...

    I will be sure to report back on the new USB cables.


    In the interim, I have some potentially noobian questions ...

    1) How do I tell in the device manager to make sure my USB ports are 2.0? I've got 4 in the back and 1 in front - I read in another thread that the ports in back are usually 2.0 while others are not.

    2) What are the implications of disabling power management on USB ports? In regards a desktop where power is not dependent on battery, are there any drawbacks at all?
  13. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    Data is moving at such speeds that what looks like a simple set of wires is performing / reacting as if radio frequency radiation rules apply and
    impedance, standing waves, reflection, cross talk effects become significant
    this is a faux pas on case makers -- with usb 1 and 2 slots lloking alike and accepting the same connectors, imo, the USB 2.0 slots should have been marked or colored differently for just this reason. the device manager will show USB 2.0 devices as USB 2.0 Enhanced Host Controller -- finding the slot(s) is a matter of trial and error.
    HUM; one might disable a device and get that effect. the result would be obvious;
    non-operational devices when attached.
  14. the.ronin

    the.ronin TS Rookie Topic Starter

    Well gentlemen ... just got home and tried out some Belkin "Gold Series" 2.0 USB cables (6 ft) ... both the HP 1020 and Canon MP210 work without a hitch. Even have them running through the USB hub to save some space. What kills me is that these cables were no more than $5 more than the cheapie cables that were giving me so much trouble.

    It's final - not all USB cables are indeed made equal.

    Thanks again for all your help guys.
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thank-you the.ronin for the update,

    Since receiving your link I went checking all over the place, and now agree that the cable could have been the number one choice (now confirmed)

    USB 1.0 data rates of 1.5 Mbit/s (Low-Speed) and 12 Mbit/s (Full-Speed).

    USB 2.0 Added higher maximum speed of 480 Mbit/s

    USB 3.0 reaching roughly 4.8 Gbit/s by utilizing two additional high-speed differential pairs for "Superspeed" mode, and with the possibility for optical interconnect.

    There are also connector and manufacture differences (to top it off)
  16. the.ronin

    the.ronin TS Rookie Topic Starter

    No, the thanks goes to you guys for the taking the time to try and help me out.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...