I've a major problem using uTorrent...help??

By torrenter ยท 14 replies
Jul 17, 2007
  1. I'm really stuck guys. I hope you can help. I've been trying to download data using a specific torrent and there's quite unusual behaviour.

    I've recently restored my PC to factory-shipped condition and am using the same version of my bT client and same Firewall as before. Namely, I'm using uTorrent v1.6.474, using the latest version of ZoneAlarm basic Firewall and using Kaspersky Basic Anti-virus.

    In fact, the problem I have is not limited to this specific torrent, but a few others. However, it does not apply to every torrent I use.
    When using utorrent, I notice that a lot of peers' IP addresses are "209.(rest of ip address).available.above.net" and all say are using Azureus v2306?

    I tried to find out what could be causing this. The Client, the Firewall or Antivirus, or maybe just the torrent.

    Using utorrent and my LinkSys router, my chosen port is forwarded properly. I've a green tick, 250+ nodes and good speeds. My ISP Engineer has even been around and there's a lot of power back now, to the cable modem. So definately no problems there.

    If I turn off Kaspersky Antivirus, or keep it on it doesn't affect anything, so I'm ruling out Kaspersky.

    With ZoneAlarm and setting up utorrent I'd allowed it to do what it wanted. The program said it was acting like a server, I said yes to it. There are 4 ticks with this program under "Program Control" (Access - Trusted, Internet and Server - Trusted, Internet) So, it should work fine. With an old version of ZoneAlarm this worked fine.

    However, if I have it on, the specific torrent starts up fine, gets to high speeds, lots of connections but then dies slowly, disconnecting from people. But ZoneAlarm doesn't report any intrusions.

    With utorrent then turned off, the reports of intrusions in "Log Viewer" goes flying up high, all saying there are incoming packets to my chosen port being blocked! This is annoying because I cannot find anywhere in ZoneAlarm to say that that port can be used by utorrent.

    So my thinking is well it should work if we disable ZoneAlarm. I do that, re-run utorrent and start the torrent again. And this time the speeds go up a little to begin with and die even quicker.

    I then configure ZoneAlarm to not start at startup. I turn off the PC, turn it on again without ZoneAlarm running, and run a different torrent.
    At this point, the speeds are very healthy, most IP addresses are different but still a handful seem to be "209.(rest of ip address).available.above.net" and using Azureus v2306.

    If I then run the original torrent now, practically all IP addresses are "209.(rest of ip address).available.above.net" and are using Azureus v2306. The speeds are rubbish and again eventually die.

    I then run the other torrent and that's fine.

    After this I turn on ZoneAlarm, and turn off utorrent. ZoneAlarm says it's stopping incoming packets to my chosen port. But I'm not running utorrent! It's driving me mad:( Does anyone know where the problem lies? I can't figure it out for the life of me.

    Thanks for any help. This is definately one of the most strange problems I've had using a PC.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Switch your torrent client to one like Azureus, its a better client all round.

  3. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Unfortunately, this doesn't really help.
  4. halo71

    halo71 TS Rookie Posts: 1,090

    I am not sure exactly why you are having these issues. But posting the same question 3 different times with 3 different titles is not going to get you anywhere fast either.
  5. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    I get you. It's just that last time I made a thread all I got from one guy said "This is how should make a thread" Instead of trying to give a possible angle on the problem. It wasn't like I'd put "1867&*^%&" in the title line:D I simply asked for help.

    But back to this problem, if you can help me. There was an optional Windows Update (KB920342), which I hadn't originally installed on purpose. It said it was important for Peer to Peer apps in terms of resolving, publishing peer names. I was a bit concerned that Microsoft might actually be trying to halt p2p activities, and so did not install it. However, now I have installed it. What do I have to lose I thought. And guess what? It still doesn't make the slightest difference.

    My PC right now is completely up to date with Microsoft Updates, 135 in all since restoring back to factory condition 5 days ago. My broadband and router are both set fine. utorrent worked fine before restoring my PC, but I probably wasn't up to date as I didn't install the Windows Genuine Advantage Tool, even though mine is. Now I know that it gives you access to more updates.

    ZoneAlarm allowed utorrent to work fine before aswell.

    Now, even though utorrent is given full access by ZoneAlarm, when utorrent is turned OFF, ZoneAlarm says it's stopping incoming packets. That doesn't make sense.
    The only thing that has changed from before is that I've installed a huge bunch of updates from Microsoft. If the problem lies there, how I can I feasibly find the culprit?

    There's got to be a more reasonable, logical explanation. Any ideas friend?
  6. halo71

    halo71 TS Rookie Posts: 1,090

    I am not sure, but I am sure its not from lack of updates! I recently started using an old Compaq laptop to run torrents, switched from using my Vista laptop. And it runs them just fine with no MS updates whatsoever. Are you positive that your port is forwarded correctly? Have you by chance pressed the reset button on the back of your router?

    EDIT: Where are you getting your torrents from?
  7. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    My fear is that an MS Update could be causing the problem, but I can't trial every update to see if utorrent works fine after installing it:p I'm using a Presario funnily enough.

    I'm pretty sure my port is forwarded correctly. The Speed Guide/Port Checker in utorrent reports my chosen port as being open. On my LinkSys router page, I've allowed data through this port to my static IP address.

    I've followed all instructions at http://www.portforward.com/english/routers/port_forwarding/Linksys/WRT54G/Utorrent.htm

    It is my router. I could unplug and plug my router back in, but I've probably already done this loads of times:D

    What's really bugging me though is whether "209.(rest of ip address).available.above.net" is really an IP address. All these peers reported in utorrent seem to use Azureus v2306.

    If the client or even client version number (version of Azureus) is different the IP address certainly doesn't end ".available.above.net". Also, when I once ran Peer Guardian, it goes crazy seeing ".above.net"

    IP addresses ending ".available.above.net" do seem to appear on certain torrents more than others, and these IP addresses do not send much data back at all!

    I have faith in the release though, because the releaser is usually solid.
    But ZoneAlarm is very strange. If I turn utorrent off after running a torrent, ZoneAlarm says its stopping incoming packets to the port.

    I get my torrents from a very reliable site. (Demons involved, wink wink)
  8. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    I also find the multiple threads distracting. You give more information than many and that's OK, but why x3? And does on have subject about the utorrents and the other, same problem, but now it's a Zone Alarm problem!

    Please read this section in the referenced site:
    The two most common mistakes made by BitTorrent newbies are not forwarding ports and not seeding torrents.:

    You may be way past the 'beginner' user, but the port forwarding section may help you with ZA.
  9. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    There are several firewalls that might be used other than ZoneAlarm. If it
    says it is blocking, then believe it and resolve the issue OR move to a firewall
    that is controllable -- COMODO would be my recommendation.

    Logged events contains details to help you determine the reason for the block
    and/or the rule you have set that is causing the block.

    My sole caution would be to disable the Component Monitoring feature --
    overly complex and unnecessary with the other three levels enabled.
  10. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    Ok people, I really do apologise in making multiple threads on really the same problem, but coming here has always been my last option. Let's stick to this thread. How can I delete the others?? I was just trying to catch someone's attention and was banking that not everyone looks at the older posts. I wouldn't want to waste anyone's time. It is however, a frustrating problem, more so than any other I've had on a PC. I thought I've come a long way, but now trusted programs are doing a u-turn? I guess I'm just waiting for someone to say, you've just missed a little detail there and bingo, I'm back running again.

    jobeard -

    "My sole caution would be to disable the Component Monitoring feature - overly complex and unnecessary with the other three levels enabled."

    What do you mean ? Could you explain a little more please?
  11. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    it's a configuration issue on that firewall (which I like and use).
    Let's table that for a different thread and stick on this issue vs your ZoneAlarm
  12. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

    So, jobeard, I should stick to this thread then? I'm just not sure where to go from here. There's definately something up with my firewall. Somehow ZoneAlarm is still blocking packets to my chosen port. It just never did this in the past. So unless I can tweak the program, I guess I'm stuck. I guess I'm going to have to look here: http://forum.zonelabs.org/ If these guys don't know, then who knows, right?:D
  13. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    stick here on this symptom + this firewall. if you elect to move to COMODO,
    then we'll go to a new thread for COMODO config issues.
  14. torrenter

    torrenter TS Rookie Topic Starter Posts: 166

  15. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    interesting, I use a website for torrents and azureus, I have sent that link there for people to discuss,

    It had to happen though one day,

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...