Joystick looses calibration after a while.

By running · 6 replies
Mar 9, 2003
  1. Hello gang!

    Yeah, that’s my problem. I’ve done a lot of maneuvering and reinstalling in order to keep the IRQs separated. The last time I had to change the sound card to a slot that didn’t have a shared IRQ in it. Everything was working o.k. (save the joystick), but I wanted to try it. To make a long story short, everything in this computer is running fine, and no stability problems at all, since I don’t overclock. It’s only that the USB joystick looses calibration after playing for a while. I reboot and everything it’s alright, then history repeats itself. I read something about “drifting” and values being too high for the CPU to read right. Whatever. Everything has the latest drivers (AFAIK), and like I said, I can be recording in Cubase 5.1 for hours and no stability problems whatsoever. Just for fun I tried a gameport joystick and it always stays right-on (aside from the initial calibration tweaking) even if I play for forty minutes.

    This happens in all my games: Motocross Madness 2, F/A-18, Falcon 4, Superbike 2001, Il-2 Sturmovik…dead zone and all doesn’t work, since the problem only starts after a few minutes (with USB).

    I’m not sure if tweaking will make a difference since I read here that USB requires so much computing power to not take a toll with games. If anyone has any ideas (or if it has been addressed already in another thread), please let me know.

    My specs for any reference:

    Athlon 1.2
    Jetway 663AS Ultra rev. 3.2
    768 RAM PC133 (taken care of with the Min and MaxFileCache settings)
    Logitech Wingman Attack 2
    Leadtek Geforce 2 GTS
    250W Power Supply
    SoundBlaster Live! 5.1 Platinum
    And some PCI controller I bought yesterday to see if there was something wrong with the onboard USB. The USB joystick behaved in exactly the same way, which means I’m back to where I started.

    Thanks for your time.
  2. running

    running TS Enthusiast Topic Starter Posts: 70

    I forgot the picture of the IRQs.

    Attached Files:

    • irq.jpg
      File size:
      46.2 KB
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    My initial feeling is that it is not a USB problem, but a controller problem. Try your controller another system using the same drivers.. Does it work properly? If not, then your joystick is obviously to blame.

    USB CPU usage is neglegable and from my experiences, I've never had or heard of a USB controller losing sync but keeping sync on a game port.

    I'm sure there are gameport to USB adapaters.. You might want to invest in one (If it doesn't work, take it back). You can probably find one at a local RadioShack or other gadget retailer.
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    And sharing IRQs is not uncomon since the introduction of ACPI. It does have its problems from time to time, but sharing IRQs is *usually* harmless.
  5. running

    running TS Enthusiast Topic Starter Posts: 70

    Hey Rick, thanks for replying. Since it's a relatively new joystick (and it works absolutely fine for the first minutes) never occurred to me that it could be the problem, but I'll try it on another machine.
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    I was reluctant to say this earlier because I really have no idea how the computers actually handle USB devices.... But you said it works fine after a reboot. And it happens on any USB plug. So since USB is hot-swappable, what happens if you unplug it and plug it back in? Change slots or keep it the same, but changing slots might force the OS to realize there is something "new" in a slot.
  7. running

    running TS Enthusiast Topic Starter Posts: 70

    Thanks to both of you for posting, and it was the joystick. I tried the suggestion of hot-swapping, but to no effect; the calibration remained crazy. I opened the joystick (hopefully nobody from Logitech reads this –so much for the warranty) because I wanted to get to the bottom of the problem, and it was really interesting. There are five screws that do absolutely nothing, except mislead you –o.k, they look cool :cool:. After nearly breaking the stupid thing :mad: I saw that their axis implementation is rather ingenious, but by the looks of it I’m 99% sure that they’re using potentiometers. I mean, my joystick costs 25 Euros, but potentiometers are like the meanest, most despicable cheap components that you can use :(. I switched the potentiometer from the Z-axis to the Y-axis, which was giving me trouble, and now it works like when I first bought. Of course, now the Z-axis doesn’t respond so well :rolleyes:, but I hardly use it anyway for throttle controls. Go figure…

    I really appreciate you guys trying to help (which you did), and I would like to know, which joysticks record axis movement using optical sensors? I get the feeling that they are using potentiometers so they get broken after a while :blackeye: and we have to buy new ones ;) Is force-feedback also potentiometer-controlled?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...