Keyboard / Mouse Keyboard reports error on boot, but works in BIOS and DOS, but not in Windows/Linux

Not open for further replies.
I have an Asus L2000B Laptop, and one day a friend was using it and found unconfortable to use the touchpad, and asked me if he could use one of the mice os another computer in the room, i said sure, why not?

Well, it was a ps2 mouse and he hot-pluged it!!! :S

Result: the laptop´s keyboard stoped working and so did that ps2 port and also the sole serial port :(, but not the touchpad.

Restarting, cleaning the plug and all that did not work.

Now when I boot, i get a 'no keybord present/keyboard error' at startup, however, it works fine in the BIOS and in DOS!?!

When Windows boots it lights Num Lock, Caps Lock, Scroll Lock an the keyboard no longer works

In Linux, No lights go on, but it doesn't wor either.

I'm certain that there is damage to the Serial ports/ PS2 ports chip but it's not all busted and probably just ignores any command and just gives outputs.

Now, I've been using a USB keyboard to 'make do' but its very annoying an not very portable.

Replacing the MoBo is out of the question as it costs more than the PC is worth.

I seek a way around the windows drivers, a simpler less demanding driver!
  • Thread Starter Thread Starter
  • #3
Tried that :(

Thanks for replying!
I have tried all sorts of testers including that one! None detect a single keystroke!
I believe Windows asks the keyboard for a reply and it must not be giving one and isn't initialized.
DOS must not ask anything and just waits for something to be spit out.
The only solution I can see is a driver for windows that behaves like DOS and not make the keyboard any questions nor wait for acknowledgement signals...
Not open for further replies.